Netatmo outdoor camera not working

I’ve been using the netatmo outdoor camera for a while now, but since I start using Nabu Casa the camera stream doesn’t load anymore. I can turn the light on and off.

I tried to use the configuration.yaml method and the nabu casa way, but they both don’t load the stream.


Hi !
I’m not sure tagging directly anyone will help. Maybe trying to collect logs, giving informations on your setup would be a better way to find help.

Edit : see How to help us help you - or How to ask a good question

1 Like

This is not a general issue and your camera seems to be detected since your lights are working. Do you have Unify APs by chance? What kind of set up do you use? Do you have custom components/HACS integrations in use?

Wasn’t sure if I should open up a separate thread or use an existing, with issues setting up the Netatmo Outdoor Camera.

I was using it successfully the last couple of month, but somehow the events stopped coming and the camera picture was unavailable for the last couple days, so I decided to set it up again. I have removed the integration from home assistant. My configuration.yaml has the following entry:

  client_id: !secret NETATMO_CLIENT_ID
  client_secret: !secret NETATMO_CLIENT_SECRET

I have checked the secrets and compared them to the entries in Netatmo Dev Apps to ensure they align and the webhook is still active.

Seting the Netatmo Camera up using the Cloud Links works and brings the camera entity, but no access to the netatmo_events. So I was trying to set it up using the configuration.yaml. Doing so I receive the following issue:

Missing code or state parameter in http://*INTERNAL_HA_IP_ADDRESS_HERE*:8123/auth/external/callback?error=redirect_uri_mismatch&state=*LONG_CODE_HERE*

Any advise? Can I provide more information?
I appreciate any support offered. Thank you all.

Setting up using the configuration.yaml is the way to go for webhook events. Yo have to expose your instance on port 443 or use the HA cloud remote service by Nabu Casa.

Yes, the port should be forwarded and as said the integration did work beforehand.
What is the error message telling me?
Can I specifically check for that port?
I am not connected to Nabu Casa, access to my home assistant instance from away is working fine.

Double check if your external url is set appropriately.

Tried the setup using the mobile devices Webbrowser… Worked without issues. Everything seems to be resolved. The camera entity is back and events coming in. Thank you anyways for your time.

1 Like