Netdisco / netifaces issue on Synology NAS

Hi, I have HA installed on Synology, and I am unable to install Discovery, Wemo or Cast… After some tracing forum searches, manual attempts, etc it all seems to boil down to the (known) issue with netdisco/netifaces dependency…
I have seen a lot of post on the issues, most of them addressed by fabaff pointing to the need to install the python compiler…
What I cannot find is instructions on how to do that on Synology in particular (the commands shown in docs seem to be for other platforms -> (eg. sudo apt-get install python3-dev or sudo dnf -y install python3-devel)

Can somebody confirm this is indeed what I need to do , and how to do it on Synology (DSM6)?


Open a shell to your NAS and try something like this if ipkg is available:

# ipkg install gcc

Depending on the platform you could need python3-devel as well. Sorry, the package names here are from Fedora. They could be different on Synology.

I’m facing the same issue on my NAS Synology (DSM 6.1)
I have tried different ways to install netdisco and netifaces packages but all of them failed
@Esteban_Traid did you finally manage these dependencies ?

Yes, In the end I solved it following (loosely) the process outlined by molano here:

It involves installing Debian Chroot on the Synology, installing the dependencies there and then copying to the main DSM environment… Waaay beyond my technical paygrade, but it worked in the end…

One note… dependencies break again every time you upgrade HA to a new version, but at that point I was able to manually upgrade each one via pip directly from them DSM environment… something like

$ /volume1/@appstore/py3k/usr/local/bin/python3 -m pip install --upgrade netdisco

Hope it helps…

Thanks for your reply it worked

Hello Esteban,
How do you handle the vi or vim part?
I’m trying to do it inside putty but it’s tricky.

Edit : I managed to do the vi part in putty, here is some help for future readers :

vi editor commands in PuTTY.
Cursor Movement:
h = move the cursor to the left
j = move the cursor down 1 line
l = move the cursor right
i = insert before (new text will appear before the current cursor position) — leaves you in insert mode
ESC = leave insert mode
x = delete the character under the cursor
Saving :
ZZ = write the data to the current file and then exit vi

After that I have some parts of the process not working :

  • I have a colored screen asking for a kernel update :
    “Kernel must be upgraded This version of the GNU libc requires kernel version 3.2 or later. Please upgrade your kernel before installing glibc.”
  • pip doesn’t install so I can’t use it.

Maybe is it possible to have the files we move at the end of the process in a zip to download, unzip it in a public folder on the NAS then move them at the right place with SSH ?
and if it works add this on the tutorial page :