New Skyconnect not working in Proxmox

VirtualBox. Could it be the culprit? Forgot to mention, but it always shows as SkyConnect under device manager in Windows.

I just received a SkyConnect from AmeriDroid and am having the same issue.
The hardware tab reports
This looks like the improper USB setting. I’ll try the fix posted to see if that fixed it.
You’d think they’d have fixed the stock by now.

That fixed it. Thanks for posting this.
Funny, I had the exact same serial number on the box listed above.

Very similar setup to you. Did you ever find a more elegant workaround? Moving from VirtualBox to ProxMox is not an option as need the host to be windows. However every restart of host, virtualbox fails to pickup the SkyConnect and have to play unplugging, resetting, adding USB into virtualbox and cross fingers

1 Like

For reference, unique whitelisted USB product identifier need to be written to USB chip EEPROM, see:

Just received a new/rebranded Home Assistant Connect ZBT-1 (June '24) and had this issue where it was not being recognized in HAOS. This fixed it for me. Thanks for the post.

I also just bought a sky connect stick, the label on the box says 242303.

I’m running Proxmox VE 8.2.4 and HAOS in a vm.

In the ssh terminal inside HA the command ls -l /dev/serial/by-id/ gives me this entry:

So HA recognizes the stick correctly, but it doesn’t show it under “Hardware”, where I want to activate the multiprotocol option.
I “Devices” where I can configure the stick I only have the option between either Zigbee or Thread.

How can I use both?