NGROK and Hass.io

that message is displayed when your agent is not connected, quite weird that you see in the logs that it’s connected or you are trying to access wrong subdomain (more likely). Can you check https://my.webhookrelay.com/tunnels whether your public URL is actually the one that you are trying to use?

I have also enabled HTTPS for your account.

Regarding add-on, got initial version working but thought I will go all-in and make it automatically configure tunnels and webhook endpoints as well, so from the web UI users will only need to get access token.

I was trying to access the subdomain that was auto generated for me. I didn’t have the option to create my own. I’m just clicking on the link provided.

When I login to my account on webhookrelay.com, go to tunnels, there is a link under “Host” the only tunnel I have. Is that the link i should be going to? Or do I use what is in the “Name” field with .webrelay.io?

If I go to the link under Host, I’m prompted for username/password. I input both and after a couple of seconds I am prompted again for username/password.
If I go to the whats listed under “name” with werelay.io I get “relay agent not connected or misconfigured”

“host” should be the one, set tunnel authentication to “none” as your HA already has authentication.

That worked. Thank You

A bit of old topic but I was hoping someone here can help me.
I’ve finally managed to setup https outside but it’s not complete:

  1. I got ngrok pro to enable tls tunnel and reserved name with ngrok
  2. ssh’ed into hassio instance via ssh addon
  3. downloaded ngrok, authenticated with a key and run to proxy 8123 on the local ip address to my reserved domain
    ./ngrok tls 192.168.x.x:443 -subdomain=xxxx.xxx -region=au
  4. all works using ngrok certificates

Now what I’m trying to change is to use my own cert generated by letsencrypt. I feel to do that I may need to use 443 port specifically? I’ve tried setting server_port to 443 in the config and got ‘This client does not support TLS SNI. See https://ngrok.com/docs#compatibility
My understanding SNI is not supported by hassio?

I’m all new to this. Anyone had success setting this up?
Also on a similar note, any way to keep ngrok install persistent?
(hassio is just running off RPi)

Thanks!

This is Just to make you know that I developed a custom-component (I’m still testing it) to embed ngrok in HA/Hassio. If you can help me to test it here it would be appreciated.

Regards,
Vincenzo

1 Like

Hello Vincenzo, I’m having trouble in setting up the ngrok add-on you’ve provided.
I’m behind a carrier grade nat, and couldn’t make the duckdns acess work, so keep searching and found the Ngrok option.

I’ve followed the steps on your git page: created a new folder on config (custom_components/ngrok) and saved the .py file on it, made the changes on config file, set the !secret info on the secret file, but the process does not seem to run. Does not show as a State.
Thanks

I’ll try it today!Let you know

Ok some simple questions for a beginner like me.

I have only the ssh shell access to my hassio, i have managed to create the directory /config/custom_components/ngrok how do i copy the .pi file?

Sorry if the question is so odd.

Thanks

wget https://raw.githubusercontent.com/vincenzosuraci/hassio_ngrok/master/__init__.py

Ok installed and configured it work perfect in http normal.

Sorry i can sonly make 3 replies so i have to modify me response.

1-Https problem: how do i create a certificate , which would be my domain to put in “let’s encrypt”?

2- I have tried without certificate i can reach my hassio but i think the bugs of ngrok comes out, after username & password i get “unable to connect retry” and gives back username and password, and loops like this.

Since my first try was only in http mode , i commeted the configuration and tried out my shell. I reached the http as before, then i configured back the https (certificate problem aside) but i didn’t reach my raspberry both with “http” or “tcp” option so your solution is a step forward but in https , for me, doesn’t end to manage my hassio.
What type of string do you run in https configuration?

3-after i try telegram, the automation doesn’t workout.

4-use a simply mail notification for the new url?

Hello,

i have this errors in the log

Error while executing automation automation.ngrok_public_url. Service not found for call_service at pos 1: (ServiceNotFound(…), ‘Service notify.telegram not found’)
10:19 helpers/script.py (ERROR)

<urlopen error [Errno 111] Connection refused>
10:18 custom_components/ngrok/init.py (ERROR)

Hello anyone still using ngrok? I had it working great, each time I rebooted I would get a text via telegram with the new link. A couple of weeks back I noticed it rebooted and I didn’t get the telegram. Didn’t pay much attention.

I’ve done two or three updates to HA, so now I don’t have a backup of when it was still working properly. Today I noticed that if I roll back to 110.5 my chromecast integration works fine, but if I update to 111.3 the chromecast stops working.

I am guessing it is similar with the Ngrok, that after some update it stopped working. However I can’t seem to find any updated posts about people having issues like mine

I’m working with Home Assistant and CG-NAT in my Internet connectionand I’d like to connect it remotely.
Anyone still using ngrok … or any free alternative?

Yes. I am still using free Ngrok via this add-on created by @ThePicklenat0r. You can find about the add-on here.

The only downside is that the URL will change if you restart the add-on or reboot Home Assistant Host. However, this problem can be easily solved by setting up rest sensor and by setting up notification via Telegram if the URL changes. You can find more about the rest sensor in this Github page.

Thank you @ardysusilo for your help.

Now, I’m using ZeroTile. It’s free (for personal use) and there is not any problem with the reboot of HA, for example.

https://www.pcdemano.com/revisiones/16695/

ZeroTier? I have also set it up in my production HA just as a backup in case something went wrong with Ngrok.

However, in my case (based on my location and ISP), using Ngrok is much much faster than ZeroTier. In addition, I don’t need to enable/disable connection to the ZeroTier VPN on my phone whenever I want to use it or not.

As a bonus, Google Assistant Integration is also possible using Ngrok free plan.

You may want to consider Ngrok if you have any kinds of trouble with ZeroTier.

Hi @ardysusilo again

I don’t have any problem with ZeroTier (yet) but I’d like to try with “your Ngrok”… but I doesn’t work with my HomeAssistant.

I’m using HA as a docker trying to use this one custom component

… but my HA doesn’t recognize the ngrok component.

I’ve create a new folder in custom componets and copied the init.py file, reboot and modified the configuration.yaml … but it doesn’t recognize the ngrok component :(.

Hello. The post I made earlier works if you are using Home Assistant OS/Supervised - because it is using addons installation.

If you are trying to expose a local container using Ngrok, you may try to follow this guide-

Regarding custom_component made by vicenzosuraci, I read that it has stopped working since last year.