NIBE Uplink API component (non S-series)

I also have updated both the VVM and the F2120 to the latest software.
That did not make a change for reporting back this fan rpm value.

@faanskit what did you do :smirk: - I’m stuck at the exact same problem you describe above, I’m just missing the good night sleep, but still find it pretty annoying that Nibe Uplink isn’t shown in the Integration panel.

@ibmchas , I just waited. Sure, a bunch of restarts and then I gave up. In the morning, it was simply there to install under Integrations.
I do not think this is an issue with this particular integration, I think this is a recent HA behavior and possibly a bug. I did notice the same problem with a completely different integration some time back - and I simply gave up.
Please leave your system to rest a few days and hope for something to happen.
Sorry for not being able to support better.

@faanskit right, I found you that you need to restart HA, I think @elupus also mention this somewhere, at least that enabled the integration option, but I ran into other issues, I don’t have/get any system ID, it comes out empty - properly because I don’t have any units registered - this is might be due to the fact that Nibe seems to have two registration options, my unit is registered on myUpway and not myUplink - I discovered this when generating a new token on my unit and it made a reference to myupway.com and not myuplink :frowning: I wonder what the difference is ? I properly need to look into other integration options :frowning:

Hello Alessandro,
I get the consumed power as follows:
sensor.nibe_43988_44308 gives the energy vs time consumed for heating in KWh.
If you take the time derivative you get the actual power in KW.
You need ‘platform: derivative’.

For hot water production you do de same with:
sensor.nibe_43988_44306.
And so on for cooling.

I hope this will help you.

Regards, Tim.

Hello Alessandro,
I get the produced power as follows:
You have to install a flow sensor Nibe EMK300.
The result is given by sensor.nibe_43988_40072

And you need the temperature difference between the in and outcoming flow of the heatpump.
sensor.nibe_43988_44058 and sensor.nibe_43988_44055 resp.
And a small calculation gives you the produced power of the heatpump.
And now you can also calculate the efficiency of the heatpump.

Bye, Tim.

hey Tim,
thank you very much for this, but i could not find this sensor (44308)
how can i see them?
thank you again

I’ve had contact with nibe about this RPM value no longer showing up.
They said there was a logging problem with their system, and they have decided to remove this value from the API.
Anybody else seen this?

Also the injection sensor in the api is gone.

so this is removed:
sensor.nibe_XXXXXXX_41002 (RPM)
sensor.nibe_XXXXXXX_41164 (injection temperature)

Anyone that has been able to turn pool heating on/off and change temperature of pool?

Did you solve this? I also would like to control my pool

Well, not with this component or the official API. But it is possible to achieve pool heating control by extracting the key from the mobile app and using the app API. I don’t have anything possible to share though. Sorry about that. I might look into making something better when the pool season starts again.

@x-erik Erik, do you have an example of your config for reading 2166? I’m unable to access it but it might be that additional HW is needed in my setup? I have a VVM S320. It shows consumed kWh on the display as a widget but that registry address seems to be unreadable for me (most others do work).

//Daniel

Hi,

Have you checked hos close this value in to the actual power usage?

Does anyone know if it is possible to set the ‘holiday mode’ parameter using the API?

I think so. But there is no entity for it right now. The set_smarthome_mode service should be able to set it to holiday.

oh, ok great! Will experiment later

Looks to be working using the values

system: xxx_systemID_xxxx
mode: AWAY_FROM_HOME

Thanks!

If the Nibe Uplink Heat Pump integration doesn’t show up in the list after HACS install, it is because of the cache. If one right click on the integration page and press reload, it will appear in the list of integrations.

Just tried this home assistant for the first time. Installed it to Windows 11 hyper-V with the instructions on getting started page. Then managed to get this Nibe uplink integration installed and also the fmi Weather & sensor integration. And got both working nicely during weekend, Nibe uplink against my heat pump and FMI to have hourly weather forecast at my location. Very promising. But then I failed to find examples which would do some real actions on Nibe. I have smart price adoption on Nibe and have set it’s priority to maximum (10) to schedule heating (and max also to warm water). Now on sunny afternoons it may heat the radiators as outside temp is ~5C but sun warms the living room to 25C … Should look at the forecast and cancel the cheap price advance heating in such a case. So, I’d want to block compressor and additional heat if weather forecast in 1,2,3,4 hours from now is sunny and temperature is >10C. But I wasn’t able to create such an automation in there. Would you or someone comment if that is possible ? Another way might be to increase the “heating factor” for climate1 in such a scenario but I failed to find those as writable parameters…