No integrations tab in Configurations

Firstly i am a noob.
So i just installed HA docker version on my qnap. I was trying to add some integrations and it usually says: Go to configuration → integrations → add integration. And here i notice that i don’t have Integrations tab at all:


I fought: this is fine, probably because of docker and NAS (is it?).
So i tried adding manually in configuration.yaml file (some integrations have this instead of “Go to configuration → integrations → add integration”). i added something like this:

  - platform: xiaomi_miio
    name: Xiaomi Airmonitor
    token: xxxxx

After checking configuration i got this error:

Testing configuration at /config
ERROR:homeassistant.util.yaml:YAML file /config/configuration.yaml contains duplicate 
key "sensor". Check lines 58 and 72.
Failed config
  General Errors: 
    - Platform not found: sensor.xiaomi_miio

So my questions:

  • Why no Integration tab in Configuration in web UI?
  • Why manually adding in .yaml not working also?

To answer you 2nd question: when the integration must be added via configuration-integrations, for most of the integrations configuration via the configuration.yaml file has been disabled.

1 Like

Well, i also tried something that is supposed to be added via .yaml, for example Android TV. So i added:

  - platform: androidtv
    name: Android TV

And same error:

Configuration invalid
Testing configuration at /config Failed config General Errors: - Platform not found: media_player.androidtv Successful config (partial)

When you installed HA, did you follow the process as described here? Alternative - Home Assistant
Browse down for QNAP NAS.

So i did the network settings and folder settings:


But i am not sure what "mount point has to be /config " means

I’m not sure either, I don’t have a QNAP NAS (anymore). Can you look at the path /share/Container/Home Assistant?
Do you see a subfolder named config there? Like /share/Container/Home Assistant/config?

Another thought, maybe use a path like /share/Container/Home_Assistant
A space in a directory name doesn’t always work.

The folder wasn’t created automatically when i did 1st install. So i thought i need to create it in advance, i deleted everything, created this folder inside installation folder and reinstall. Basically - no difference. By the way, the folder is empty…


Did you see this: Installing Home Assistant on a QNAP NAS using the CLI and Docker Compose

Here this is mentioned:

  • Everything before :/config specifies the location on your NAS where data should be stored. Since we created a Shared Folder above you would expect that path to be /share/docker/home_assistant. But it’s not quite that simple with QNAP. You need to include CACHEDEV*x*_DATA in the path where *x* is a number. Most likely it is a 1 but it could be a 2 or even a 6 depending on how many CACHEDEV*x*_DATA folders your machine has.

On your main page, in the lower left corner, is your User Profile. Go to it and turn on “Advanced Mode”. That should turn on the Configuration Tab.

it is not…


Try going into the Configuration page and creating a User for yourself with admin rights and log in using that new account.

it looks like instruction for manual install via command line, i did automatic install. so no need to manually select correct file path

Yes, but your path might be missing the CACHEDEVx_DATA-part, that’s what I’m trying to tell you.

Anyway, hopefully someone with a QNAP NAS can help you better than I can, good luck!

Well, i was selecting the path from drop down menu, so i chose the path which QNAP gave me…

there is no such setting in Configuration page, only create Cloud account

At this point me thinks you either have a corrupted or very outdated install file or something went terribly wrong on your install. I suggest you go to Installation - Home Assistant and start over.

Thank you everyone for trying to help!
i found the problem: the version which was downloading automatically from Qnap container station is like very old from 2018:



this is very strange and counterintuitive…
when i figured it out i did “image pull” in container station menu and downloaded late version of HA from docker repository (i think), after that i just created container out of it.
everything is working now!