No Shelly connections after 2024.3.0 HA upgrade

Hello all,
after the HA upgrade my Shelly integration disconnected my three Shelly1 devices (gen1) and won’t let me connect them anymore. I also tried deleting the integration and then installing it again, but nothing changed. The three devices have the latest firmware installed, have a fixed IP and work well without problems with the Shelly app. Can someone help me?
Thanks in advance.

My Shelly 1PM is still working as expected.

Did you set up CoIoT unicast on the devices?

Yes, enabled CoIoT and port 5683. Now I have uninstalled all Shelly devices, but if I try to reinstall one, the Shelly integration replies “Unable to connect”. Yet everything on the network works, the router sees the Shelly1 devices and the app on IOS works perfectly. I noticed that the firmware version installed on the three devices is the
20230913-112003/v1.14.0. It might seem a little old, but there are no others after this one. Could it be a port problem with the new version of HA?

I forgot to mention that before installing 2024.3.0 my previous HA version was 2023.6.3 .

Ok that’s a big jump.

Look in Settings → System → Logs for relevant errors.

I took a look at the log, but there is no reference to Shelly, to one of the IP or Host Names of the Shelly devices. However, I remind you that the Shelly integration is not currently installed as there are no devices mounted. I was thinking of downgrading to my previous version of HA (2023.6.3) and then proceeding by sequentially installing 2024.1.6, 2023.2.5 and 2023.3.0 and attempting to reinstall the shells on each of these. What do you think about it?
Thanks again for your help.

So, I started from my old version of HA 2023.6.3 (I had saved the Config folder before the update) and did everything as described in the previous post. Well, the problem seems solved and the Shelly devices work perfectly. I hope this can be useful to someone. Thanks to @tom_l for the support.

Somewhat the same here. However it happened to me after upgrade to 2024.3.3.
Since I’m running HA on proxmox I had a backup from yesterday (2024.3.1) before upgrading to .3. I restored that and everything seems to work fine again.

After several tests I came to conclusion that the connection is lost when, for any reason, HA is disconnected from the network for some time. Subsequent attempts fail to restore the connection in any way other than deleting the integration and reinstalling it. The integration is probably no longer able to connect to the cloud.

The Shelly integration does not connect to the cloud (local push only)

If the devices are battery powered, they may not connect until their next wake-up period or event trigger.

The devices are Shelly1 powered by 220v. I tried disabling them and then re-enabling them, but they keep looping trying to connect.

Sorry, I missed that part.

Hi team,

same issue…
Shelly 1 Gen 1.

Works fine with HA_2024.3.(0/1/2) fails with HA_2024.3.3. Fails with 2024.4.x…
Verified, it works again restoring backup with 2024.3_under-3-.

I would turn on debugging to see what is in the logs. And if there is not anything obvious in the logs, open an issue on GitHub (and post the logs with the issue).


Hi, just upgraded from 2024.2.x to 2024.5.1 and lost most of my Shelly devices, mostly Gen1 (but also a Pro3 and a Pro4PM were faulty while connected via ethernet directly to the same switch as HA, so no wifi network issue). I could see them on the network, access then via their IP directly, but the integration would say ‘unavailable’. All devices have fixed IP, CoIoT configured, and have been working for more than a year without any issue.

Checking from my phone I saw one ‘offline’ on the app and on the local web page I saw that i disabled the cloud connection for this this device. So I enabled the cloud connection and immediately the device was active again in HA…

I could reproduce the same behaviour with a second device: when cloud is activated again the device becomes recognised in HA within 5 secs.

So I tried to disable again cloud connection in the local config page of one device, then reboot HA, but now most devices are back active again, also the one with no cloud connection. Only one Gen1 was not back, that had no cloud connection, but was recognised again when I enabled cloud on it.

I think that some things have changed recently int he integration and the migration is not working properly when a Shelly devices has no cloud connection or when one jumps HA updates?

While it is true that the integration uses local push, maybe this particular change was needing the cloud connection to update the entities??

At least I found a workaround. Hope this helps,

So a similar thing here. Everything was PERFECT and ROCK SOLID for at least 18 months…then I install 2024.5 and on restart half my Shelly devices Gen1 are offline…a restart of HA doesn’t not return them, nor does a full reboot, not does just ‘waiting’.

However, going to Settings > Integrations > Shelly and then for each Shelly device (I have 38) going Reload causes the Shelly to come back on line. It doesn’t need me to touch the Shelly devices themselves, the reload operation immediately restores the connection.

I do not know what has changed, it is almost like the new “fast startup” stuff that has been added is not allowing enough time to restore everything…

I have a mix of Shelly devices, all Gen1, all with no cloud service, all hardcoded to talk directly to HA. Some will connect correctly, others do not. I’m not certain yet if it is the same ones that fail on restart or a random selection. But it wasn’t like this before!

The change log can be found here (search for “shelly”): Full changelog for Home Assistant Core 2024.5 - Home Assistant.

I would provide the logs & debugging information (see post above) in a new issue on GitHub.

Or try diving a little deeper by trying some of these debugging techniques:
2024.5+: Tracking down instability issues caused by integrations.

Finally, reverting to the previous version / restoring a backup should work.

We have an issue for tracking this #116975

Please don’t join the issue there just to write “I have the same issue” as it just spam the issue and defocus us. It is enough to put :+1: on the first post.

If you want to provide more details please look at #116975 (comment) and add your details.


1 Like

Noted, but I read the notes and added an observation as to the behaviour as I have needed to restart HA a few times in the last 24 hours (for unrelated reasons). I have found that it is not the case that they do not come online after restart - they do, and they work…they are lost a short time after the start up sequence has been completed.

Let me know via the Github issue if you need further logs or helping testing.