No state/value for Air-visual integration main sensor?

HI
using the https://www.home-assistant.io/integrations/airvisual/ integration, there seems to be no value for the main pollutant at all? All I get is a name, symbol, unit_of_measurement, the lat/long and the quality.

The value for the main_pollutant this is based on, which seems to be the main value for this sensors… isn’t provided:

55

this is the station near, showing the 6 which is what should be in the sensor too.

16

anyone else see this? do we have a bug?

“When configured, the platform will create three sensors for each configured air quality standard”

Where are your other 2 sensors?

32

none of these content the value for main pollutant PM2.5

I’ve added the Chinese method also:

02

same for Pm10

ah, i understand now. Make a feature request.

maybe try a bug first… :wink:

bug when it’s not a bug pisses off developers :wink:

yeah, never sure what to do,
feature requests that don’t get any attention of the dev’s do comparable things to the users.
but, I’ll play nice.

Just make an issue and say “i’d like this to get added” if you want more visibility from the devs.

made the feature request…

but still will do as you suggest, referencing both my FR and community post.
thanks for the hint.

update

Issue filed: https://github.com/home-assistant/home-assistant/issues/27818

and closed, the API doesn’t pass the info:

too bad really, but nothing we can do about it.

now see it in the api docs also:
see note about key pollutant concentration values bottom left on the page:

I wrote a quick & dirty fix here: Air Visual main pollutant (V 0.95.4)