No TTS after upgrade to .110

Were there breaking changes to Google Translate with this upgrade? I no longer have TTS. I can hear the “start up” sound, but my Google Homes no longer speak. My Grandfather clock is working, so I know its will play Mp3 and music. I just can’t figure out why speech isn’t working.


Set your base_url for TTS

  - platform: google_translate
    service_name: google_say
    language: 'en-au'
1 Like

Thanks! And how did you know that I liked the “en-au” voice? lol
That kinda worked, the problem is that all of my speech automations use “google_translate_say”, so I’m going to have to change all of them to use “google_say”
Thanks for the help.

or you can change the service_name to google_translate_say

Ahhhh, Doh!

I have the same problem (0.110.3), in addition to not being able to cast anymore.
I don’t like having to specify the base_url here now when I didn’t need to before, and it breaches the DRY (don’t repeat yourself) principle, since this is already specified in the homeassistant: (general) section.

Did changing base_url in http to external_url & internal_url break this?
I couldn’t find an issue for it.

As seen in other threads (the main 0.110 release blog post thread), it seems a bunch of these issues are to do with people using the SSL certificate via the http component. I followed the advice of others’ and have just installed NGINX instead, and it’s working well with local IP access on http and remote duckdns access on https. I don’t need the base_url in tts anymore… and I can cast :slight_smile:

I had the same problem and it solved
my config file


my automation
service: tts.google_say
message: the door is opened
entity_id: media_player.family_room