Node Red not opening in HA GUI

I have HassIO installed on a Nuc running ubuntu.

I have installed node-red addon, port forwarded 1880, turned off SSL in the node-red config and can gain access to the add-on via the LAN.

However, when I try to access node-red via the Home assistant GUI I get a blank page.

If I disable the ubuntu ufw firewall, I am able to access node-red via the home assistant GUI.

the problem is… I don’t know what port(s) need opening for node-red on HA GUI. does anyone have an idea?

If you are using the “open Web UI” button within the Addon then you do not need any port forwarding. Home Assistant is taking care of that for you.
That feature is called ingress. https://www.home-assistant.io/blog/2019/04/15/hassio-ingress/

In general, you shouldn’t need any port forwarding for node red when you just want to reach it within your local network if you haven’t done anything to wall off your access. But then you would probably know what you did.

Officially, Ubuntu is not supported for Home Assistant Supervised. But I have it running in the same configuration.

As for the Firewall, according to the documentation the ports are specified in the config.json:

Ingress#
Ingress allows users to access the add-on web interface via the Home Assistant UI. Authentication is handled by Home Assistant, so neither the user nor the add-on developer will need to care about the security or port forwarding. Users love this feature! It connects your user directly to the add-on, can provide a seamless UX within Home Assistant and grants your add-on 2 points of security.

Here are the requirements of Ingress:

Ingress must be enabled. Set ingress: true in config.json.
Your server may run on port 8099. If it does not run on 8099, you must set ingress_port: PORT_NUMBER in config.json to match your configuration.
Only connections from 172.30.32.2 must be allowed. You should deny access to all other IP addresses within your add-on server.
Users are previously authenticated via Home Assistant. Authentication is not required.

The config.json for the NodeRed Addon:

  "ingress": true,
  "ingress_port": 0,

Not sure if that helps :wink:

I was in your situation and it was maddening. I ditched Ubuntu and switched to a Proxmox VE running a supported version of HA and all of my problems went away. Might consider it.

thanks for this, an excellent suggestion! I have been searching around trying different things but it’s not quite working yet…

Strange you should mention this. I have been looking into this today. I run plex, roon and Home assistant from my server and been looking at starting a windows VM.

I’m feeling kind of done with docker and learning it so it seems proxmox is the route to go

UPDATE!

I took advantage of the bank holiday weekend to install Proxmox and I couldn’t be happier. it’s so simple and makes for a great way to manage ubuntu and windows separately from Home assistant. also I found this link which made the install super easy:

Also worth watching Juan on YouTube for an insight although I went with the above link route - https://www.youtube.com/watch?v=42gopfIrPBY&t=371s

Needless to say my node-red is working as expected on a supported version of HassIO

1 Like