Nodered "unknown : ha-entity"

My flow suddenly stopped working (this morning), and when I open Nodered addon, I see “unknow: ha-entity” instead of the entity node that were storing flow output.

In the palette, I cant do anything about the ha-entity.

I read that The Node-RED ha entity node is deprecated in favour of four individual home assistant entity nodes (Sep 2022) - #11 by 35e
But I dont manage to get the sensor node.
I have the nodered companion (with HACS) up to date.

I did notice some of the names in ‘server’ recently changed from ‘home assistant’ to HA-Main, switching to the new name solved it for me :wink:

Thanks but I dont have nodes with “server” (or I cant see that input since node is unknown)
I also tried to restore nodered to 13.4 but that did not fix.

I exported flows, I then deleted all my flows, but when I restart, they come back.

I also tried to delete nodered, but it’s like I cant get a fresh install of nodered.

PS : okay, I found that flows persist in config folder Erase all data after unistallation - make clean install - #4 by flamingm0e

PS2 : By cleaning nodered config folder, I managed to reinstall a clean nodered and then import my flows, and decide whether I migrate to new entity nodes or not