Not able to reset Zigbee Sonoff Dongle Plus (P) for new Zigbee Network

Hello together,

I am using a SONOFF Zigbee Dongle Plus (P-Model) as router.
After installing a new Home Assistant Instance, I’d like to use this router in a new Zigbee Network.

Pressing the reset button didn’t work to pair it, and I also tried to re-flashing the router firmware. After flashing the firmware, it also didn’t work to connect the stick to my new Zigbee network.

Does anyone know how I can use this dongle in a new network?

I flashed the firmware with the ZigStar Tool…

Thanks a lot in advance!

Best Regards,

I have three of them running on a Zigbee2MQTT with firmware 20221102 just fine.
There are two buttons on the Sonoff board, sure you are not putting it back in DFU mode? After flashing, my experience is that you should be able to just power cycle the dongle and it comes up in pairing mode, no button pressing.

I think you might find more help if you share some more details of your path and config:

  1. Zigbee2MQTT or ZHA or ???
  2. What is your coordinator device and firmware?
  3. Output of the flashing log

Good hunting!

But it doesn’t stay in pairing mode very long.

My process:

  1. Flash it (I use cc2538-bsl with the erase (-e) flag)
  2. Unplug it
  3. Enable “Permit Join” in z2m,
  4. Plug it back in.

Hello and thanks for your replies @dproffer and @jerrm :slight_smile:

I am using ZHA and my coordinator is the SkyConnect (new Instance).
In the old instance I also used ZHA but the coordinator was the Conbee II.

I’ve already paired the router SONOFF Dongle with my old instance, and now I want to reset the dongle to use it for the new instance.

Already tried to flash it again (using the router firmware and ZigStar Tool on Windows). After successful flash I started the ZHA search and plugged it in but it didn’t appear. Also tried to push the Reset Button multiple times (on the board) - without any changes.

I think the router is still searching for the old instance, which is not longer active?

Thanks a lot in advance.


When you flash the router FW it complete wipes the previous network settings. part of the flashing command is erasing he module first. If it’s not detecting, likely interference near the router or coordinator.

I will try it again pairing the router with my Zigbee network.
I already connected some Zigbee Devices to my SkyConnect without any problems - only the router makes some struggle.

Keep you updated. Thanks @tube0013 :slight_smile:

Just thinking out loud -

  • You’re positive the re-flash was with the router firmware?

  • ZHA/Skyconnect was started with a new network? If it was migrated from the ZBDongle-P, then there could be MAC conflicts.

Hi @jerrm

Yes - like I said new Instance:

  • No Migration, new network

Re-Flash of SONOFF Zigbee Dongle Plus (Model P)

  • It shows that the Flash was successful, but there’s no router when I try to add it to my ZHA network.
  • using ZigStar Tool because the Smart RF Software didn’t work

I’ve used the Dongle-P with my old network (conbee as coordinator), where I have no longer access.

That was my interpretation, just wanted to be sure.

I’m not sure what the problem is. I’ve installed more than a dozen ZBDongle-P routers, including “reinstalling” several on different nets. A new flash has always reset the stick back into pairing mode.

I don’t use the zigstar or TI Windows tools, I’ve always used cc2538-bsl from the linux command line.

Make sure you are selecting any nvram erase options with the zigstar tool, or try cc2538-bsl, or use the flasher addon:

mercenaruss/zigstar_addons: Home Assistant add-ons for Flashing ZigStar Devices (

Make sure to use a custom url pointing to the router firmware.

Hate to complicate your steps and spend more of your coin, however, from my reading I would ‘run not walk away’ from that SkyConnect thing. Having a solid base of a TI 26xx coordinator and several TI 26xx routers seems like a reliable base (this is what I use on my production and test networks). And (soapbox on) a better path for you to dump ZHA and move to Zigbee2MQTT (soapbox off) :wink:

Maybe not relative here or not but FYI, you might also want to look into changing the IEEE address of your Zigbee Router adapter to make sure it uses a unique IEEE address.

The scenario when you absolutely would need to do so is if you have first used the “old” adapter as a Zigbee Coordinator and then migrated from it to a “new” Zigbee adapter before re-purposing the “old” adapter as a Zigbee Router in the same Zigbee network.

The reason for that is that when migrating an existing Zigbee network from a other Zigbee Coordinator then part of that process has been to copy the IEEE-address from the old adapter to the new, thus you have two adapters with the same IEEE-address. This will cause problems if you then add the original adapter back to the same Zigbee network before manually changing its IEEE-address as it should never have two devices with identical IEEE-addresses.

If you do manage to get two different devices with exactly the same IEEE-address on the same Zigbee network then routing will get screwed up. so at least it will not hurt to change the IEEE address of Zigbee Router devices as what that is in the Zigbee network is unique MAC-address for addressing that specific device.

You can find links and information about how to change the IEEE-address on CC2652 based adpaters here:

Note! If the Zigbee Coordinator shows its ieeeAddress as 0x000000000000000 then it is screwed up (needing to write a new IEEE address to Zigbee Coordinator, reform whole network, then re-pair devices).

Hello together,

I tried again to re-flash the Dongle and now it worked:

  • using python to switch to Bootmode on Zigbee Sonoff Dongle Plus
  • starting Zigbee discovery in ZHA
  • activating erase, write, verify, nvram reset in ZigStar Software
  • flash

The tool told me “Unknown error” for zigpy but it showed up in ZHA.
Now it runs fine! :slight_smile:

Thanks a lot for all your help and advises!

Have a nice weekend!