Notify.notify & some other notification service not working

I have just noticed majority of my previous notifications is not sending out especially on those using notify.notify.

I have just upgraded to 2022.3.5 from 2021.8.3, but I realise this issue is already there before i upgraded. So i went to developer tools and use the service tab to send out notify.notify. Even using the GUI. It seems not working. None of my IOS device received any notifications. However, when i choose notify.admin_group, it does works on those designated IOS device including iPhone & ipad. But if i use notify.mobile_apps_xxxxx, it only works on ipad but not on the iphone.

This seems to be a major issue for me as i see the notification functions as a basic important functions for this home automations to work. All my IOS has been upgraded to the latest companion apps. Appreciate any advices

notify.notify only works if you haven’t named a notification service.

You are much better off using named notify services. e.g. notify.mobile_name_here or notify.group_name_here.

Thanks for your response and advice.

I created a separate notification group and changed the notify.notify to a notify.group_xxx and it works again. Don’t think the notify.notify can be used.

I am trying to get notify to work for the first time and can’t seem to get it right. I have tried notify.notify and notify. and nothing seems to work. However the same yaml works in dev tools. I can’t think of anything else to try. The notify I am trying to fire is from keymaster. I had difficulty following your fix since this is new to me. I see nothing in the logs at all. Any ideas?

Share your configuration for the notify action.

I have two scripts due to conflicting documentation on keymaster. Neither works.


Btw, I also tried notify.my_phone_entity Also did not work.

Does this exist in Developer Tools → States?

Also maybe ask here: KeyMaster Z-Wave lock manager and scheduler

I know nothing about that integration.

It was a bug in keymaster. They are working on it.

This isn’t working for for me, suddenly none of my notify services are showing. Just simple email notify, all gone.

Got mine working again, some reason the SMTP settings changed and made the service not appear