NSPanel Pro - Custom android apps (working)

I got mine going with the Ariela app and FNG (Fluid navigation gestures).
Working great!

It looks cool :smiley: What font type are you using? And I assume this is Mushroom dashboard?

I use the ‘quicksand’ web font (Google Fonts: Quicksand).
I’ve uploaded a copy of my dashboard YAML here: nspanel_config (github.com)

Blakadder has made an article on his blog on how to Sideload Apps to Sonoff NSPanel Pro.


I also did


And working on guide how to run Zigbee2MQTT or use it as a coordinator over TCP for ZHA


And another one


Would be interested to know if sonoff have locked this down now. Got my Nspanel pro today and tried to connect via USB to ADB into it but the device only shows in Windows as a mobile device. The ADB driver will not install for it.

This may be of help…

1 Like

Thank you so much. Didn’t see that little caveat. All working now

in app ewelink, on nspanel device open option and click 8 times on id device or fw, after go up and enable develop tool.

1 Like

Is anyone with an NSPanel Pro on 1.3.2 or 1.3.3 able to get wireless adb working? I have enabled developer mode in the eWeLink app, and I can get adb just fine over microUSB to the OTG port, but all attempts at running adb tcpip 5555 does not actually start the adb server and I can never actually connect to it from my desktop. Obviously opening the device anytime I need to make a change is not ideal so if anyone knows what I might be doing wrong I would greatly appreciate any advice. Thanks!

I went strait to V1.4 and never used usb. It worked fine without any issues.

1 Like

Well I think we are facing the same circumstance. I’ve already have the NSPanel Pro sideloaded, even had HA installed. Then I found I cannot connect to it var adb any longer, nether wifi nor USB. It just told me adb connection refused.
Then I input adb tcpip 5555, it returns “no devices/emulators found”.
I wonder is there anyone could solve the problem. Thanks!

What’s the LAN/WLAN IP subnet that your NSPanel Pro is on? I found that I can’t connect to adb over tcp if it’s not on a 192.168.x.x network.

if already rooted:

  • unplug device for 10sec
  • turn device on
  • click to settings / system / developer option’s
  • check USB debugging must be on for adb (also for adb over wifi)

Thank you seaky.
I’ve send it back to Sonoff cause they were interesting about what happens. A new one is just arrived.

1 Like

I really appreciated your articles they saved me a lot of time so thank you for that. One thing that would be helpful is they have changed things a bit since 1.5 and it took me a while to get around it. ADB is available but is not on by default. Now you need to connect the device to Sonoff (you mention this), go into the device info and tap the device id 8 times. It will then make you agree to developer mode. You then need to go into developer settings and check the adb button and sign your rights away.

Maybe if I moved a little slower I would have noticed this but I wouldn’t describe myself as a patient man…

I hope this will help someone else who can’t seem to connect via adb.

Thank you for this information! I have 2 panels that are on Version 1.5 and not changed. My 3rd one ist still on 1.33 and I played arround with developpermode and adb. Since then it is not possible to install newer firmware anymore. Its not even recognised. Even a complete recovery did not help.
Is there any way getting back to default mode, to be able to upgrade to the latest version?

They make it pretty clear when you check that button that once you turn it on you aren’t going back.

I Just got the new Pro, with V1.5.0 OS Version
But tapping 8 times does not activate developer.
Wifi ADB and USB OTG is also disabled.
Anybody got a solution to connect ADB on these?