Nuki Smart Lock 2.0 - support all available API actions (i.e. add lock/unlock)

First, list command to show what you’ve done on the bridge:

Second, delete all entries (id=0, id=1, etc.) with command delete:

Then add the correct callback:

curl -X GET -H "Content-Type: application/json" 'http://your_nuki_bridge_IP:8080/callback/add?token=your_NUKI_API_token&url=http://your_HA_IP:8123/api/webhook/your_long-term_webhook_id'

Glad it’s working also for you, enjoy it. :slight_smile:

Did you have the setting “rechargable” forced on? That would explain it. If I’m not mistaken, there’s an Auto setting, so the Nuki detects if the batteries are normal or rechargable.

Anyway, good that is working too. You’re all set now. :slight_smile:

Thank for the help !
The first command run fine and shows one entry (id=0) but something is wrong with the second command, I get “HTTP 401 Unauthorized”. By the way, this “%26” seems a little bit strange to me.

%26 means &

If you follow instructions of the original post, you can add the callback again.

The problem is that Nuki Bridge doesn’t support HTTPS, only HTTP. You need to use the INTERNAL IP on HTTP. If you hardened HA’s config to only accept HTTPS, you can’t use callbacks from Nuki Bridge. It only works on HTTP.

If you hardened HA’s config to only accept HTTPS […]

I configured an internal URL ( via the UI but I cannot connect to my HA server this way. What I have to do to “dis-hardened” my config ?

How di

How did you harden the configuration? Check those instructions and reverse them. It’s OT in this thread.

I will specify in the instructions for the card that it only works with HTTP because of Nuki Bridge limitation.

You are right !
Thank you for the help, I deleted the existing callback and I will check this http problem.

I thought so too, but it says

Automatisch (automatically)
Nuki Power Pack / Akkus (<- means rechargeables)

which I read as it will automatically been recognized and distinct between normal batteries and rechargeables.
But it seems its only good when using with rechargeables.

No problem, sorry if I answered so briefly, I was on the phone. :slight_smile:

Let me know when you solved it.

It should work like this:

  • Automatic detection enabled: you check the result, and see if it detects the batteries correctly, if not, you can disable it.

  • Automatic detection disabled: you have the option to specify what kind of batteries you’re using

Hm, this is somehow strange. I can’t uncheck either choice. When I have checked Lithium Batteries and enable “Automatically” it chows what I had checked before, even when it was Alkali but Lithium batteries are in.
Seems the detection is not really working.

So autodetection doesn’t detect lithium batt. but you can choose them manually, I would do that. Disable automatic detection and choose lithium.


1 Like

I have this problem (i try register 2 callback)

Any idea ?

Let me know when you solved it.

Solved setting a reverse-proxy (nginx).
Now I have status door ok.
Thanks !

why did you register 2 callbacks? only one is needed.

the error message says “unregistered webhook”, that means you didn’t create the long-term token as per instructions. you need to read carefully the instructions and don’t skip any step.

Glad you solved the problem.

Hi, I registered 2, because the first one gave me an error.
the 1st is registered with the token name
the 2nd is registered with the token
and I have read the guide several times, in fact my long-term token is registered

Delete the first one. A few posts above I explained how. Better leave one callback, otherwise you could have issues.

Follow these steps:

Since the “callback” lock status is faster updated than the “normal” lock status, it would be nice to have a way to update the representation of the lock/unlock button with it instead of with the “normal” lock status.