Ok, next noob issue - Automations

Thanks both. I think Coolie may be right. I will check the online details as the print on the paperwork it came with is too tiny.

You won’t be able to set the wakeup interval unless you manually wake it up at the same time you issue the change from HA. Your device will have a button, switch or some other way to cause the device to wake up and talk to your Z-wave controller / HA for a short period of time (usually 30 seconds or so).

looks like you need to adjust Param 7 & 9, to get your ideal setup.


Also, if there are long periods of time, where there is no one home, and you have the wakeup time set to a very short interval you will be greatly shortening the battery life. If the device reports light level when it reports motion, consider that when choosing the wakeup interval.

API Manual

I am not getting the ability to set the Ambient Light Sensitivity Level:


If I select “Config Parameter”, there is nothing in the list.

IDN, mine show 10 options:

1 Like

You may need to wake the device up and make some change for the device to update ha with the available parameters. You may need to do that more than once for things to show up. Read your manual to see what is available. There can be multiple versions of the device with slight differences including variations in configuration options.

Maybe I should remove and add the sensor back in. I set the node to be the:

Then nothing for the config options. I had this configured on another pi setup which was a pi1. It was so slow, I got a pi3 and just used a snapshot from the old pi. Maybe something did not translate well. I will try this when I get home later. Thanks for the confirmation from both of you. It is really helping this noob.

You should not need to remove the device. Try forcing a wake-up first. The device should update its capabilities with HA. Make sure you are in the section. There are multiple dropdowns.

1 Like

Thanks, will try. How do you force a wakup? I did a test node and I see a wakeup in the OZ log:

2018-03-19 17:28:05.423 Detail, Node004, Queuing (WakeUp) NoOperation_Set (Node=4): 0x01, 0x09, 0x00, 0x13, 0x04, 0x02, 0x00, 0x00, 0x25, 0x3f, 0xf9
2018-03-19 17:28:27.058 Detail, Node004, AdvanceQueries queryPending=0 queryRetries=0 queryStage=ProtocolInfo live=1
2018-03-19 17:28:27.058 Detail, Node004, QueryStage_Probe
2018-03-19 17:28:27.058 Info, Node004, NoOperation::Set - Routing=true
2018-03-19 17:28:27.058 Detail,
2018-03-19 17:28:27.058 Detail, Node004, Queuing (WakeUp) NoOperation_Set (Node=4): 0x01, 0x09, 0x00, 0x13, 0x04, 0x02, 0x00, 0x00, 0x25, 0x40, 0x86
2018-03-19 17:28:27.058 Info,
2018-03-19 17:28:27.058 Detail, Node004, Queuing (WakeUp) Query Stage Complete (Probe)

Oh, I think I need to do this via the device. I will try later when at home.

Special thanks to zarthan and Coolie. I ended up having to remove the z-wave Dome device as it was in a bad state in the XML file and even though I could wake it up by pressing the button on the device it would never give me the context configuration menu. I ended up excluding and removing the device then including and adding the device. I now get the contect menu:


Still running up the curve and only about 10% of the way. But I think I am gaining some ground everyday.