[On Hold] Deprecating Home Assistant Supervised on generic Linux

Forrest, Stupid is as stupid does.
Are you kidding or are you serious? One installation method or another is not the point, you are eliminating an entire infrastructure and, of course, the functionality in the latter. The ability to use one infrastructure or another it’s a feature, a feature that makes the difference in choosing a product. Guys, the basics, please, at least the basics!

i’m glad on reverting idea, it’s the right decision.
Really appreciate that.

This is getting more and more bizarre and I think on one hand the communication is to blame but on the other the decision needs to fit a certain product vision and the direction to reach it. If the direction is to limit the hardware and OS home assistant can be installed on then this is a good way to do it. If it is very tactically to address a work overload then this does not really make sense.

As I am fairly sure that I am personally not affected either way, as I don’t run the supervisor, I can only input that we likely have way too many options for installations. If I may give an opinion on this: Provide self contained images for non advanced users (Pi or NUC, maybe others). For all others, if we are technically versed enough to create our own VM, then we should know to install an generic OS in the VM, install Home Assistant and maintain it ourselves. It isn’t all that much more difficult. It is very easy to make something simple very complicated. It is much harder to make something complicated simple. To me that’s what docker is and I never understood the value of it besides the ressource savings, but when they spawn like rabbits in heat and we need a supervisor to manage them, they don’t make any sense anymore and I prefer to run them all in a single VM. It’s a matter of vision… One that is blurred for HA at the moment.

1 Like


1 Like

“On Hold”. Thank god.
I was about to throw it all away. The supervised version on my raspbian is crucial for me. With Hassos I cannot use my touch display for viewing, I cannot (unless otherwise changed) edit the files to rotate the display (the official cover makes sense!) mand similar.
If this version is kept, I continue to use Home Assistant, otherwise I abandon it. I am not going to move on to the others since they are not good for me.


I’m not sure if this is the right place to share this experience but I’m going to anyway because it seems to be an install method ESXi users would use if it worked :slight_smile:

After reading about this deprecation around 12AM last night I was saying to my self, “Oh CRAP! Well, it looks like I know what I’m doing tomorrow!”

Anyways, I was able to get the VMDK working and expanded on my ESXi install.

The key to the process was making sure to use vmkfstools -i hassos.vmdk hassos-new.vmdk to clone the VMDK file that’s designed for VMWare Workstation to be suitable for ESXi. This allowed me to increase the size of the virtual disk and allow HassOS to resize its volumes automatically to use the new space on first boot. A few but not all of the blog posts on this subject mention that step and it’s crucial. Otherwise when you try to boot up the existing 6GB disk it runs out of space. And if you don’t clone it first and try to increase the disk size ESXi will not start the VM.

Next was to make sure when you import the cloned drive it’s set as an IDE drive. Last was to set the VM BIOS to EFI mode.

For cleanup I also removed any unnecessary hardware like SCSI/SATA controllers and CD-ROM drives.

Contrary to what some bloggers say the VMXNET3 NIC type DOES work since (at least on the latest VMDK version) and it’s highly preferable to use it since there are plenty of known, never-to-be-fixed bugs with the E1000 driver that can cause host crashes.

I remapped my USB ZWave stick to the new machine as well and it found it without a problem.

There are lots of tutorials out there and each one seems to be missing a piece of the puzzle or has something the others don’t which is frustrating. I haven’t spent any time learning how to create OVAs or vApps for vCenter or ESXi but maybe it’s time I do and give something back since that’ll probably make the process for installing HassOS on ESXi much smoother.

A major problem I ran into, however, was that my snapshots from my Supervised Generic Linux install would NOT restore on the HassOS VM no matter what I tried. Now, I was using a snapshot generated by the Google Drive Backup addon. Maybe that had something to do with it but as far as I understand it that shouldn’t matter as it’s the whole point of that add-on. Also, probably HALF of my configuration files were missing from the backup. I had to fire up the old Supervised install and copy everything over. Again, maybe related to using the Google Drive Backup add-on? As a test I did a backup of the new HassOS using the add-on and downloaded it, uncompressed the tarballs and everything looked to be there so shrugs.

Anyways, a bit rambly but that was my experience converting to the VMDK install of HassOS on ESXi.

All that just to read now they are backing away from the deprecation! lol.


Thanks for reversing the decision! I am running Supervised on my Pi 3.5 with a boot into a USB SSD, and it works great. Never had any issues with it, way more issues running Hassos versions from the SD card…


I got to say I am pretty proud of the community here … This has been for the most part very civil and passionate… :heart:


Thank you for holding this decision. I am just starting to learn what HA is and I am already proud of being part of this community. Although disappointed, users kept respect in the way they communicated their frustration.

This is very much a supported method. The errors you’ve taken screenshots of have all indicated issues with your host in some way, either you’ve not pointed your VM at the appropriate disk image file, or the underlying media storage container something was pointed at was full. Do you already have a lot of other virtual machines on this host?


This was the key missing from the other instructions.

@ludeeus, FYI: Not sure if you needed to do this to get it to work, but this after running vmkfstools to clone the disk I was instantly able to get it to boot with an expanded disk size. I’m running ESXi 6.0.0 U3, so I’m not sure if this a version specific bug, but this was the trick needed. I appreciate the help last night though. Not sure why my install was being so finicky about it.

1 Like

I did not need it, I just pointed my VM to the VMDK file, and made the changes I wrote yesterday.

Strange. Maybe they can host an ESXi-specific OVA file along with the other OVA and VMDK files so we ESXi users don’t have to jump through the extra hoops of creating the correct configuration, converting the disk, etc.

1 Like

Add it as a feature request here https://community.home-assistant.io/c/feature-requests
But nothing special was required for me with ESXi 6.7.0 Update 2 (Build 13006603)

i have just seen … that there seems to be an ova already:

but it fails to deploy

Issues detected with selected template. Details: - 23:5:PARSE_ERROR: Parse error: Undeclared namespace prefix "vmw" (for attribute "osType") at [row,col,system-id]: [23,93,"descriptor.ovf"].

So far about the “supported” way of installing HA. I’ll stick with my “bad” generic linux hass.io installation … as it was and is working as it should out of the box since the beginning.

ESXi complains about the structure, same with proxmox (I’ve been told).
For ESXi I (personally) fond that the VMDK file was the best way.

Please do not suggest software architecture by polling the most popular options. This rarely works. There is a reason “designed by comittee” has a certain ring to it.

The strength of Home Assistant is its vision on usability, aesthetics and giving a pleasant experience. You don’t get this by including every feature or installation method that very different people desire.

Give me a coherent experience over implementation details (and VM image vs. supervised vs. “HassOS” is just that for me) any day!

1 Like

after deprecating news i cleared my host for a proxmox installation. now my setup is offline, i’m waiting new ssd for vm… and now is on hold? what i have to do now? just re-install as before or change all my scripts, setup etc… (weeks of works after an year of work)? please… i’m going crazy for this. i’m using zoneminder on the same host and vm have less performance.

For now reinstall, it’s not gonna deprecated as per statement

When the deprecation news came out I was disappointed. Disappointed at the short notice mostly. I know I’ll be able to get something else worked out. I am currently running HA in an Ubuntu VM running in KVM on an Ubuntu hypervisor; it works just fine right now, and I could probably get by without any updates for some time.
I looked at the latest options for install, and it all looks kind of hardware-dependent, though there are some VM images available, and one in particular that caught my eye: qcow2. That wasn’t there when I first installed HA on my Ubuntu VM, otherwise I would probably have gone with that in the first place.
Anyhoo, I’ve tried installing that, and after a bit of trial-and-error (there’s no documentation on any of these VM images that I could find), I got a new VM running the qcow2 image (UEFI is the key).
So, now I can rest a little more easily knowing I personally have a way out.
But I do worry that the “official” way I choose next will be dropped suddenly too. After all, the way I did it before, installing HA in an Ubuntu host was official until yesterday. And then official again today, though I notice the instructions have not reappeared on the front-page of the HA website.