One physical RPi3 but two IP and MAC addresses?

I just noticed today that my Hassio installed on RPi3 has two IP addresses leased by my DHCP server, both with different MAC addresses. I only have one physical RPi3 and Hassio install, so is this normal? I’m able to access the frontend using both IP addresses and it appears to be the same Hassio install. Seems a bit odd, any ideas?

1 Like

Are you connected via WLAN and cable?

Hm, something isn’t right. I’m supposed to be only connected via cable and this was never an issue in the past until I upgraded to 0.57.3. So I just pulled the SD card and checked the system-connections folder and it’s empty (i.e. not configured for Wifi). However, I put the SD card back into the RPi3 and plugged in only power and sure enough, I’m able to access Hassio… meaning Wifi is obviously enabled some how. I have no idea how this is occurring.

Apparently there’s more to just removing the resin-wifi file from the system-connections folder. I posted over here at the resinOS forum a while back when I was trying to disable the Wifi and just made another reply with this new issue. Here’s the thread:

Bottom line, I haven’t figured out how to completely disable Wifi yet and I’m not even sure if it’s possible without root access to Hassio. It would be awesome if there was a way to modify Wifi settings from within Hassio.

1 Like

Any updates on this?

If we are talking about RPi3, try this Disable wifi and BT

I haven’t messed with it but if you follow that thread I linked to above ( forums), the fourth post down basically explains what you need to do. Basically, you have to read the SD card from a Linux host or something that can read an ext4 partition to completely remove the Wifi settings. Simply removing it from the /system-connections boot partition that you see when you plug in the SD card to a Mac or Windows machine doesn’t actually remove the Wifi settings completely. When resinOS boots, it reads the data from that /system-connections boot partition and apparently writes some of the data to another directory that is only readable on a Linux host (ext4).

Great, I will do this then! I tried to access the ext4 partition form a Chromebook, which succeeds, but I can’t remove files from there (I think a limitation in ChromeOS). I also tried to install some tools on MacOS to read ext4 partitions, but writing/removing seems a whole other problem. So after two hours I stopped trying and unplugged my ethernet cable to only use wifi for now, but disabling wifi on my RPi3 and only using the cable seems like a better option! Thanks!