Openweathermap api key still not valid after 12 hours

Same issue. At first it worked, but when I added the integrity again, it no longer worked.

Message: Invalid API Key provided

I’m having a similar issue. Tried signing out and setting the call type. Hopefully we get a resolution soon.

Changing to “hourly” in the Configuration worked for me - switched it back to “onecall-hourly” and it failed again. Changed to hourly and it worked again. No idea why that option is broken. Try it out.

This error seam to persist to this day.
No matter hte call type i use: Invalid Key provided

1 Like

I’m heaving this issue with OpenWeatherMap. When trying to install this integration, I get “Invalid API key” (on multiple API key and with all settings)

Logging off from Openweather on my browser worked but only for hourly.

Same problem. Latest version of HA. Unfortunately nothing in the thread worked for me so far.

‘hourly’ works for me and ‘onecall-hourly’ immediately breaks

Looks like I was able to get the ‘onecall-hourly’ mode to work by subscribing to the Open Call API 3.0.

I initially set up a free plan and couldn’t figure out how to get hourly data, but upon further reading, I realized that I needed to subscribe as well.

1000 calls a day are free and then you pay per 100 calls thereafter (you can set your limit to 1000 calls though)

They say it is an instant upgrade but it took a few minutes after I changed the mode in HA from ‘hourly’ to ‘onecall-hourly’ for things to start working.

Then I was able to get this output (instead of 3hr intervals)

Hope that helps

4 Likes

For anyone that waited 2 hours and still gets the empty dialogue, it’s because your latitude and longitude have too many digits. Try shortening to 4 decimal places and then selecting “hourly”

1 Like

So I also have the issue. my api keys do work (I tested through postman). I tried both api versions and reducing longitude/lattitude to integers. Any furhter idea is welcome.