Optimistic mode for Z-Wave (helpful for GE Dimmers)

Tags: #<Tag:0x00007f7393b26a20> #<Tag:0x00007f7393b26930>

Hi, I would like to have optimistic mode for Z-Wave the same way we have it for mqtt.

When a state_topic is not available, the switch will work in optimistic mode. In this mode, the switch will immediately change state after every command. Otherwise, the switch will wait for state confirmation from the device (message from state_topic).

This would be useful for the GE Z-Wave and other dimmers that don’t immediately report their status so the switch flips back to the previous position for a few seconds before settling in the correct position. Setting polling and refresh does not correct this behavior. The only way right now to fix this is to set Z-Wave Command Dim Rate to 1 so that the transition happens fast enough for the flip to not happen. This is not ideal though and optimistic mode may be a better method.

Thanks!

I also see the flipping switch behavior on my Yale Z-wave lock.

I just wanted to add, there is also a “delay” zwave device_config parameter which can be used (see below), which seems to delay for the specified time in seconds before refreshing the value (where can I find the documentation for these z-wave device_config params?). This is helpful for these GE Dimmers. … however, this does not prevent the state from falsely flipping back and forth on the HA UI before this time. My point in bringing this up is this optimistic mode for z-wave will likely need to somehow take into account this delay parameter as well. Like, maybe it could be “optimistic” about the state of the light until after the delay period… at which point it will update the actual values???

zwave:
  usb_path: /dev/ttyACM0
  device_config:
    light.ge_14294_inwall_smart_dimmer_level:
      refresh_value: true 
      delay: 5

+1 would love to see something like this to help with the UI from flip flopping!

Here’s an animation with my GE Dimmers (and with the delay option set).

1 Like

I did some searching on github and it looks like the main issue may be that the Z-wave delay attribute just doesn’t work. There have been multiple issues opened and they just get closed with no resolution. This problem seems to be pretty wide-spread, so it is concerning this has been an issue for so long. I would like to buy more Z-wave dimmers, but not before this issue is fixed.

I have a similar problem that I reported on this thread. I hope this delay value is supported but as you mention it doesn’t seem to be… =(

Same issue here, just picked up a few GE Dimmers, they are terrible compared to Leviton, not saying Leviton switches don’t have their own issues but they are bad.

I’d love if this was implemented as well.

+1 for this - I just switched over from Vera and the z-wave support in Home Assistant is… disappointing. I use HA mainly as a HomeKit bridge and this screws all kinds of things up in HomeKit, sometimes lights won’t turn off because it thinks they’re already off, or vice-versa.