OTBR errors, but not sure where it failing

Hello, does anyone know what these error could be? I using skyconnect in mutlipan mode for thread.

otbr-agent[303]: 00:00:27.295 [N] Mle-----------: RLOC16 6800 -> fffe
otbr-agent[303]: 00:00:27.299 [W] Platform------: [netif] Failed to process request#5: Unknown error -95
otbr-agent[303]: 00:00:27.755 [N] Mle-----------: Attach attempt 1, AnyPartition reattaching with Active Dataset
otbr-agent[303]: 00:00:34.255 [N] RouterTable---: Allocate router id 26
otbr-agent[303]: 00:00:34.255 [N] Mle-----------: RLOC16 fffe -> 6800
otbr-agent[303]: 00:00:34.258 [N] Mle-----------: Role detached -> leader
otbr-agent[303]: 00:00:34.259 [N] Mle-----------: Partition ID 0x2514c72f
otbr-agent[303]: 00:00:34.284 [W] Platform------: [netif] Failed to process request#6: Unknown error -17
otbr-agent[303]: [NOTE]-BBA-----: BackboneAgent: Backbone Router becomes Primary!
otbr-web[401]: [ERR ]-WEB-----: Error is 9

I am facing the same problem. Have you solved it?

1 Like

nope, sorry :frowning:

If I had to guess, and it is just a guess, it appears that one of the Thread nodes is detaching from the Thread network (perhaps weak radio signal) based on RLOC16 6800 -> fffe, and the Failed to process request was a symptom of this.

The “Error is 9” web error I have no idea.

Exact same problem here with Raspberry image 10.4 just installed

It seems that device can find my thread network but cannot join it. Not sure if it related to this error message, just reporting on my limit testing

It started working for me.

I disabled notifications on Android for new Matter devices. After this the “Matter devices” section was gone in Android > Settings > Google > Devices & sharing and adding devices didn’t even ask me to scan the QR code afterwards.

I then installed the “Google Home” app. I previously had one installed with the same or quite similar name and same icon also from Google but that one only showed content about Google Matter and Thread development.
The one I have now shows a toolbar at the bottom with Favorites, Devices, Automations, Activity, Settings.

I also installed the “nRF Connect” app suggested in some Thread related discussions which helped me to figure out if the devices I tried to commission are actually advertising.
Resetting them or removing inserting the battery made them advertise again for a while.

After that I could successfully commission 7 different Matter Thread devices.
It requires at least 2 attempts (up to 5 or so as far as I remember) until the device got added to HA.

I had the problem that there was a Thread network from previous experiments and HA always complained that it couldn’t communicate with that network (I already had it deleted a while ago).

I think I saw a discussion that it’s a known issue that there is no way to chose a network if there are more than one. It was mentioned it’s being worked on.

I had to play around a bit to ensure Devices & Services > Thread > CONFIGURE
only showed one network “Preferred network” “home-assistant” with “1 border router” to not get any related errors.
Perhaps mDNS is slow to drop such collected information (I have no knowledge about how that actually works)

How to configure preferred Thread network has some discussion about that