Paradox Alarm MQTT Hassio addon


#42

Hi all;

So I have got this up and running. I’ll write a fuller update on what I did in a short while when i have some time. Pretty straightforward with what has been brought up above.

I think what is causing the alarm going off to lock up the system has to do with the way the software handles the alarm state in the paradox system. I purposefully triggered the alarm system so that i could see the behaviour and true to form the system worked perfectly even with the alarm pending state with the timer before the system goes off.

What happened then is that the alarm creates a historical alarm log which is what i think locks it up. Not sure why yet, but i’ll look through it further. I reloaded the entire HASS but it still remained locked up. I tried to clear the alarm from the panel but it did not clear for some reason, still showing a historical message. I think that the timeout will occur in the next day or so and then i’ll see if the system unlocks itself then.

A question though it why is the WAN IP Logger portion of the IP150 system not used. In theory this should push the logs out to a remote monitoring site like ADT or something. Perhaps we could use this instead to send through to the MQTT broker for the firmware which is not usable anymore.


#43

Hello everyone,

I’ve spent a few hours with this again after several weeks of being snowed under, and I keep failing miserable :frowning: I guess it does not help that my module is an ip100 and not ip150. This is what the log message of the add-on is currently saying:

Traceback (most recent call last):
  File "ip150_mqtt.py", line 123, in <module>
    ip_mqtt.loop_forever()
  File "ip150_mqtt.py", line 105, in loop_forever
    self.ip.login(self._cfg['PANEL_CODE'], self._cfg['PANEL_PASSWORD'])
  File "/ip150.py", line 135, in login
    'Wrong page fetcehd. Did you connect to the right server and port? Server returned: {}'.format(lpage.text))
ip150.Paradox_IP150_Error: Wrong page fetcehd. Did you connect to the right server and port? Server returned: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"><html><head><meta HTTP-EQUIV="content-type" CONTENT="text/html; charset=UTF-8"><link rel="stylesheet" type="text/css" href="webstyles.css"><script language="javascript" src="langue.js" type="text/javascript"></script><script language="javascript" src="commun.js" type="text/javascript"></script><style type="text/css">body {margin-top: 60px;}</style><title>Paradox IP Module</title></head><body><div id = "ERROR"></div><script language="javascript" type="text/javascript">document.title="Alarma Paradox StQ";var str_message, mode;var str_result = "<center>";str_result += parent.cmtop("blue", top.ln_cant[1],"#FFFFFF","500px");str_result += "<table border='0' cellpadding='0' cellspacing='0' width='500px'><tr><TD width='1' bgcolor='#C8CFD2'></TD><td><table width=100%><tr class='he4'><td></td></tr><tr class='f10 far'><td align='center'><div class='f10 far' id='MESSAGE'></div></td></tr></table></TD><TD width='1' bgcolor='#C8CFD2'></TD></tr></table>";str_result += parent.cmbot("500px");str_result += "</center>";document.getElementById('ERROR').innerHTML = str_result;str_message = "Marc             ";str_message+=top.ln_cant[2];document.getElementById('MESSAGE').innerHTML = str_message;</script></body></html> 

It looks like it is actually fetching a page off the internal webserver in my Paradox, but it does not understand what it is. At least that is my impression :frowning:

Anybody in the same situation? Can somebody help?

Thanks


#44

Can this addon be installed in full linux home assistant? And how much of the code is based on tertuish’s? As I extended his code…but in doing so made it more specific to Spectra devices. So would be keen to integrate my code.


#45

Hi guys, after repeated failure with using the paradox/MQTT plugin, I decided to give up and use NodeMCU to interface home assistant with my Paradox SP6000. Works great so far! If anyone is interested I will do a youtube video. Cheers


#46

Absolutely!!! Could you elaborate a bit more what the approach is and what that integration method entails?


#47

The only issue is that my method uses the PGM output of the alarm panel as well as the PGM output of the wireless RTX3 panel. So this method may not suit everyone.


#48

Don’t have neither of those outputs I think… how can I confirm I do have the needed hardware installed? My alarm panel is the EVO192


#49

Sorry not familiar with the EVO panels. on my SP6000, the main board has 5 pgm outputs out of which 2 are used for the bell and alarm strobe respectively. That leaves me 3 pgm outputs to play with. On my RTX3 panels I have 4 pgm outputs. So i have a total of 7 pgm.

It is also possible to add additional pgm outputs to the panels by addon card but i have not found a need to do that at this stage.


#50

Interesting! Apparently I have 4 pgm outputs available, although I think I’m using two already (didn’t install the system myself and don’t have access to the keyboard just now). May I ask how you connect those outputs to HA and read the information off them? Any chance you could provide a detailed description and post the configuration?


#51

I connect the PGMs to an optocoupler which then fed into the NodeMCU which in turn interfaced with HA via MQTT. Will post a video soon.


#52

That’s just great. Please do!! :slight_smile:


#53

That will be great to share your NodeMCU project!
I found another solution. Please check it here

I also create another topic here


#54

Did you went somewhere with that issue? My alarm is getting locks after Alarm log. When i manually clear the log from the system keyboard with Mem > Clear the system start over again with transferring MQTT messages.

Maybe something from the code side is lacking. I was thinking and searching how to disable the event logging. Or may be we should Receiver configuration for reporting…


#55

Hey kitus,

I recently installed this addon myself and I still have a few issues with it. I was getting the same log as you and couldn’t figure out what was wrong. I digged into the addon Python code and it’s simply trying to get your internal “sass” id. Then, I analyzed the Paradox’s HTML code to notice a redirection to the HTTPS version of the IP150 site (which I think is why the addon cannot recover the needed ID to login.)

tl;dr: I fixed it by giving directly the HTTPS IP: “https://192.168.2.xxx:443”.


#56

Hey peter,

I read the Paradox documentation (found here: https://www.paradox.com/Downloader/?ID=7040) and what I think this does is simply reporting your WAN IP to a dyndns service. I kinda wish this was actually a true reporting feature so we could use it to parse the info instead of polling.

I myself have the same “lock” issue. I was able to poll the information once and since then it’s frozen. My status never updates. I’m still debugging it trying to figure out what’s wrong (MQTT, addon or my panel)


#57

Hi @fliptoback, is that offer still open? :slight_smile:


#58

I am also experiencing the “lock” issue. It may last minutes, hours, I really have no idea, but the device freezes the communication and the only way to make it work is unplug the IP module. Do you know a better way?


#59

Hi Kunago,

I still haven’t found a workaround with the current addon but I’ve been experimenting with another avenue: a python script by Tertiush: https://github.com/Tertiush/ParadoxIP150v2. It uses the software port rather than the web version and it seems to be solid. I haven’t started an alarm to see if the lockup still occurs but it’s already working better than the addon for me so far. The sad part: Tertiush’s script doesn’t work on Home Assistant because as per my understanding this script is written for Python 2.7 and hassio only supports Python >3. I’ve tried to convert Tiertiush’s script to a compliant Python 3 script with the ultimate goal to convert it to a hassio addon but sadly it’s quite painful. 2.7 vs 3 is all about handling strings rather than bytes and we have to constantly do the conversion from bytes to string and vice-versa. I only had a few days of vacation and I thought I could get it to work within a day… no dice. :frowning: I didn’t give up on it but I just haven’t got much time (I work a lot…) https://github.com/alexricher/ParadoxIP150v2_Hassio

Long story short, I run the script on another machine and update the MQTT server on my hassio machine. I got a few zones to report their info properly but I still cannot get the alarm state working. Overall, it’s promising though. :slight_smile:


#60

@alexricher Why couldn’t you create a virtualenv with python2, run mqtt with ParadoxIP150v2 there and still use python3 for Home assistant? I am running my Home assistant in hass distro and see the possibility there at least. Hassio was unstable in my case.


#61

Everything is working fine for me but I can’t figure out why this plugin stops working every time my house loses internet connection?
That’s shouldn’t be related