Password is correct but UI saying Invalid login or Password

Same thing with mine I’m totally lost now bc I have no way to login and use home assistant it keeps telling me password invalid and I know it’s not I use the same pw for everything and I do have nabu casa but what’s that going to do nothing I still can’t login I’m screwed

Did you check in the the .storage folder in the auth_provider file for your username?

I suspect that your password is correct. It’s your username that probably has a typo that you didn’t notice.

The name and username are two different things and can be different. You need the username to login. Are you sure you are entering the username and not the name?

I know it’s confusing because the username is not shown anywhere in the UI

Thank you for the info I was confused bc I had forgotten they were two different names

Last week I installed HASSWP on a Win10 machine and during install entered in the relevant popup: (note capitals) (I’ve shown it layout as I can’t remember which is name and username)
It started with the User Interface showing Fred in the bottom left and as far as I recall Bloggs up at the top of the screen.
I could log into it from a laptop as Fred no problem.
Today elsewhere I installed a new instance on a Win8.1 computer with the same details on install. However in the account entry I first clicked on the second row to enter Fred then back to the top row to enter Bloggs as as I hadn’t decided whether to use the same names as my previous install. initially. Note the names definitely ended up int he right places as before. I am particular about names/passwords as we have so many these days and wrote them down immediately.
The User interface comes up as Bloggs in the bottom left and no name at top.
I could not log in remotely as either Fred or Bloggs.
Examining HASSWP/config/.storage/auth it shows a user “Bloggs” but lower down under credentials it has username “fredbloggs”. Note all lowercase though I was particular abut entering capitals initially.
In auth_provider.homeassistant it has username “fredbloggs”
No way did I enter the names on one line by mistake.
However I can now log in as fedbloggs remotely. It is the name not the password that is the problem.
It may be that the problem is in the way the install handles data entry initially.

Me too – Me Too – Me Too —> SOLVED - VERY EASY !!!

Twice so far HA has eaten my password… or worse!
I was totally logged out of HA and had created a new system so there was no ssh or other way in.
I had not realized that there was actually useful command in the HA console !
I finally did figure out though how to use the console in HA !
In the console type:
authentication reset --username “my_username” --password “my_password”
AND BINGO! my password was reset and I can now log in to HA, through the dashboard !
Amazing !

[core-ssh ~]$ authentication reset --username “redacted” --password “redacted”
-bash: authentication: command not found
[core-ssh ~]$

It’s not working for me in the console in the latest version.

I discovered that my display name was uppercase and my username was lowercase but to log in locally I had to use upper case go figure. Your milage may vary…

1 Like

That finally helped me figure out my login problem. lowercase username

1 Like

First time joining and posting here…

Just started using Home Assistant and ran into this issue except my cause and solution is different. Short of it is, my keyboard layout was different when I created the password. My username was correct and matched what I typed, but my password had special characters that were swapped with others because of the keyboard layout. Specifically, the characters for " and @ were swapped on the keyboard. So when I typed one, I would get the other. Typing, for example, ‘p@ssword’ would be ‘p"ssword’ in Home Assistant, but you can’t see that by default. When I found out my keyboard was doing this and I typed in ‘p"ssword’ with my username to access Home Assistant, it worked. I found this out by typing my password characters on the command line and noticed the swap.

Details, (software downloads and versions as of 7/21/2022):

  • I freshly installed a Raspberry Pi 400 using the Raspberry Pi Imager (imager_1.7.2.exe) from Raspberry Pi OS – Raspberry Pi and the latest recommended image
  • I used the advanced configuration option to preset my image customization options. This precluded me from running through them on first boot
  • I booted my Pi400, installed docker, and downloaded/started the Home Assistant container
  • Ran through the setup process in Home Assistant which included entering a username and password. If I recall correctly, there was an “eyeball” I could have probably clicked on to see my password was not translating correctly through the keyboard, but I’m not sure
  • I installed Home Assistant on my iPhone and it found my Home Assistant server but would not accept the username and password. It gave error messages similar to those posted earlier in this thread about the “http.ban”
  • I rebooted my server and now I could not get in locally via the :8123 URL
  • Meanwhile, I was typing special characters in a terminal window and noticed some of them were getting swapped. Specifically, one of the ones I use in my password. The ‘@’ and ’ " ’ were being swapped
  • I went into my Raspberry Pi Configuration tool and looked at the “localisation->Set Keyboard” setting. It showed ‘English (UK)’ for both the ‘Layout’ and ‘Variant’. I changed them to ‘English (US)’ and my keyboard characters now mapped correctly. (btw, I also went back and changed the ‘Localisation->Set Locale->Character Set’ to UTF-8 instead of ISO-8859-1)
  • Now armed with the knowledge that characters in my password were swapped when I entered it into Home Assistant, I simply used the password using the substitutes for those swapped characters and voila, I was back in!

Hope this helps someone out there with the same obscure scenario. Thanks to all of you with the troubleshooting tips that helped me verify my username and find the logs. My takeaway is I am always going to click on the eyeball if there is one so I can verify my password is what I think it is : - )

I had this issue because I typed the username as the name in people rather than the username from users

It had different capitalization.
The username spot is case sensitive

So I typed in lower case and in worked


I ran into this issue of HA throwing the incorrect userid or pw error message too.
Opened a new Incognito window in Chrome browser and tried again and it worked.
My conclusion therefor is that if you’re 100% sure your username and pw are correct, it must have something to do with browser caching.

I’m a first time user by the way, just installed it in a VM on a Synology NAS and started playing with it. Awesome. And all you guys on this forum trying to help others rock!!!

Just ran into this issue after not touching my setup for a few months. The Android app stopped working and when I tried to reinstall I “couldn’t” log in.

It would be nice if HA would show the username somewhere in the “Profile” screen. You can change your password there, but nowhere are you shown the username, just the display name. I was still logged in on my desktop, so if the username had been available in the UI this would have been very simple to get past, no shell required.

1 Like

It is shown in the UI

Open your Home Assistant instance and show your users.

Bumping this to report the same issue!

Seeing this on MacOS Ventura, MacBook Air M2.
I am able to connect from my iPhone and my Windows computer just fine.

Hope this gets more traction!

Clear your cache and refresh the page and then log in.

Makes no difference

I’ve been hitting this more frequently too. It’s pretty odd because I know my username and password are correct but it rejects them. I SSH’ed into my system and did a host reboot and I after the reboot could log in with those exact credentials over Nabu Casa but locally I cannot. It’s very frustrating.

I noticed that this problem occurs on the Mac using Safari with autofill password.

If I let Safari autofill the userid and password, it’ll say invalid password.

But if I then display the password, copy it, then manually retype the userid and paste the password, it’ll work.

Note: just leaving userid filled in there and just paste in the password won’t work. You have to re-type the userid and paste (or type) the password.

The 2FA under Safari also does not work (autofill). You have to manually type (or paste) it in.

Using Chrome works but then again, I don’t have the password saved in Chrome so I’m always doing copy and pasting.


This was exactly the problem for me. 2 hours of my life I won’t get back :joy::sob:

This is exactly what happens for me when using safari (thanks for giving the solution, at least I have a work around). This is only a fairly recent issue. It really seems like more and more releases have annoying issues like this, it is really starting to get extremely frustrating and every time I update anymore I always wonder what’s going to break THIS time.