Petoneer Smart dot add-on

I did some restarts of whole HA today while updating Lovelace UI but still no luck.
Smart Dot unplugged also.
It will be superb if You will manage to work on it :slight_smile:
Anyway thank You for your work.

1 Like

Today I tried with recreating input select and automation:

* Uncaught
* Uncaught TypeError: Failed to execute 'observe' on 'MutationObserver': parameter 1 is not of type 'Node'.
* Uncaught

I can’t find the integration

This add-on is still supposed to work?
hen trying to start it I get this error message: s6-overlay-suexec: fatal: can only run as pid 1

It is not an integration. It is an addon.

Hi everybody, unfortunately I didn’t have much time to work on it.
In particular, given the new capabilities of HA regarding Bluetooth, I’d love to create a proper integration (not just an add-on), but due to my limited of python knowledge I’m quite blocked.
Any help would be very appreciated!
In the meantime I’ve created earlier a webapp that you can use to control the smartdot, in case at least you want to get rid of the smartdot app. You can find it at

Is your Smart Dot the Tuya compatible one? I haven’t managed to connect mine via he webapp but I can connect to it with nrfconnect from the same phone(s).

Can you document the BT protocol on GitHub to help developers on other platforms?

1 Like

Here it is GitHub - marcomow/petoneer-smartdot-bluetooth-protocol: The Petoneer Smartdot Bluetooth protocol reverse-engineered !

I think that having enough Python (and Home Assistant) knowledge such integration should be quite trivial to develop.

I hope that someone could pick it from here, otherwise you’ll have to wait when I will have time to learn and work on it :slight_smile:

Thanks for that. Seems we have different versions since mine has encrypted BLE traffic.

I’ve just converted mine to a WiFi with a module transplant because it was easier for me.

Hi @marcomow, thanks for all your work on this.

I believe I am having the same issue @blakadder mentioned above, I have been trying for a few weeks to integrate my Petoneer Smart dot, but unfortunately all the communication is encrypted (in my case I bought mine on Aliexpress - TY001). I have tried reverse engineering the Petoneer apk as well to see how the connection is done, but with no success.

Could you please just confirm what version of the smartdot you have or send a picture of the bottom of yours so we can confirm this theory?

I would like to have a working home assistant addon (if possible)

Hey, that seems very interesting. What are the sensors and controlling possibilities you have available in haas with that modification?