Philips Hue Play HDMI Sync Box integration

This integration makes the Philips Hue Play HDMI Sync Box available as a media_player in Home Assistant. I have (temporarily) mapped some of its functionality on standard media_player features so they are easily accessible through the default card.

Below follows the installation instructions from the readme. For the latest documentation check the Github repo.

README.md

Make sure the Philips Hue Play HDMI Sync Box has been setup with the official Hue Sync app before adding it to Home Assistant.

HACS

  • Install the integration from within HACS
  • Restart Home Assistant.
  • Devices will be found automatically.

Manually

  • Install the custom component by downloading it from the Github releases and copy it to the custom_components directory as usual.
  • Restart Home Assistant.
  • Devices will be found automatically.
7 Likes

In case anyone is following the topic.
I made some updates the past few days.

These are the highlights:

  • No need to include huesyncbox: in configuration.yaml anymore
  • Link procedure is more robust
  • Added device actions to make it easier to build automations

Im looking to incorporate a button that would start the “sync” of the lights on my HA dashboard. Would that be possible with this integration?

1 Like

Yes that should be possible.
As the box is currently exposed as a mediaplayer you can simply use the default mediaplayer card.

If you want your own button you can call the media_player.media_play service to start syncing.
As an alternative you can call the huesyncbox.set_sync_state service which offers more options. For example always start in “video” mode or on a specific input. You can play around with this service in the Service tab of the Developertools in Home Assistant to build the exact command you want.

3 Likes

Awesome. Thanks for the reply. I have a harmony hub to manage the inputs, this will be nice to start light sync on my mounted dashboard instead of going into hue app.

2 Likes

Maybe you already know, but you can also control the Philips Hue Play HDMI Sync Box with the Harmony Hub.

https://support.myharmony.com/en-us/harmony-experience-with-huehdmi-syncbox

This is true, however, it only does it over IR, which is, well, lame.

Hmmm, installed through HACS and restarted home assistant, but I don’t see anything under developer tools for the hue sync box.

Mine isn’t being discovered either and I’m thinking it’s because it’s on a separate VLAN.

thanks that worked, I have been away from HA for awhile.

Here is how I integrated it!

2 Likes

I don’t know a lot about VLANs, but the box uses mDNS for the discovery. Maybe that is something you can/haveto configure with VLANs?

That dashboard looks nice. What is it?
It does not seem to be the default Home Assistant user interface

I had mDNS already setup. The way I got around it was to add an virtual LAN interface on my IoT VLAN. Then it finally got discovered.

It is a combination of this custom side bar card and this love lace soft ui.

1 Like

Any of you clever people figured out how to change the Entertainment zone without using the Hue Sync App?

For example, movies I prefer only certain lights and 25-30% brightness with high intensity, but for DJ sets/music I like a larger entertainment zone with higher brightness.

The brightness levels I can script to various room modes/scenes, but I’m just missing the ability to change the Entertainment zone.

Changing the entertainmentarea is currently not possible with this integration.
However it seems to be available on the API of the syncbox so it could be added.

Just not sure how to expose in through Home Assistant as you would also need to know the available entertainment areas.

Thanks - I’ll check out the API documentation, should then be easy enough to just create a couple static ‘rest_command’ entries to do what I need and then map to buttons/drop down menus.

I actually still control my Hue bridges using rest_command, due to a previous bug with multiple bridges and scene names - never did migrate back to the official scene control, assuming that bug was fixed :slight_smile:

EDIT: Seems to work with curl, but I’m guessing I need to find a way to trust the self-signed cert, so probably using ‘shell_command’ is the way forward with curl -k:

curl -k -X PUT -H "Authorization: Bearer looooooongtoken" -H "Content-Type: application/json" -d '{"groupId":"10"}' https://x.x.x.x/api/v1/hue

Where groupID is an entertainment group, from the groups section, on the main bridge.

EDIT 2: Ah ha, verify_ssl: false, so I end up with:

  set_huesyncbox_entertainment_area:
    url: https://x.x.x.x/api/v1/hue 
    method: PUT
    verify_ssl: false
    headers:
      Authorization: 'Bearer looooongtoken'
      accept: 'application/json, text/html'
    payload: '{"groupId":"{{huessyncentertainmentgroupid}}"}'
    content_type:  'application/json; charset=utf-8'

Then I can specify the groupID number with huessyncentertainmentgroupid as a data variable.

I added an issue for this so I won’t forget about adding it in the future as I can’t look into it right now.

1 Like

Just moved my box to an IoT VLAN and saw the same… For me, it was a firewall issue.

I’d enabled (temporarily) OPNsense mDNS repeater on the IoT VLAN as well, allowed a firewall rule into the IoT VLAN (Protocol UDP, Source Any, Dest 224.0.0.251, Port 5353)…

But I had forgotten to enable ‘IP Options’ on the above rule, so multicast was still filtered.

“This allows packets with IP options to pass. Otherwise they are blocked by default. This is usually only seen with multicast traffic.”

After that, I turned off the mDNS rule again and disabled the mDNS repeater on the IoT VLAN. Which I’m hoping I can keep it like this.