Picture for person component and Zone naming Enhancement for "home" and "not_home"

It would make sense to be able to set a picture for the person component as per devices

I know it can be acchieved using customize for a specific entity using entity_picture, but due to the origin of the component, it would make perfect sense to be able to assign an image directly to it as we can already do for known_devices entities.

Another thing I have noticed is that the zone names are correctly picked up:
But once you are home or away it doesn’t show nice naming as the device tracker do

To make it clear, device tracker say “Home” and “Away” while person say “home” and “not_home”.

The device tracker way is much “nicer” to see when integrated in Lovelace for visualization

Well, just installed 0.89.0 and the home/not_home Home/Away thing has actually been fixed.

A picture is still missing so I guess that FR remains :slight_smile:

You can set picture via customization section in your config file.

Yes, I know and I wrote it, this a FR because a picture should be part of a “person” entity as it is for the devices in known_devices

Did you have an example? In the config.yaml or customization.yaml?

    entity_picture: local/images/andrey.jpg

Awesome! Thanks!

Thanks for posting this. I had previously tried to customize Person.xxxxx to show an image by overriding the “icon:” setting which did nothing at all. Did not know about this “entity_picture” parameter. It works!

Seems like this FR isn’t needed, but a documentation update sure is.

Don’t know what I’m doing wrong, but this isn’t working!
Below entry in cusomize.yaml
entity_picture: /local/Lance.jpg

I’m able to add the picture using /local/Lance.jpg in know devices for the tracker Ariela creates, but can’t add the picture to the tracker Owntracks creates

My experience to help if anyone makes my own mistake:

First I added in customize.yaml

  entity_picture: local/Claudia_192.jpg

without the slash before local. Weird behaviour, the icon showed correctly in the Person card but not in the presence badge.

Adding the slash, as in

  entity_picture: /local/Claudia_192.jpg

the picture started showing also in the badge. A restart was needed to pick the change.

You can also change this in the UI:

Configuration > Customization, select the entity, then click on “Pick an attribute to override”.
Select “Other”. In Attribute name, type “entity_picture” and in the Attribute value type “/local/image_name.png”. Don’t forget to click “SAVE
Shouldn’t need to restart to see the change

1 Like

Yes, I made a mistake also that way… :grin: at first I put “entity_picture:” (with the semicolon) as Attribute name. Ended up with something like this (not working) in customize.yaml:

  "entity_picture:": local/Claudia_192.jpg

That made the configuration editor go crazy (showing the configuration two times, not saving the changes), I had to edit the file directly.

Hi, I can not find the entity “person” in the list of customization page: I did the customization on the device_tracker entity.
Is it normal?