Playstation 4/PS4 custom component

media_player
Tags: #<Tag:0x00007f4801d70e60>

#82

Happy New Year 2018. Got it works. Thank you very much ^^


#83

Hi
when my PS4 is off i get this error.
Failed to call info: {“status”:“Could not detect any matching PS4 device”}
13:04 custom_components/media_player/ps4.py (ERROR)

Anyone can help me ?


#84

Has to be in ‘Rest Mode’ for it to detect and turn it on.


#85

Start MediaPlayer and change Source with delay/loop

has anyone tried an automation to turn on the PS4 and start a Game?
It needs to be turned on and notice when its on/idle and then select the source. I’m not sure how the checking/noticing would work. It needs to be some kind of loop.


#86

I use a command link switch:
sudo ps4-waker start cusaxxxx

  • where x is the number of the game located on the spine of the game case

#87

Fantastic guide. Total noob like me got it working.

Couple things I want to mention in case anyone else runs into this issue using your guide.

It took me a while to get the PS4-Waker to show up in the second screen companion app. I had to restart the pi after having the mofified ps4.py file in place, and the configuration.yaml set up with the ps4 as a media device. I was afraid to do this at first because i was getting config errors with the config file checker. Once i copied the mofied ps4 file, the errors went away, rebooted, and the Ps4 waker showed up in the companion app (after a minute or two).


#88

Brilliant explanation, just followed all your steps and it works, thank you so much.


#89

Hey there. I am migrating to HassIO, but have trouble with my ps4 component.

I get this ps4-waker -c /config/.ps4-wake.credentials.json -d 192.168.REDACTED.REDACTED -t 5000 search

After rebooting the pi, in the docker image of ps4-waker, there is still the ps4-creds.json and options.json file.

In the SSH container with the configurations, there is the .ps4-waker.credentials.json file with the information I got from the ps4-waker container.

What bugs me, I don’t have the ps4-waker command on neither docker container. ps4-waker, the homeassistant-raspberrypi3 or supervisor.


#90

Has anyone managed to get the cover art to show?


#91

hi all…

after upgrading to hass 0.61.1 aio venv install i get following error:

2018-01-22 00:01:29 ERROR (SyncWorker_14) [custom_components.media_player.ps4] Error decoding ps4 json : Expecting property name enclosed in double quotes: line 1 column 3 (char 2

Which file is meant here ? credetials or what?

WOuld love seeing it working again :slight_smile:


#92

i get exaclty the sam error… it worked before updating to hass 0.61.1. did u solve this issue?


#93

it’s the result file from the ps4-waker command, so I added an extra error logger so the json is dumped to the log when there is an error

on my setup it works fine, so it must be because there is an error in the stuff returned from the ps4-waker command


#94

Is it just me or do the images not currently load? Running on Hass.io using the guide posted in this thread. Everything else works great (awesome job hmn).


#95

I don’t have a hass.io setup running, so I can’t test that one out

But @hthiery and I am working on adding the component to the main repos without having to use the ps4-waker command so hopefully it should be easier to run in the future


#96

Music to my ears, thanks very much :slight_smile:


#97

I didn’t change anything butbonky installed newest has version. How could I debug… I’m not the inky one with this issue :frowning:


#98

I set the name parameter in my configuration and it started working. I believe the documentation says it’s optional, but I couldn’t get it to work until I set the name.

- platform: ps4
  host: xxx.xxx.xxx.xxx
  name: "PS4"
  cmd: 'sudo ps4-waker'
  filename: 'ps4-wake.credentials.json'
  games_filename: 'ps4-games.json'

#99

Good point.was wondering as I also did not add a name …now I added name in double quotes …restarting has and…


#100

Still same issue but I’m using another config…let me check again


#101

Nope.nothing works