Probably bricked my Home Assistant - some unbricking tips would be helpful!

Hello dear Hass community! :slight_smile:

I’ve not done a great job keeping my hass up to date. I’ve just tried to upgrade to the latest version from one of the 2023 versions I wanna say… I can’t remember now and since my Raspberry PI is not responding I can’t check.

So any unbricking steps would be helpful! After I hard reset (kill the power) to my Raspberry Pi, it comes back briefly online. And then it dies. Even my router doesn’t see it. What is the best thing to do now? Do I need to reinstall the OS on the SD card? I don’t really want to do it since I’ll probably lose my integrations and automations. I think I do have a backup somewhere, but it’s definitely more outdated than my previous HASS version…

I guess the most convenient thing for me at this point would be to fix the issue straight on the sd card (without booting the OS, just mounting it on my PC). Has anyone tried that? Any tips here at all?

Otherwise the annoying thing is that the PI takes longer to boot up after power cycling than it’s responsive for and I feel like it’d be a loosing battle…

Have you hooked up a monitor and keyboard to the rPi? If so you can downgrade the version until it kicks back in again. My guess is that you have a bunch of stuff not designed for the latest version and that is why it is “bricked”. If it’s not that then the console will tell you what is going on - you could just have a worn out SD card, hard to know until you get a monitor on it.

Just for future reference:

How to Troubleshoot Raspberry Pi Crashing.


Disaster Recovery Planning.

Wonderful, thanks guys! This is exactly the kind of help I was looking for!

Gonna hook up a monitor (completely forgot about this for some reason :sweat_smile:) and check the logs.

I might try downgrading when I get access to it.

Will have a play around and check back in :slight_smile:

Hello again!
So I’ve finally found some time to play with the Pi. The device was actually all fine when I hooked it up to an external screen. I decided to go all in and upgraded core to the latest version. The update took a while but all was fine so decided to put it back in its place (generally it’s not sitting on my desk :smiley: ). Then it stopped responding again. The interesting thing is that it dies (becomes unresponsive on the web UI and ssh) whenever I connect the Zigbee dongle. Any ideas where I could look for more informative logs? How could I fix this guy? Which plugin should I remove/reinstall?

I’ve not really found anything too helpful for me in the logs. This is the only error from ha core logs:

Any further debugging/fixing tips would be hugely appreciated!

There are some issues with HAOS 12.3 You might want to drop back to 12.2

Issues · home-assistant/operating-system · GitHub.

And these are the last supervisor logs from when the Pi died:

The zigbe2mqtt/log/2024-05-08-* logs are empty.

You can try some of these if you are feeling brave: 2024.5+: Tracking down instability issues caused by integrations.

Thanks! That was it!

Ran ha os update --version 12.2 and my Zigbee dongle started working once again :raised_hands:

1 Like