Problem booting if I enable http section

A few releases before I had to comment http section in configuration.yaml because if enabled Homeassitant did not work.
I have updated to last version and I wanted to enable again http section beacause I need it for accesing remotely using https.
If I enable it and reboot, then Homeassistant does not start and I have to connect using ssh for deleting http section.
Is anybody actually using http section ?
thanks

Nearly everyone uses it. Post your non working configuration (correctly formatted) or we cant help you.

1 Like

Thanks, this is my Duck dns config

lets_encrypt:
  accept_terms: true
  certfile: fullchain.pem
  keyfile: privkey.pem
token: 1111111-1111-1111-1111-1111111111111
domains:
  - perahome.duckdns.org
aliases: []
seconds: 300

And this is my configuration.yaml

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 1111111111
  longitude: 11111111111
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: UTC
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
introduction:

# Enables the frontend
frontend:
ios:
# Example configuration.yaml entry
mobile_app:

http:
   base_url: https://perahome.duckdns.org:19855
   ssl_certificate: /ssl/fullchain.pem
   ssl_key: /ssl/privkey.pem

google_assistant:
  project_id: 1111111111111
  api_key: 11111111111111111111111111111111111111111111111111
  exposed_domains:
    - switch
    - light
    - group
    - scene
    - cover
  entity_config:
    cover.fibaro_system_fgrm222_roller_shutter_controller_2_level_4:
      name: PUERTA_PARCELA

# Enables configuration UI
config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: peranhome.duckdns.org:8123
# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Homekit
homekit:
  auto_start: False

# Sensors
sensor:
  # Weather prediction
  - platform: yr

# Text to speech
tts:
  - platform: google_translate
    service_name: google_say

# Cloud
cloud:

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

I have replaced sensible information with “11111”

Thank you very much

Indentation doesn’t look right. Should be:

http:
  base_url: https://perahome.duckdns.org:19855
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

And there isno longer a base URL, there is an external_url, and an internal_url. Set them both to your current base URL.

Thanks 1 [quote=“PlayedIn, post:4, topic:204469”]

http:
  base_url: https://perahome.duckdns.org:19855
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

[/quote]

like this?

http:
  external_url: https://perahome.duckdns.org:19855
  internal_url: https://perahome.duckdns.org:19855
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

No. I forgot. The internal and external URLs go under homeassistant: now.

same error with this config:


homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 40.440111
  longitude: -3.918956
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: UTC
  # Customization file
  customize: !include customize.yaml
  external_url: https://perahome.duckdns.org:19855
  internal_url: https://perahome.duckdns.org:19855

# Show links to resources in log and frontend
introduction:

# Enables the frontend
frontend:
ios:
# Example configuration.yaml entry
mobile_app:

http:
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

google_assistant:
  project_id: controlhogar-d9839
  api_key: 1111111111111111111111111111111111111
  exposed_domains:
    - switch
    - light
    - group
    - scene
    - cover
  entity_config:
    cover.fibaro_system_fgrm222_roller_shutter_controller_2_level_4:
      name: PUERTA_PARCELA

# Enables configuration UI
config:

I see this info in logfile:

2020-06-13 18:04:52 ERROR (MainThread) [homeassistant.setup] Setup failed for introduction: Integration not found.
2020-06-13 18:04:59 ERROR (MainThread) [homeassistant.components.ipp] Error fetching ipp data: Invalid response from API: Error occurred while communicating with IP>
2020-06-13 18:04:59 WARNING (MainThread) [homeassistant.config_entries] Config entry for ipp not ready yet. Retrying in 5 seconds.
2020-06-13 18:05:00 ERROR (MainThread) [homeassistant.config] Invalid config for [google_assistant]: The 'api_key' option is deprecated, please remove it from your >
2020-06-13 18:05:00 ERROR (MainThread) [homeassistant.setup] Setup failed for google_assistant: Invalid config.
Setup failed for introduction: Integration not found.

Remove:

introduction:

It has been removed from home assistant.

still same error tryin to access site.

I noly see this info in logfiles:

2020-06-13 18:36:19 ERROR (MainThread) [homeassistant.components.ipp] Error fetching ipp data: Invalid response from API: Error occurred while communicating with IPP server.

The only wayt I found for booting fine is commenting http section :frowning:

Thask for your help!!!

1 Like

When you don’t comment out the http from configuration.yaml, is the url of HA you’re using to connect to, https instead of http?

I commented it but now I can only access using http, and I need to connect using https.

Thanks!!!

I recently saw a post by frenk saying that internal and external are not generally needed (I’ve never used them) unless for a specific need / requirement (no idea what that would be)
I connect both internally (local) and externally (remote) take a gander at : -

Does anyone know of a solution to this problem? I would really appreciate your help.

I have the exact same issue

  • If I add the HTTP section into the configuration.yaml, HA won’t boot
  • HA boots fine if I delete HTTP section

My difference with OP is that I’m using the latest version as of last week (I’ve never installed a previous version as I’m new to HA). I installed via Virtual Box on a windows machine using HA Hassio’s VDI file

My “configuration.yaml” is pretty bare


# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml


homeassistant:
  external_url: https://xxxxxxx.duckdns.org
  internal_url: http://192.168.x.xx:8123

http:
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

However I don’t see any error messages in “home-assistant.log” when boot fails:

2020-12-22 10:17:04 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=73 from 2020-12-22 18:10:37.290255)
2020-12-22 10:17:43 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave node 11 not ready after 30 seconds, continuing anyway
...(several other warnings about zwave)

My eventual goal is to get DuckDNS working for external access. I also tested by stopping DuckDNS (also disable on boot) , then add HTTP and see if HA boots… same problem.

Solved!

Someone on reddit helped me realize that I need to use HTTPS to access the front end instead of HTTP once I include the http section in configuration.yaml