Pushing Images with Pushover 3.0

I had this working in my docker container on 0.94.3

But now I’ve moved over to HAssio on a RPi3 on 0.94.3 and I also get the attachment: invalid message parameter error. I’ve been pulling my hair out, it just won’t work… :exploding_head:

Are you using pushover as the custom component name, and do you have a manifest.json file with the 0.4 version of the pushover library referenced? My theory is that you need to have the custom component shadow/pre-empt the stock pushover component, and you need to have the newer library version present in the manifest file. That error message is evidence that the older version of the pushover python library is being used.

Yes, I have the manifest with version 0.4 referenced.

I literally just copied the folder from my Docker to the raspberry. I can see in the startup log that the custom component is loaded (as you get that warning message about using custom components).

None of my messages work at the moment though due to the ‘invalid message parameter’. I need to remove the custom component to even send a standard pushover notification.

Where on my Docker container, it’s still working fine.

As one datapoint, when I look inside my Docker container (via docker exec -it hass bash) I notice this:

[email protected]:/usr/local/lib/python3.7/site-packages# python -c 'import sys; print(sys.path)'
['', '/usr/local/lib/python37.zip', '/usr/local/lib/python3.7', '/usr/local/lib/python3.7/lib-dynload', '/usr/local/lib/python3.7/site-packages']
[email protected]:/usr/local/lib/python3.7/site-packages# head -5 /usr/local/lib/python3.7/site-packages/pushover.py
# pushover 0.4
#
# Copyright (C) 2013-2018  Thibaut Horel <[email protected]>

# This program is free software: you can redistribute it and/or modify

which indicates that the newer dependency for version 0.4 of the pushover library got installed in what looks like the standard python library path for site-specific packages.

I wonder when hass.io resolves package dependencies, where/if it managed to install the 0.4 version of the pushover library, and if the sys.path in the running Home Assistant would resolve to the newer version if it didn’t get put into the same place. Maybe there’s something different here with how hass.io supports its own extensions? Just a wild-ass guess on my part.

I can’t get it to work, I tried everything above but no luck

I noticed this thread Integrating Blue Iris, Pushover, Node-RED, and Amazon Rekognition which is another means of getting access to this capability via Node Red. This might be something to consider if you’re already using Node Red…

I’m using HA in Unraid in container and had the same issues…
I simply updated it in container console by running:
pip3 install --upgrade python-pushover
And I restarted the container.

Works fine now.
Just in case it help users with this setup.

1 Like

Yep, this worked for me

sfnetwork wrote:
I simply updated it in container console by running:
pip3 install --upgrade python-pushover

I saw someone else mentioned that above, but how do I do that from hassio?

FYI, after updating to HA 0.94.4, still the same issue.

I use portainer and opened a console session on the home assistant container and ran the command.

1 Like

Your explanation and portainer helped solve the problem. HassOS 2.11 v0.94.4, sending images again working.

1 Like

I just upgraded to 0.95 and it looks like I still need to run the command with this version.

pip3 install --upgrade python-pushover

Anyone know when it will be bundled into the normal releases?

2 Likes

Thank you!! I was pulling my head (I am bald) with this! Thanks for the link, after I installed it on the custom_components folder, I started getting the new messages with pictures attached!
Great!!!

someone running this on hass.io without docker?thanks

I am running hass.io without docker, it works as described above. Logging in via ssh

Am running Pushover on Hass.io ver 0.95.4 without docker. I used Portainer Hassio addon to access the root, and than run the command. And it works !

Powefull App handle with care.

pip3 install --upgrade python-pushover
1 Like

I need install portainer then? Container console is installed by default?

Yes. In the portainer quide you will see how to unhide the Home assistant Container.

Known issues and limitations

By default all Hass.io managed containers are hidden from Portainer. This is recommended since fooling around with Hass.io managed containers can easily lead to a broken system.

Access to these containers can be gained by going into Portainer -> Settings -> Hidden containers. Then delete the listed hidden labels (io.hass.type labels). Only do this if you know what you’re doing!

1 Like

right now its working again,thaks a lot everyone for help

it looks like this has been officially added in the next release

Add ability to send attachments in pushover notifications (#24806)

1 Like