RaspBee2 not working

This is my first try to use home assistant, so I am very new to it.
I installed HomeAssistant on my Raspberry Pi with HA OS and Supervisor.

So far, the OS is working fine.
To connect some ZigBee devices, I bought the RaspBee 2 (RaspBee II Installation).
I plugged it onto the pi, rebooted and thought ‘here I go’. I tried hto add the integration for ZHA. According to this (Zigbee Home Automation - Home Assistant), I selected the only available serial device path (/dev/ttyAMA0) and let the ZHA try detecting the radio type, which failed. So, I selected the ‘deCONZ’ radio type and typed manually the serial device path ‘/dev/ttyAMA0’. So, it says ‘connection failed’.

So, I tried to install the deCONZ Add-On, where I also selected the /dev/ttyAMA0 device because its the only one selectable.
With debug, the log says the following:

s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] firmware.sh: executing... 
[10:08:58] INFO: GCFFlasher V3_17 (c) dresden elektronik ingenieurtechnik gmbh
Path             | Vendor | Product | Serial     | Type
/dev/ttyAMA0     | 0x0000 | 0x0000  |            | RaspBee 
[cont-init.d] firmware.sh: exited 0.
[cont-init.d] nginx.sh: executing... 
[cont-init.d] nginx.sh: exited 0.
[cont-init.d] novnc.sh: executing... 
[cont-init.d] novnc.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[10:08:59] INFO: Running the IKEA OTA updater...
[10:08:59] INFO: Running the deCONZ OTA updater...
[10:08:59] INFO: Running the OSRAM LEdvance OTA updater...
[10:08:59] INFO: Websockify waiting for VNC to start
[10:09:00] INFO: Starting VNC server (local/yes)...
[10:09:01] INFO: Starting websockify...
[10:09:04] INFO: deCONZ waiting for VNC to start
[10:09:04] INFO: Starting the deCONZ gateway...
WebSocket server settings:
  - Listen on
  - Flash security policy server
  - Web server. Web root: /usr/share/novnc
  - No SSL/TLS support (no cert file)
  - proxying from to
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
[10:09:11] INFO: Starting Nginx...
2021/10/20 10:09:11 [notice] 316#316: using the "epoll" event method
2021/10/20 10:09:11 [notice] 316#316: nginx/1.14.2
2021/10/20 10:09:11 [notice] 316#316: OS: Linux 5.10.17-v8
2021/10/20 10:09:11 [notice] 316#316: getrlimit(RLIMIT_NOFILE): 1048576:1048576
2021/10/20 10:09:11 [notice] 316#316: start worker processes
2021/10/20 10:09:11 [notice] 316#316: start worker process 1352
10:09:11:366 HTTP Server listen on address, port: 40850, root: /usr/share/deCONZ/webapp/
10:09:11:717 dev /dev/ttyAMA0
10:09:11:717 COM: /dev/ttyAMA0 / serialno: , RaspBee
10:09:11:718 ZCLDB init file /data/.local/share/dresden-elektronik/deCONZ/zcldb.txt
10:09:12:102 parent process s6-supervise
10:09:12:102 gw run mode: docker/hassio
10:09:12:103 GW sd-card image version file does not exist: /data/.local/share/dresden-elektronik/deCONZ/gw-version
10:09:12:103 sd-card cid: 035344534c33324780ffffffff00f2d3
10:09:12:106 DB sqlite version 3.27.2
10:09:12:108 DB PRAGMA page_count: 42
10:09:12:108 DB PRAGMA page_size: 4096
10:09:12:108 DB PRAGMA freelist_count: 0
10:09:12:108 DB file size 172032 bytes, free pages 0
10:09:12:108 DB PRAGMA user_version: 8
10:09:12:108 DB cleanup
10:09:12:113 DB create temporary views
10:09:12:139 started websocket server at port 8081
10:09:12:152 [INFO] - Found file containing button maps. Parsing data...
10:09:12:182 [INFO] - Button maps loaded.
10:09:12:187 dlg action: Read binding table
10:09:12:187 found node plugin: libde_rest_plugin.so - REST API Plugin
10:09:12:195 found node plugin: libde_signal_plugin.so - Signal Monitor Plugin
10:09:32:406 found node plugin: libstd_otau_plugin.so - STD OTAU Plugin
10:09:33:266 dev /dev/ttyAMA0
10:09:33:539 dev /dev/ttyAMA0
10:09:33:540 COM: /dev/ttyAMA0 / serialno: , RaspBee
10:09:33:654 Announced to internet https://phoscon.de/discover
10:09:33:655 discovery server date: Wed, 20 Oct 2021 08:09:33 GMT
10:09:33:656 	 local time seems to be ok
10:09:34:461 wait reconnect 5 seconds
10:09:34:599 dev /dev/ttyAMA0
10:09:34:600 COM: /dev/ttyAMA0 / serialno: , RaspBee
10:09:35:511 wait reconnect 4 seconds
10:09:36:562 wait reconnect 3 seconds
10:09:37:612 wait reconnect 2 seconds
10:09:38:614 wait reconnect 1 seconds
10:09:38:746 dev /dev/ttyAMA0
10:09:38:747 COM: /dev/ttyAMA0 / serialno: , RaspBee
10:09:39:614 wait reconnect 5 seconds
10:09:39:746 dev /dev/ttyAMA0
10:09:39:748 COM: /dev/ttyAMA0 / serialno: , RaspBee
10:09:40:614 wait reconnect 4 seconds
10:09:41:615 wait reconnect 3 seconds
10:09:42:615 wait reconnect 2 seconds
10:09:43:614 wait reconnect 1 seconds

The reconnects are going on as long as the add-on is running.

I found some tutorials with Mosquitto broker or something, this seems very complicated. Isn’t there a easier way to get the ZHA integration working?


See this topic:

I did the following:
I unsquashed the “disk” partition, created the config.txt in /mnt/boot/, added the line like in the topic above and squashed the partition.
But, after booting, the problem is still the same.

Sorry, but that seems totally wrong. There is nothing to squash or unsquash. You just have to edit (not add) your existing config.txt.
Not /mnt/boot just /boot

I searched all 4 partitions from HAOS for a config.txt, the one in disk/mnt/boot/ is the only one.
In the topic above, I am not sure if he was using HAOS or did it with containers…

OK, you’re not the first one that doesn’t find the boot partition on HA OS. There are 8 partitions by the way. Easiest way is to shutdown HA OS, insert the SD card in a windows computer and edit config.txt there.

Oh, alright… I’m running on Linux, this only was detecting 4 partitions.
Give me a few secs, I will be back soon.

Alright, I found and edited the config file with the dtoverlay=pi3-disable-bt part.
I started the pi, but nothing changed, there is still no connection to /dev/ttyAMA0.

Enable UART in the Kernel and disable UART use for BlueTooth.

In /boot/config.txt add following lines:


Remove the console entry by removing any of those entries from /boot/cmdline.txt if present:

console=serial0,115200 console=ttyAMA0,115200

Reboot your Raspberry.

Thank you, I was not aware enabling uart.
I don’t deleted the only line in the cmdline.txt: dwc_otg.1pm_enable=0 console=tty1
I rebooted, but still the same problem.

You are sure you uninstalled ZHA ? If both ZHA and deconz try to access the raspbee it won’t work either.

You mean in the Add-Ons? There are deCONZ, Mosquitto broker, SSH & Web Terminal and Zigbee2mqtt bridge, all of them were installed while trying to get ZHA working. Which should I uninstall?

I would uninstall deconz and zigbee2mqtt. These probably try to access the raspbee too, and only one integration can access the raspbee at the same time.

Thank you. I uninstalled and rebooted, but still the same… :confused:

what does

ls /dev/serial/by-id/

return ?

There’s no folder serial in dev, I already checked that :frowning:

Then I suggest you contact DRESDEN ELEKTRONIK tech support. Your raspbee may be defective.

Alright, I will do. Thanks man!
Just to be sure: The SSH & Web terminal can get access to all needed files and folders on the system, also /dev/serial/by-id/?

If protection mode is off : yes. I don’t know if protection mode is on.

I deactivated the protection mode just after install, so it should be able to.
I just mailed to phoscon support and will keep you updated.