Raspbian + Docker + HassIO

Do you have SSD and Conbee II on RPI4 with no problems?

Hello,
I have installed raspbian on raspi4.
I just tried to install this. I followed the guide, installed dependecies etc… I installed docker from apt, with apt install docker.io

But I dont understand, where is the actual home assistand application?

I installed with this, and now I can see two new docker images running.
curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s -- -m raspberrypi4

[email protected]:~# docker ps -a
CONTAINER ID        IMAGE                                   COMMAND                  CREATED             STATUS              PORTS               NAMES
370c9042a188        homeassistant/armv7-hassio-dns:1        "coredns -conf /conf…"   6 minutes ago       Up 6 minutes                            hassio_dns
e5bafe8489c2        homeassistant/armv7-hassio-supervisor   "/bin/entry.sh pytho…"   7 minutes ago       Up 6 minutes                            hassio_supervisor
[email protected]:~# ss -tln
State                       Recv-Q                      Send-Q                                           Local Address:Port                                             Peer Address:Port                      
LISTEN                      0                           128                                                    0.0.0.0:22                                                    0.0.0.0:*                         
LISTEN                      0                           128                                                       [::]:22                                                       [::]:*  

I ran the script a second time, and it started another container called homeassistant which listens on port 8123…

1 Like

Hello ,
can somebody recommend what I am doing wrong ?
I follow many guide and no of them work.

I follow official guide


does not work

then
this quide


I have stuck in last part docker attach --sig-proxy=false ada5bbfc74f0
does not work
trid also IOTstack what GACHAPO mention
does not work

those command what I have tried

sudo -i
apt-get update
apt-get install -y software-properties-common apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat
systemctl disable ModemManager
curl -fsSL get.docker.com | sh

apt-get update

wget https://download.docker.com/linux/raspbian/gpg

[email protected]:~# apt-key add gpg
OK

echo "deb https://download.docker.com/linux/raspbian stretch stable " | tee -a /etc/apt/sources.list.d/docker.list

apt-get update

apt-get -y install docker-ce

systemctl start docker && systemctl enable docker

curl -sL “https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh” >> hassio_install.sh
sudo bash hassio_install.sh -m raspberrypi4

[email protected]:~# sudo bash hassio_install.sh -m raspberrypi4
ModemManager.service enabled
[Warning] ModemManager service is enabled. This might cause issue when using serial devices.
[Info] Install supervisor Docker container
[Info] Install supervisor startup scripts
Created symlink /etc/systemd/system/multi-user.target.wants/hassio-supervisor.service → /etc/systemd/system/hassio-supervisor.service.
[Info] Install AppArmor scripts
Created symlink /etc/systemd/system/multi-user.target.wants/hassio-apparmor.service → /etc/systemd/system/hassio-apparmor.service.
[Info] Run Hass.io

[email protected]:~# docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
2d1ee939c70c homeassistant/raspberrypi4-homeassistant:landingpage “/run.sh” 10 seconds ago Up 8 seconds homeassistant
92def09042fe homeassistant/armv7-hassio-dns:1 “coredns -conf /conf…” 19 seconds ago Up 17 seconds hassio_dns
fc7d97c080a2 homeassistant/armv7-hassio-supervisor “/bin/entry.sh pytho…” 33 seconds ago Up 31 seconds hassio_supervisor

[email protected]:~# docker attach --sig-proxy=false 2d1ee939c70c
^C

this part attach does not work docker image looks for me ok but still I dont see hassio menu on HA.

my logs

[email protected]:~# docker logs fc7d97c080a2
20-03-01 01:01:51 INFO (MainThread) [main] Initialize Hass.io setup
20-03-01 01:01:51 INFO (MainThread) [hassio.docker.network] Can’t find Hass.io network, create new network
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Home Assistant configuration folder /data/homeassistant
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Hass.io SSL/TLS folder /data/ssl
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Hass.io Add-on data folder /data/addons/data
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Hass.io Add-on local repository folder /data/addons/local
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Hass.io Add-on git repositories folder /data/addons/git
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Hass.io temp folder /data/tmp
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Hass.io backup folder /data/backup
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Hass.io share folder /data/share
20-03-01 01:01:52 INFO (MainThread) [hassio.bootstrap] Create Hass.io DNS folder /data/dns
20-03-01 01:01:52 INFO (SyncWorker_0) [hassio.docker.supervisor] Attach to Supervisor homeassistant/armv7-hassio-supervisor with version 201
20-03-01 01:01:52 INFO (SyncWorker_0) [hassio.docker.supervisor] Connect Supervisor to Hass.io Network
20-03-01 01:01:53 INFO (MainThread) [main] Setup HassIO
20-03-01 01:01:53 INFO (MainThread) [hassio.utils.gdbus] Connect to dbus: org.freedesktop.systemd1 - /org/freedesktop/systemd1
20-03-01 01:01:53 INFO (MainThread) [hassio.utils.gdbus] Connect to dbus: org.freedesktop.hostname1 - /org/freedesktop/hostname1
20-03-01 01:01:53 WARNING (MainThread) [hassio.dbus.rauc] Host has no rauc support. OTA updates have been disabled.
20-03-01 01:01:53 INFO (MainThread) [hassio.utils.gdbus] Connect to dbus: org.freedesktop.NetworkManager - /org/freedesktop/NetworkManager/DnsManager
20-03-01 01:01:53 INFO (MainThread) [hassio.host.info] Update local host information
20-03-01 01:01:53 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/hostname1
20-03-01 01:01:53 INFO (MainThread) [hassio.host.services] Update service information
20-03-01 01:01:53 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.systemd1.Manager.ListUnits on /org/freedesktop/systemd1
20-03-01 01:01:54 INFO (MainThread) [hassio.host.network] Update local network DNS information
20-03-01 01:01:54 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/NetworkManager/DnsManager
20-03-01 01:01:54 INFO (MainThread) [hassio.host.apparmor] Load AppArmor Profiles: {‘hassio-supervisor’}
20-03-01 01:01:54 INFO (MainThread) [hassio.host.services] Reload local service hassio-apparmor.service
20-03-01 01:01:54 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.systemd1.Manager.ReloadOrRestartUnit on /org/freedesktop/systemd1
20-03-01 01:01:54 INFO (MainThread) [hassio.dns] No CoreDNS plugin Docker image homeassistant/armv7-hassio-dns found.
20-03-01 01:01:54 INFO (MainThread) [hassio.dns] Setup CoreDNS plugin
20-03-01 01:01:54 INFO (MainThread) [hassio.updater] Fetch update data from https://version.home-assistant.io/stable.json
20-03-01 01:01:54 INFO (SyncWorker_0) [hassio.docker.interface] Pull image homeassistant/armv7-hassio-dns tag 1.
20-03-01 01:02:02 INFO (MainThread) [hassio.dns] CoreDNS plugin now installed
20-03-01 01:02:02 INFO (MainThread) [hassio.misc.forwarder] Start DNS port forwarding to 172.30.32.3
20-03-01 01:02:02 INFO (MainThread) [hassio.dns] Start CoreDNS plugin
20-03-01 01:02:03 INFO (SyncWorker_5) [hassio.docker.dns] Start DNS homeassistant/armv7-hassio-dns with version 1 - 172.30.32.3
20-03-01 01:02:03 INFO (MainThread) [hassio.homeassistant] No Home Assistant Docker image homeassistant/raspbe

Your second link is rather old, probably out of date by now.

I’m guessing you are running latest Raspbian? I didn’t install the optional network-manager. With it my Pi 4 looses wifi after reboot.

On a fresh Raspbian install, try the following: (from here)

sudo -i
apt update
apt upgrade
apt install -y software-properties-common apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq socat

curl -fsSL get.docker.com | sh

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s -- -m raspberrypi4

problem solved I see menu does not call hassio but supervisor

I’ve recently moved to Docker + HassIO. For some reason, my HA update, when run from the GUI very rarely manages to do its job. The update doesn’t conclude, and the system seems to clog up somehow so I can’t even run any commands on it.

How can I troubleshoot this? What logs should I be looking at to find what the issue is?

Thanks,
Ville

I don’t use hassio o my knowledge is kind of limited on that.

But I think there are some supervisor logs that you can look at to tell you what is going on with the updates and the reasons why the update failed…I think.

Don’t ask me where those logs are located because I honestly have no idea.

SSH to raspbian (not home assistant)

issue

sudo docker ps -a

to list te docker containers. Find the id of supervisor

sudo docker logs <id of supervisor>

to view the log of supervisor

1 Like
docker logs hassio_supervisor

Should work. Sudo should be unnecessary if you correctly followed the instructions when you install docker and added the usual user to the docker group. You can also use a docker logs -f hassio_supervisor to give real-time updates. Use homeassistant instead of hassio_supervisor for homeassistant logs as well.

1 Like

Thanks for the swift replies. The updates have worked a couple of times for me since posting my question, but now I’m stuck with the same issue I had before, i.e. the homeassistant container fails to start properly.

It seems the logs don’t really capture what the issue is. Any ideas on how to dig up more info/fix the issue?

The hassio_supervisor log shows:

20-04-29 05:07:38 ERROR (MainThread) [supervisor.homeassistant] Error on call https://172.30.32.1:8123/api/: Cannot connect to host 172.30.32.1:8123 ssl:None [Connection refused]
20-04-29 05:07:38 INFO (MainThread) [supervisor.auth] Home Assistant not running, check cache
20-04-29 05:07:54 INFO (SyncWorker_6) [supervisor.docker.interface] Start homeassistant/raspberrypi3-homeassistant
20-04-29 05:10:18 ERROR (MainThread) [supervisor.homeassistant] Home Assistant has crashed!

The docker log for the homeassistant container shows:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] udev.sh: executing... 
[07:08:07] INFO: Update udev information
[cont-init.d] udev.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting. 

After Docker I installed Hassio-supervisor. New installation script is:

> sudo su
# curl -sL https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh | bash -s -- -m raspberrypi4

But I have error:

[email protected]:~# curl -sL https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh | bash -s -- -m raspberrypi4
[Warning] This installer is no longer supported.
[Warning] 
[Warning] Home Assistant might work today, tomorrow maybe not.
[Warning] 
[Warning] If you want more control over your own system, run
[Warning] Home Assistant as a VM or run Home Assistant Core
[Warning] via a Docker container.
[Warning] 
Please typ "not supported" to continue this installation
bash: line 17: syntax error near unexpected token `then'
(23) Failed writing body

The hassio_install.sh not actual now. What can I install HASSIO in Docker containers?

You need to copy the script and run it locally.

Not runing:

[email protected]:/home# curl -sL installer.sh | bash -s -- -m raspberrypi4
bash: line 1: !DOCTYPE: No such file or directory
bash: line 2: html: No such file or directory
bash: line 3: syntax error near unexpected token `<'
'ash: line 3: `<head id="ctl00_ctl00_Head1"><title>

This GitHub branch now is archived, and README.md announced: “This install method has been deprecated”. I see the another installation algorithm.

You need to run it locally. I used it yesterday!
(Also you don’t need to ‘curl’ it if you downloaded it - don’t use curl -sL)

./installer.sh | bash -s – -m raspberrypi4

Hello, due to this installation process not supported anymore (depricated), does someone know what are the new instruction/commands to type (for having hassio on raspberry desktop, indeed only way to keep the supervisor icon on HA session)? indeed I read in the message error that it could be possible, but I don’t know what to type :frowning:

1st option: flash the Home Assistant OS image for your Pi - you keep the supervisor, you lose access to a full OS

2nd option: Install Raspbian as the OS and install Home Assistant Core in venv or docker. You gain access to a full OS, you lose the supervisor.

Hello jason :slight_smile: I just realize that despite the installation is not supported anymore, the http://xxx.xxx.xx.xx:8123 seems to work and I see the supervisor. So I don’t really understand why it works :sweat_smile: do you think I will have a problem later on? (=I don’t understand "the installation is not supported :thinking:)

If I can keep my installation, I had another question : when I will restart my Rpi later , does someone know what are the commands I will need to type on the terminal, please? Thank you in advance for your help

Try my fork… curl -sL https://raw.githubusercontent.com/krdesigns-com/supervised-installer/master/installer.sh | bash -s -- -m raspberrypi4

1 Like