Reading UK smart meters

With the now introduction of SMETS2 meters. I thought I would look again at wether it is worth getting upgraded how to incorporate into HA. (Currently have a SMETS1 thats no longer smart since I moved supplier)

As I see it there are 4 options

  1. Direct comunication API to the meter.
    It look at least in the short term that direct comunication is not an option.

  2. Scraping the suppliers website for my data.
    This is not live data and would need some significant programing skill. Would also be different for each supplier and may not be even posiable for some.

  3. Flashing LED on the meter.
    Any one know if the new SMETS2 meters still have the flashing LED?

  4. Using the remote dispaly, a camera, and some OCR
    I have seen this idea mentioned once on the forum but not sure if its been done. Either with the seven segment reader of some dedicated sofware on a Pi, ESP3866 or similar.

Anybody tried and failed or got any of these or something else working succesfully?


Take a look at

It uses the freely available glow API to read the smart meter.

1 Like

I’ve just tried this and it seems to work in the app pretty well. Added the integration to home assistant, config seemed different to the instructions and have only got a sensor for electricity and gas for the current day, none of the others have showed up so far. So far I’m happy to get some form of monitoring in home assistant

After a bit of messing about it’s working perfectly with all the sensors showing up

How did you get the other entities to show up?
I can only see the consumption today.
Are you able to get rates as well? I am on E7 so could ideally do with rates pulling through as my night rate is cheaper than the day rate.

I’m not really sure to be honest, I thought I was on a forked version that someone else was maintaining but I’m the one posted above is the forked version. The first 2 times I added the integration I only got options for username and password. The third time of trying I got options to enter numbers for what I think is gas tariff. Then I got all the sensors

Have you just created your bright account? Maybe it needs some time to collect data before it works properly?

Yes I’d only just created the account. There was plenty of historic data loaded on Bright, however this doesn’t get transferred to Home Assistant.
Perhaps I’ll try deleting and re-installing the integration again. (I’ve only got electricity so hopefully that isn’t a bug that gets this working!)

it takes some time to get the first readings indeed.
I have however an issue getting the gas readings. I’ve reported this and apparently I’m not the only one and they’re working on fixing it…

Hi @fuziduck
Hopefully, in time @HandyHat will consider the pull requests.
In the mean time, you should be able to use the fork.

You will need to remove the original integration from HACS. Restart Home Assistant, then re-add the integration using the forked URL.
At this point, it should show two extra config parameters for GAS conversion to metric.
When started, the extra Cost and Tariff sensors should show up as soon as they are added.
They will have a status of “Unknown” until data is pulled via the API. This can take a few minutes.

I am not on E7, should would be really interested to know if the correct rates get pulled through - they should do, but have no way of testing.

Hi @ColinRobbins

I’m already using your release of this integration and unfortunately it still doesn’t come up with the tariffs. I wonder if E7 tariffs show up in a different way in which the integration cannot extract?
I’ll be honest I have no experience in programming any of this, however if I can help then I’m more than willing.

I have tried re-installing the integration a number of times, however I never get more than the 1 entity. (Its been left now for over 24hrs with auto updating for newly discovered entities checked.)

In the Bright app I can see the tariff changes on a graph, however it doesn’t quite reflect the tariff I’m actually on according to my bill!

Can you see the sensors in HA?
There should be 10 sensors showing, for example sensor.electric_tariff_rate.
If there are not 10 sensors, then the code is getting configured correctly, and no data will get pulled through.
Is there anything in the logs?
When you added the integration via HACS, did you see the two configuration parameters for GAS, as well as username and passowrd?
Finally, can you take a look at the file custom_components/hildebrandglow_dcc/manifest,json and tell me what version it is saying you have?

Ok I’ll try and answer in order.
1.) I can only see sensor.electric_consumption_today
2.) Nothing that I can see in the logs, which specific log should I check?
3.) No I didn’t see any configuration for GAS I only had the username & password fields.
4.) “version”: “0.3.3” (I did see a number of other versions when I went to install on HACS however this was the pre-selected version)

@fuziduck, it looks like you are picking up the HandyHat version still.
I suggest…

  1. Remove the integration from the configuration / integrations page
  2. Remove the integration from the HACS / integrations page
  3. Restart HA
  4. Check custom_components/hildebrandglow_dcc has been removed.
  5. Check the sensor.electric_consumption_today has gone.
  6. Restart HA
  7. Re-add the integration into HACS
  8. Re-add the DCC integration in HA.
  9. Check the custom_components/hildebrandglow_dcc/manifest.json shows 0.4.4 (or above)

You’ve done it!!
Thank you so much, I followed your process however I had to add in the step of removing the repository from HACS and putting your Github link back in. I’m sure I used your fork last time, but evidently not because it now works!

Once I’ve set this up I’ll let you know how the integration reports E7

1 Like

I’m soo close!
Now when I go to the Energy setup I can no longer see sensor.electric_consumption_today for ‘Consumed Energy’

Weirdly if I click the button for ‘Use an entity tracking the total costs’ I can see the above sensor along with the cost sensors.

Perhaps the system just needs an hour or two for data to push through to show HA that this sensor can be used for ‘Consumed Energy’??

There is a discussion here that suggests there is a problem at the Hildebrand end, that started 2-3 hours ago. None of us are getting data at the moment.

1 Like