Recorder errors

Addons doesn’t show in Samba. In SSH it shows empty.

Using thé samba add-on ? Use whitelist external dies.

How? In the SAMBA config?

This is my working configuration as of now.

workgroup: WORKGROUP
username: redacted
password: redacted
interface: eth0
  - ._*
  - .DS_Store
  - Thumbs.db
  - .Trashes
compatibility_mode: false

Mine looks very close to yours I have no idea where to look.

Did you try in configuration.yaml :

    - /share
    - /addons

I already have access to /share & /addons

nothing in them?



There is nothing in my addons folder either.

I believe the database is inside the Mosquitto addon docker container.

If the database is in the docker container, how are updates managed ? As far as I know, an upgrade replaces the docker container.

Good point. I just saw your post about whitlisting. Tried to add this:

    - /config
    - /addons

But got:

not a directory @ data['whitelist_external_dirs'][1]

It’s ok with config but not addons.

I get the same error. I have also asked where the db is store on the discord channel. Hopefully someone will answer there.

Looks like its in the MariaDB container, dug around in /data using portainer and seems like everything is there. Dunno how updates are managed, you’d have to ask the add-on owner I guess.

Here is what I was told on the discord channel " cogneato yesterday at 11:37 AM all addons are containers"

I can find the maria container using ssh and then docker ps, but I can’t see the contents of the container with either SSH or samba.
I am just passing on what was told to me.

And still, I believe it is in /addons (at least on HA Supervised)


But since HA Supervised and HA OS pull the same container, there should not be much difference. It definitly is not inside the container.

It seems, if you use Home Assistant OS, /addons is not mounted in the HA container. I read this here :

Although the backup folder wasn’t mounted for us in the homeassistant container, /config, /share and /ssl are available. The addons folder is not mounted either, but mounting the drive ourselves gives us that too, if you need it for some reason.

1 Like

He’s talking about mounting the snapshots folder no mention of Mariadb. Interestingly I do have a mount for backups and can see my snapshots using the samba addon.

Yes, but it would explain why you can’t see the /addons folder. Can’t test it myself, as I only have supervised installs.

My statement from that post was simply mentioning the folders visible from the SAMBA addon in relation to what is mounted in the default homeassistant docker container. To be honest, I hadn’t really looked at the addons folder visible in the SAMBA addon. Now that I look at it, on my system I see that it is empty. I don’t know what that folder is for. It’s clearly not where the actual addons are stored. It might just be a folder that all addons have mounted that they could use to share additional files.

Hi, I had this problem after reinstall hassio and restore a snapshopt.
The Problem is now solved! Thank you :slight_smile: