Release 0.100 fixing trackers/Device_trackers?

Hi All

I just upgraded and I read the release info…

But I have a hard time finding what to do to fix everything that isn’t working

  - badges:
      - device_tracker.henrik_bayesian
      - device_tracker.nina_bayesian
      - device_tracker.thomas_bayesian
      - device_tracker.victoria_bayesian
      - device_tracker.people_home_bayesian
      - device_tracker.life360_henrik_caspersen
      - device_tracker.life360_nina_caspersen
      - device_tracker.life360_victoria_caspersen
      - device_tracker.life360_thomas_caspersen

And all the:

Can I search for each of these and just add them in the new:
Unused entities

These are the entities that you have available, but are not in your Lovelace UI yet.
Select the entities you want to add to a card and then click the add card button.

But what is the alternative?

Normally its not that hard fixing things but this have me stumped…
Hope someone can help me


An idea of which device_tracker integrations you are using along with life360 and how they are configured might help someone answer.

The issue probably lies with the non-life360 tracker configuration based on this comment

I found the issue more or less straight away

I was using an old legacy unifi device tracker. Once i removed that all was good :slight_smile:

So one of these device trackers - Unifi or 360 tracker breaks all trackers?

Unifi is integrated into HA but yes I do have them in my configuration.yaml

Example: I get notification whenever my family visits and even get to the door…
Sorry for being stupid but what replaces the known_devices.yaml?

I use Unifi device trackers, and also all of the iPhone trackers like Battery state,Battery level
Location 360 and Unifi (Not bluetooth)
I also use my own bayesian sensors from the above: (HA GPS/360/Unifi Wifi) gives better accuracy

Ok I think I will do a rollback for now - to many things not working makes the family angry :slight_smile:

The entity REGISTRY.

Have you tried removing them from configuration yaml?

Having one thing broken in the chain of events when the system loads can absolutely kill everything down the path from that one thing.

I just removed the legacy (ie not supported) unifi integration on my device_tracker.yaml and it fixed it all.

Basically, one misconfigured device tracker will cause the whole device_tracker component not to load, so all device trackers will fail.

That was it - Thanks a million!

Just one thing I had to also exclude the setting to add devices to Known_devices

## Unifi
#  - platform: unifi
#    host:
#    port: 8443
#    username: !secret unifi_username
#    password: !secret unifi_password
#    ssid_filter:
#     - 'Wifi'
#     - 'guest'
#    verify_ssl: False
#    site_id: !secret unifi_siteid
# 30    
#    interval_seconds: 30
#    consider_home: 1200
#   detection_time: 300
#    new_device_defaults:
#      track_new_devices: false
#      hide_if_away: false

So how do I add any new devices in the future?

1 Like

Thanks I added the “same lines” I guess standard is that it will add all devices to the Known_devices or similair inside HA

BTW: One more thing if someone else is updating to .100 and are using Synology
The camera integration is broken

It doesn’t add any of the device trackers to the known_devices.yaml file any longer.

It only adds them to the entity registry.

All of the devices you have from the unifi integration in the known_devices.yaml file are useless now. Other device trackers may still use the known_devices.yaml for now, tho.

Thanks have to find out how to activate them?

One more thing I just noticed my Node-reed light control stopped working in this update any input on what might have changed?

(Keeping everything I find in the same thread in case someone have same problems)

The Sonoff switch works if I toggle the switch - so something broke in the connection to the switch?

One more - My Google assistant is now very slow to handle my Sonoff switches
Turn light on and off takes a very long time, no changes in configuration
1-2 minutes before turning light on and off - before it was instant?
Could it be something with the Mosquitto broker?