Request for https://homegraph.googleapis.com/v1/devices:reportStateAndNotification failed: 403

Tags: #<Tag:0x00007f73b3ca4dc8>

I found what caused the error in my setup, you need to enable the home graph api. Previously in the documentation that was explained under the api_key instructions. Now it is described under the service account under point 9 and 10, this was changed 20 hours ago. This took me a few hours to understand, hopefully it will help someone else!

Direct link to activate the home graph api: https://console.cloud.google.com/apis/api/homegraph.googleapis.com/overview

5 Likes

Hi guys!

I had this message on log when trying to trigger an automation (send push to my phone when switch.radiator state is on). The push was not sent and the error appeared on log.

I’ve tried the same automation but with a different entity (switch.tv) and it worked (push was sent to my phone and no errors in log).

I’ve found that despite i had switch.radiator in Google Home app it was not associated to my home. It appeared down as “Linked to you - x devices not in a home”.

After i added it (switch.radiator) to my home the automation started working, without errors.

Hope i can help someone with this info :wink:
Cheers

Hi, I’m running v0.104.3, and setup Google Assistant with a service account. I have the HomeGraph API enabled yet the message persists.

make sure testing is enabled in the console… it times out after 30 days and prevents syncing… so you need to reenable it in there.

1 Like

Hi David. Thanks mate - will check.

I’ve had this issue for some time now.

After seeing this thread I decided to give it a try to trigger a sync through Google Home / Google Assistant.

First try:
Wrote “sync my devices”
Sync reported an error in the Google app.

Second try (approximately 3 minutes later):
Wrote “sync my devices”
Google reported all devices synced

I haven’t had a single error since then :see_no_evil:

I had same issue cost me $100 aud. With requests over 3 days. So have diabaled it. I know I can set quotas but don’t want to risk it!

Moved to v0.105.0 sadly problem remains. Testing is enabled, yet the error persists. This has me stumped.

When I examine the metrics for HomeGraph, it seems I am getting around 50% errors over a given period. Can I interpret that as I am also having 50% success; thus this fault is “intermittent”? And therefore, my setup is working - just not consistently…

PS. I created a new project and action from scratch which produced exactly the same behaviour.

Up to v0.105.2, still the same dud 404 errors. Was hoping a change by @frenck in the latest update would fix it but wait we must… So frustrating!

With so many folk saying that they overcame the 404 error, it forced me to take drastic action. I did a complete re-build of HA from scratch. Not using a snapshot restore via Supervisor; but manually piecing everything back together from a snapshot extracted to a local drive. No more errors and I didn’t change anything on the Google side of things. Something in my build was hinky - but that’s history now.

Same problem here but I don’t want to rebuild it from scratch…!

The problem is that it works, so we will have little luck getting the code owners to look for a problem (that isn’t in their code). I followed the instructions accurately on my old build and I had errors. Followed the identical process on a new build and I have zero errors. My installation had a gremlin, not the Google Assistant code as such. So thats my/our problem to solve. If this thread had many many more complaints it might get attention. I suppose a long standing deployment of HA can acquire cobwebs that trigger a fault like this. Good luck.

PS. I did try a supervisor snapshot restore on a fresh install, that was no good - it just imported the bug to the new build.

You can add me to the list of complaints.

Have you guys who are having issues created a service account key like the documentation states and added it to your config?

yes indeed.

The cloud dashboard should show you the errors on google’s end, you’ll want to check there to see what’s being thrown.

hey guys,

the problem is solved here :slight_smile:

I have the same error 404 and i have already the agent_user_id define in my automation, but not the good one…i previously put the admin one (create by the system) and its the user one that is needed…lol

Now, good buy the 404 error, even when i automate the syncing.

enjoy

1 Like

I did all of this, none of my devices are showing up in my Google Home App

I ran into the same issue. I tried several things which did not help:

  • Disable and re-enable Homegraph API
  • Restart home assistant
  • Recreate project

What finally helped to fix the errors was to first unlink my Project in the Google Home app (Android) and then relink the Project again. Relinking without unlinking did not help!

Hope this helps.

hello @Anders_Karlstrom,

thanks for this solution, i lost my mind today to unlink/relink my “test” account in google assistant…

What is really strange is i succeed, it works for 2 hours and then i can syncing anymore…

Then i read your POST, and go to the API Homegraph page with your link, and surprise, the Homegraph API wasnt active anymore!!! but i activated 2 hours before…dont understand how the Homegraph API can desactivated by itself??

Thanks