Resolved: Error: Unknown Flag: --content-trust

Don’t have a clue, but since the latest supervisor update you do need os-agent installed. Did you install os-agent ?


Thanks for the contribution! I’ve been largely inactive on notary since I left Docker ~18 months ago but I’ll see if I can get a review on your PR today. Happy to see somebody using it.

Thank you Francis. This was the problem. I had just been updating through the interface and it had never notified me that I needed manually install os-agent.

I followed the steps here and the issue is resolved:


Hi, I think I have the same problem : Supervised version on VM.
I have just upgraded supervisor to supervisor-2021.09.4 with the same message.
I have tried to install OS Agent (downloaded os-agent in BackUp directory) but I have an error message :

Command not found ?

Thanks for your help.

Try without sudo

I have just tried :

Same answer. Thanks for your help !

By the way, I use the Terminal in HA :

Are you able to login directly to the host console? That is where I installed mine.

Host console ? With Putty ? It’s not the same ?

I too have started getting this flag (running Home Assistant Supervised on debian), but when I go to install the 1.2.0 linux x86/64 OS Agent deb, it fails due to udisks2 not being installed, which then has quite a few more dependencies.
I then spotted that the official guide now mentions Debian 11 rather than Debian 10, so should I sort out the udisks issue or just do a whole new install?

Could this not be in an apt repo/ppa that we could add to our systems? Then it would get updated when a new version is published and not just die on the vine.

I will forget to update this… unless something breaks which will just be another annoyance.


I am on debian 11 but had similar experience.

sudo dpkg -i os-agent_1.2.0_linux_armv7.deb 
sudo apt install udisks2
sudo apt --fix-broken install

Seems to have done the trick

1 Like

Thanks - I got it working with sudo apt-get install -f then I had to reboot to get HA to remove the flag. Think I’ll leave off a Debian 11 install for now.

In 3 months Debian 10 will be unsupported.

ha supervisor options --content-trust
Error: unknown flag: --content-trust

Still get that after install and reboot but the other command on

gdbus introspect --system --dest io.hass.os --object-path /io/hass/os


And the system page doesn’t have the warning about os-agent.

Great, that works for me, after a complete reboot ! (I have done the first sudo at the end, not first). Tanks :slight_smile:

I have Debian 10. I guess we have to go to 11 ? Is it cumbersome ?

See :


Thanks - Debian 11 upgrade complete.

@tieke , you have used the guide in the last post to upgrade ?

Yes, except I went with the linux_x86_64 version of the os-agent rather than the linux_aarch64 one as I am running it on intel hardware.

All running, except that weirdly enough my Frigate installation is running at aprox 10% more CPU (now uses around 35% without hardware acceleration as opposed to 25%).

1 Like