RFXcom and klik-aan-klik-uit (KAKU) doorbell

I assume that you guys are all talking about the actual button (ACDB-7000A).

However, I don’t have the button, I only have the receiver (ACDB-7000C) and I want HA to send a signal to it to tell the doorbell to ring.

How on earth do I add this device? I assume that I need to do something similar to how I added my Somfy RTS, by plugging the RFXcom device into a pc and then putting KAKU in learn mode.

But the details… I have no idea… does anyone know?

You don’t need to add the bell device. Just add a switch or input boolean with the rfxtrx platform and make up some valid device code. Your rfx module will broadcast that code. Put the bell in learn mode and switch on your virtual bell. That’s it.

Yup, that did it, who knew it was so easy :smiley:

Maybe someone who can help.
I have the Kaku doorbell. How do I set it automatic back to an off state after x seconds.
Now it always stays on.

Late reply but I did it like this:

  alias: Doorbell_main_entrance
  - event_data:
      entity_id: switch.main_entrance
      state: group on
    event_type: button_pressed
    platform: event
  - data:
      message: Main entrance
    service: notify.ios_zinkens_iphone
  - alias: ''
      entity_id: switch.main_entrance
    service: switch.turn_on
  - delay: 00:00:05
  - data:
      entity_id: switch.main_entrance
    service: switch.turn_off

That way I will get a notification and the “dummy”-switch will switch to on for 5 sec and back to off.

Hi Koen,

Ik hope you can help me out. i have the KlikAanKlikUit ACDB-7000BC and i can’t tigger anything when i push on the bell button.

If i ring my doorbel i see the folwoing data on the rfx manager.

17-12-2020 03:23:00:322= 0710010041080770
Packettype = Lighting1
subtype = ARC
Sequence nbr = 0
housecode = A
unitcode = 8
Command = Chime
Signal level = 7 -64dBm

Please help. im working on this already for 3 days
Thanks already

Hi Jeroen,

No sure what the relation is between the rfx manager code and the doorbell id, but here’s my configuration of my rfxcom doorbell:

  device: /dev/ttyUSB1
  debug: false
  automatic_add: true
      fire_event: True

If you put the automatic add option in, you should see the device com up in your devices:

The fire event is important for automation.

After thats configured you can automate like this:

- alias: Doorbell pressed rfxcom
  initial_state: true
    platform: state
    entity_id: binary_sensor.ac_1a3cf4a_12
    - service: notify.telegram_x
        title: Doorbell pressed!
        message: Doorbell pressed!
            - url: http://linktoipcamsnapshot
              caption: 'Doorbell pressed'


hi how did you add a different sound?

I’ve tried this over a hunderd times but can’t find the right device code.
Can anybody give me a clue what device code I’ve to use?
I followed this manual: RFXCOM RFXtrx - Home Assistant
“*manually add a device, in the options window, an event code can be added in the field Enter event code to add” But I can’t find the right code :frowning:

no idea if this can help you, but I have this as device code (configuration.yaml):

  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A11P1X5A-if00-port0
      fire_event: True

and this in my automation.yaml as trigger:

- alias: Deurbel Melding
    - platform: event
      event_type: rfxtrx_event
        id_string: "1417d5e:1"

I have a kaku doorbell, and when pressing the button, a new device shows up. But when trigger it wit the gui, switch on or off, the chime does nothing.
What to do exactly?

I figured it out, with the new switch I got from de rfxcom when pressing the doorbell, press on the chime the pairing button, and then fire the new switch from HA.

Thanks. I’ve tried to add the doorbell but no luck :frowning:

but try to add it in code in the configuration.yaml. So not like you did now by doing it through the GUI and adding as integration.