Ring Device integration via MQTT w/ Video Streaming

I think I remember now…I need the “id” to insert in the config:
``
rtsp://03cabcc9-ring-mqtt:8554/xxxxxxxxxxx_live

``
I seem to remember using a terminal command to list all my devices and I found it there. Can anyone help me figure this out?

im having issues getting any stream to work in HA. the generic camera entity seems to just continuously load then i try and start a stream. anyone that has this working have any tips?

Same here, no solution, not being able to stream at all in supervised installation

I think you can find that info in the log file

Hi, Is anyone else still having issues seeing devices status etc, I’m unable to see any of my devices all appear offline although MQTT appears to be connecting to Ring API and detecting devices.

Running ring-mqtt…
2021-12-09T21:18:31.184Z ring-mqtt Using configuration file: /data/options.json
2021-12-09T21:18:31.193Z ring-mqtt Reading latest data from state file: /data/ring-state.json
2021-12-09T21:18:31.410Z ring-mqtt Attempting connection to Ring API using saved refresh token.
2021-12-09T21:18:32.350Z ring-mqtt Connection to Ring API successful
2021-12-09T21:18:32.357Z ring-mqtt Starting connection to MQTT broker…
2021-12-09T21:18:32.445Z ring-mqtt File /data/ring-state.json saved with updated refresh token.
2021-12-09T21:18:32.462Z ring-mqtt MQTT connection established, processing locations…
2021-12-09T21:18:34.757Z ring-mqtt ------------------------------------------------------------

I am not sure. It is above somewhere. But I think if it hangs at processing locations…In my case it was because a light bridge was off line.

Any progress? I cant get the live view to work. still image is ok. But not live. I’m using Home Assistant Blue.

Hi thanks for your response, It is actually processing locations I just didnt want to post the location logs… They show up on the log file but offline when I look at entities.

Switched to WebRTC, it is working flawlessly just avoiding the problem :slight_smile:

Ok. How did u do that? :slight_smile:

Please check this thread, it is a general streaming solution for home assistant Realtime camera streaming without any delay - WebRTC

WebRTC worked for me, but now one of my cameras is getting an error: “Deactivating event stream due to signal from RTSP server (no more active clients or publisher ended stream)” anyone seen this?

Does anyone know if there is a way to set the alarm state to “pending” (i.e entry delay) somehow? I have some spare door sensors which aren’t ring door sensors so I’d like to use them to kick start the entry delay if I can.

Currently while playing around it seems possible to set the state to disarmed or armed but I cannot set the state to pending…unless I’m just being stupid somehow!

I guess you are using an automation to use them? Add a delay in the automation?

Im getting an error trying to run the docker container. I’ve change the MQTPORT to localhost and the ip address of my synology (Im running it on a synolgy)

Here’s the error:
Unable to connect to MQTT broker. connect ECONNREFUSED localhost:1883 +2ms

Im guessing I need to install a broker?

Quick Install

This is a Home Assistant addon and must be added to the native Home Assistant add-on store, this project has nothing to do with HACS and attempts to add this to HACS will fail. The Home Assistant add-on store is only available when running Home Assistant Supervised installed via either Home Assistant OS or manually. If you are running Home Assistant Core via Docker or manual install into a Python virtual environment then there is no support for the addon store but you can still run the ring-mqtt project directly to get the same capabilities.

This add-on requires a working MQTT broker. Configuring Home Assistant MQTT support is outside of the scope of this document but the standard Home Assistant Mosquitto integration along with the Mosquitto MQTT add-on is the recommended configuration.

2 Likes

Is anybody else having connection issues this morning?

I’m getting a 500 error in the logs.

2022-02-11T13:21:07.634Z ring-mqtt WARNING - Unhandled Promise Rejection
HTTPError: Response code 500 (Server Error)
    at Request.<anonymous> (/app/ring-mqtt-dev/node_modules/got/dist/source/as-promise/index.js:117:42)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5) {
  code: 'ERR_NON_2XX_3XX_RESPONSE',
  timings: {
    start: 1644585660818,
    socket: 1644585660818,
    lookup: 1644585660819,
    connect: 1644585660849,
    secureConnect: 1644585660911,
    upload: 1644585660911,
    response: 1644585667628,
    end: 1644585667629,
    error: undefined,
    abort: undefined,
    phases: {
      wait: 0,
      dns: 1,
      tcp: 30,
      tls: 62,
      request: 0,
      firstByte: 6717,
      download: 1,
      total: 6811
    }
  }
}

Hi all,

New poster here, been following many of these threads to set up my new HA setup.

I am running into this weird issue with HA and ring-mqtt. Whenever I restart my HA service (HA OS as VM), the integrations works great. I can start the live-stream service through a toggle, and when I click on the picture-glance (or picture-entity) card it opens up the live stream in a big pop-up window. However, once the live-stream service shuts down (automatically), and I restart the live-stream service through the toggle (and I see the service running in the log), when I click on the card it only shows the header bar of the pop-up, and no longer the video.

Further, I can see that the snapshot function is working as the card image updates after each motion detection throughout the day.

Did I code or config something wrong? See below the various codes:

Card code:

      - type: picture-glance
        entities:
          - entity: switch.front_door_live_stream
        camera_image: camera.front_door
        tap_action:
          action: more-info

Configuration.yaml:

#Ring Camera
camera:
  - platform: generic
    name: Front Door
    still_image_url: http://<IP of HA VM>:8123{{ states.camera.front_door_snapshot.attributes.entity_picture }}
    stream_source: rtsp://streaming_user:[email protected]:8554/9c7613387efb_live

Note: I also tried stream_source: rtsp://03cabcc9-ring-mqtt:8554/9c7613387efb_live, same result.

ring-mqtt Configuration:

enable_cameras: true
snapshot_mode: motion
livestream_user: ''
livestream_pass: ''
enable_modes: false
enable_panic: false
beam_duration: 0
disarm_code: ''
mqtt_host: <auto_detect>
mqtt_port: <auto_detect>
mqtt_user: <auto_detect>
mqtt_password: <auto_detect>
branch: addon
debug: ring-*
ring_token: >- <TOKEN>
location_ids:
  - ''

Note: I also tried enable_modes: true, same result

ring-mqtt Log after toggling live-stream

2022-02-11T15:00:58.242Z ring-mqtt [Front Door] Received set live stream state ON
2022-02-11T15:00:58.242Z ring-mqtt [Front Door] Starting a keepalive stream for camera
2022-02-11T15:00:58.246Z ring-mqtt [Front Door] The keepalive stream has started
2022-02-11T15:00:58.247Z ring-rtsp INF [RTSP] [conn 127.0.0.1:47110] opened
2022-02-11T15:00:58.249Z ring-rtsp INF [path 9c7613387efb_live] runOnDemand command started
2022-02-11T15:00:58.273Z ring-rtsp [Front Door] Activating live stream via topic ring/229e1772-af0c-4bc5-b1b2-15088a9858e1/camera/9c7613387efb/stream/command
2022-02-11T15:00:58.275Z ring-mqtt [Front Door] Received set live stream state ON-DEMAND
2022-02-11T15:00:58.276Z ring-mqtt [Front Door] ring/229e1772-af0c-4bc5-b1b2-15088a9858e1/camera/9c7613387efb/stream/state ON
2022-02-11T15:00:58.276Z ring-attr [Front Door] ring/229e1772-af0c-4bc5-b1b2-15088a9858e1/camera/9c7613387efb/stream/attributes {"status":"activating"}
2022-02-11T15:00:58.276Z ring-mqtt [Front Door] Establishing connection to live stream
2022-02-11T15:00:58.310Z ring-rtsp [Front Door] Live stream is activating...
2022-02-11T15:00:58.964Z ring-attr [Front Door] ring/229e1772-af0c-4bc5-b1b2-15088a9858e1/camera/9c7613387efb/stream/attributes {"status":"active"}
2022-02-11T15:00:58.987Z ring-rtsp [Front Door] Live stream is active!
2022-02-11T15:01:01.266Z ring-rtsp INF [RTSP] [conn 127.0.0.1:47140] opened
2022-02-11T15:01:01.269Z ring-rtsp INF [RTSP] [session 649772858] opened by 127.0.0.1:47140
2022-02-11T15:01:01.275Z ring-rtsp INF [RTSP] [session 649772858] is publishing to path '9c7613387efb_live', 3 tracks with TCP
2022-02-11T15:01:01.277Z ring-rtsp INF [RTSP] [session 343835732] opened by 127.0.0.1:47110
2022-02-11T15:01:01.278Z ring-rtsp INF [RTSP] [session 492989300] opened by 127.0.0.1:47110
2022-02-11T15:01:01.286Z ring-rtsp INF [RTSP] [session 492989300] is reading from path '9c7613387efb_live', 3 tracks with TCP
2022-02-11T15:01:03.249Z ring-rtsp INF [API] [conn 127.0.0.1:38516] GET /v1/paths/list

Regards!

Roy

I have had something like this. The video streams were clickable once, after that it would just bring up the video player header and nothing else. When I’ve been trying it now, it’s been fine, but then and now I’m getting this in my HA logs.

2022-02-11 17:25:13 ERROR (stream_worker) [homeassistant.components.stream.stream.camera.front_door_events] Error from stream worker: Stream ended; no additional packets

I should add, and when this happens my camera entity becomes unavailable (which it just did), so I have to restart the camera integration (which I know I could automate, but I shouldn’t have to).