Samsung refrigerator via Smarthings, all sensors except one reporting uknown state

Apologies in advance if this topic should be posted elsewhere …

I recently purchased a new Samsung refrigerator and was pleasantly surprised when I noticed that it had WIFI capabilities. It was not listed at all in the specs in the store.

Anyways, of course I added it immediately to my SmartThings hub, which I had already integrated into Home Assistant (I’m currently using ST to control Zigbee/Z-Wave devices and getting them into HA).

I then refreshed the ST integration and sure enough, the new fridge appeared as a new device in HA with 8 entities (sensors). There’s a binary sensor for the door, two temperature sensors and 5 energy/power sensors of some sort. However, only the door sensor works correctly and reports on/off correctly depending on the state of the door. All of the other sensors just report an “unknown” state.

Of course this all works correctly in the ST app but not via the ST integration into HA. I wonder if there’s any config or somthing I can mess with to get this to report correctly in HA?

I tried to get mine in tonight and was unsuccessful. I know it’s something with the connection. I’m going to take another crack at it tomorrow and I’ll let you know what I find. But this was encouraging (I was hoping to get a few sensors out of it),

Hey @Sergeantpup, any luck with it? :slight_smile:

Lol, you know how it goes. I got side tracked with a million other things that are smart home related and actually made so much progress, the fridge is one of the few outstanding issues. I have not tried again to make the connection but ill try right now.

*Edit I have successfully made the connection and I realized why it failed the first time (that external Samsung load page takes a long time to load and I think I was impatient with it the first time).

I can see the fridge and the tv (the only two devices still on my samsung hub). I know the fridge says unavailable but I will play with it and test your use case/issue above.

2022-01-24 16_09_54-Configuration - Home Assistant

I did some additional digging and my final assessment is Smartthings is no longer sending this information. Allow me to show you how I came to that conclusion:

Added the fridge via the HA/Smartthings integration. I get the same features you do. the contact sensor is wildly responsive, energy meters appear to work but the temperature for the fridge/freezer/drawer are unavailable. Additionally, there’s not a switch for the ice maker (i promise this is an important fact).

I’ve had a smart fridge for over two years and I KNOW that I had it working somewhere and it was showing multiple temperature zones and an ice maker switch. I left smartthings, went to hubitat, and just converted to HA. I was racking my brain trying to figure out what I recalled this functionality from.

Then it dawned on me. It was in the alexa app. when integrated from smartthings to alexa, the fridge would come over with multiple temp zones (that showed as thermostats) and a switch for the ice maker. I think there was one for the door too. Point being, the smart fridge used to break up into multiple devices in Alexa.

I reconnected smartthings to alexa and discovered devices. The fridge came over as a scene and as a supply entity. There are no thermostats associated with the device nor in Alexa. Effectively making the connection in alexa to the refrigerator now useless. What this tells me is that Samsung has done something that has broken the sending of this information not only to HA but also to Alexa and I can 100% without a doubt vouche for the the way this used to work in Alexa from 2019- late 2020.

I have confirmed the temp zones still register in the Smartthings app

Here’s all that comes over in Alexa now

looking in the samsung IDE, the child devices are displayed as they used to display in alexa but none of them are showing states or any last activity except the contact.

Thanks for the update :slight_smile:

In case anyone finds this via Google (like I did), the fridge temperature sensors can be enabled. Per a comment in another thread:

I would note that, at least in my case, I had to bypass the new “beta” SmartThings app and log into to get access to the device configuration.

Stunning! Worked beautifully, thank you!

Thank you for providing the link to the SmartThingsAPI. Was able to fix the temperature readings. The icemaker still is not showing up in HA.

1 Like

This worked perfectly! Thanks for the assist!

I am logging into Smarthings web api but I cannot find where to change the formentioned “Type”. I this the correct page?

Unfortunately I’m seing the same as benquan above. Just got a samsung bespoke fridge today and decided to add to HA for fun, but unfortunately seeing the same issues as everyone above, and no way to get to a page that resembles what mr_k posted above. Not sure if the ‘advanced’ smartthings page changed in the past year when that screenshot was posted or if we’re just not looking in the right spot, but unable to change the device type on my end and no thermo readings within home assistant.

I am also experiencing the same as RickFish and benquan.

Same here. But when I enabled debug logging I see that the webhook is sending the temp updates, so the problem must be on the Home Assistant side. When I have a chance I’ll dig into the code to see if I can see what might be going on.

This is the problem: Smartthings Device with 3 Components ==> Missing Switches / Sensors · Issue #91892 · home-assistant/core · GitHub

I will have a PR ready to fix this sometime in the next few days.


I also have this problem as well. It only shows 2 temp sensors when the refrigerator reports fridge and freezer temps in ST. I also have a range with the flex oven and only the upper oven and whole oven state are shown. The Microwave also doesn’t show the door status when it is also avalible in ST.



I would love for the ST integration to be updated to get all the missing information for the OCF devices.

Hi, I’m a beginner… what and where did you change…?
the smartthings web page that I access is only the advanced one Samsung account
and I can’t make any changes to the attributes
Thank you!!!

Just in case, here is a fixed (at least for me) SmartThings you can install via HACS: GitHub - contemplator1998/smartthings

(Pulled #99924 and wrapped into a HACS repo)

It makes everything accessible, even sensors/controls that are always unavailable (just disable them in the HA).

1 Like