Scheduler card/custom component

But usually there´s an UI to select your entities and groups and all that stuff.

yes you are correct my issue is about conditions of sensors , where i had predefined a list of possible values.

re: scenes, i can have multiple scenes in once schedule, but i want but they have to share the timeslot, i want to have like from 1:00 to 2:00 turn on scene A and from 2:00 to 3:00 turn on scene B and 3:00 to 4:00 back to scene A and so forth.

Hi, I would like to try your great work but the card says there are no objects to view.
In the instructions I read that “the card scans the entities in your HA configuration and suitable candidates should automatically show up in this view”.
Certainly I’m wrong something, I followed the instructions to the letter … but I don’t understand … everything seems ok …

You need to hit the edit button in the dashboard’s edit mode. By default nothing’s included (correct me if I’m wrong).

Yes, forgive me, I have not explained myself well: when I activate the card and try to insert the first entity the answer is that there are no groups. How do I enter them?

I thought I had no issue with beta but realized I was wrong. I was seeing old schedules that I wasn’t able to delete. Each time I hit delete, it would still show. I then restarted, but got into a weird state where there’s missing schedules now it seems and odd spacing in the card and nothing showing when I tap on the excluded items:

I tried to create a new schedule for a weekend climate control and it never showed on the card. The switch got created behind the scenes but is in a funky “unavailable” state with no ability to delete:

I also have a problem. Scheduler tab 2.0.0b. If I want to delete a plan, the plan will not be deleted.
I added the bug to GitHub

thats exactly the same issue i have.

Usually when you add the card to your lovelace on the left side should appear a visual editor where you can select the entities and all other things. This part doesn’t work, is not shown. And I*m not able to add them manually.

So I’m not so stupid … there’s something wrong … still a very interesting job, congratulations to neliss.

I have a schedule to turn underfloor heating on & off, which works great.
But, using the timing scheme, it has to perform an action at midnight (start of a new day). I’ve got this set to turn the underfloor heating off, but it is already off from the night before. That works fine, but it causes the heating controller to light-up in the bedroom every night at midnight.
Is there a way of defining & performing “no action” for a time period? I know how to define the custom actions, but how can I define a “do nothing” custom action?

I saw an issue with the deleting of schedules. I have it fixed locally, will release an update soon.

There is no need to assign actions to each timeslot.
The view is just restricted from 00:00 - 23:59 (spanning a full day), but you can create slots as you desire, and leave slots blank where you don’t want actions.

Can anyone tell why my custom schedule name isn’t working here?
Nothing seems to change the primary info.

Never mind I found the answer in a post above.


Nov 17

display_options applies to the whole card, not to one entitiy.
So it shouldn’t be placed within customize .
This is also documented .

The empty spaces in the card are concerning, they suggests you have some schedules which were not migrated correctly (they got corrupted or something), and therefore the card cannot read/display the properties.
It would be best to remove them completely.
If you keep having problems, please create an issue for it in GitHub.

You solved with the latest updates? For me nothing … I keep having the same problem … no groups are set up and, therefore, I cannot proceed …

Sorry if this has been answered already, but I can’t seem to find it. I want to add the generated switch.schedule_uvwxyz to an entities card, so that it shows up with a simple toggle to enable or disable the schedule. However, it always shows up just showing the state, and says waiting (or whatever the current state of the schedule is).

Is there an easy way to add the schedule toggle into an entities card? I know when I click on the entity, it shows a toggle in the dialog, so it seems like this should be easy.

Try updating to latest-greatest.
I took care of this…

1 Like

You should add some entities for which you want to create schedules. Please read the documentation.
If the card does not allow you to add entities (in editor mode), then open an issue for it on GitHub for follow-up.

Awesomesauce! It worked great, and the update seemed to go smoothly for me. Thanks so much for this integration & component. It really should get adopted as a core feature of HomeAssistant.

I have updated to latest component, card and deleted the integration and re-added it back.

I then restarted HA.

Went to go add a new schedule and when I hit “save”, nothing happened. I tried it again. Same issue.

In the dev console of chrome, I see this:

Looking at the entities, i see 2 of them created:

Card itself is blank though:

I then removed everything (Integration, Component and Card). Restarted and installed the Component then rebooted. Then added the integration and rebooted. Then added the card and reloaded lovelace.

Tried to add another schedule and same thing – wouldn’t save. But the entity is created: