Schlage Connect ZWave Locks


#61

My wife is ALWAYS right. That’s how I made it through 30 years. LOL


#62

Thank you!! I was looking for something similar I have 2 Schlage connect zWave locks and I am using them in HASS. One is connected to HASS directly using the Aeon USB stick and the other is using Wink. What I like about the wink is that “exposes” the user names and the associated key and the users are binary sensors making it really easy to create automations. When using the Aeon connected one, by observing the Alarm levels when a valid user key is entered I was able to identify the user number. Your example showed me a different way to do it. Thank you! I will be nice® if they could be defined as binary sensors. Thanks again!!


#63

I agree with you, I have two Schlage connect zWave using the latest HASS and they are really responsive. In my scenario my Raspberry Pi is at the basement and my locks are at the main floor and I have been able to pair them using HASS adding a secure node with no issues whatsoever. The only thing with zWave is to make sure that your mesh is strong by adding hopefully more than one device :slight_smile:


#64

When I run this command the response comes back as

hass[1118]: INFO:homeassistant.components.lock.zwave:Usercode at slot 1 is: **********

Similarly, if I use OZWCP, the list of user codes does not display the actual value.

Is there some setting I need to change in the lock so that it will expose this info? It would be nice to not have to clear out all of the user codes in order to remove one code that I didn’t write down.


#65

I’m seeing the same thing as @unholysampler with some newly setup locks. Everything works, except for clear_usercode (doesn’t actually clear the usercode) and get_usercode (always shows ********** for any slot which has a usercode).

Is there a setting on the lock to allow usercodes to be displayed? I have a valid network key, and can lock/unlock and even set/change usercodes. Just can’t clear or get usercodes.


#66

This sort of makes sense, even if it is inconvenient. It’s good security practice to not have the ability to reveal secrets or passwords in the clear. I’ve noticed with my Schlage lock that I get ******* characters for programmed locations, but not for “empty” ones. I’m pleased that the lock works this way; there’s evidence that someone was thinking seriously about security.


#67

Fair enough, you do have a good point. Are you able to clear usercodes though?


#68

@guardmedia I got it to clear by setting a usercode to 0000 for a slot, but it only worked once… You should try it.


#69

I just set up a Schlage Connect and noticed that when I manually lock it the lock.entity updates the lock_status attribute with “Manually Locked by Key Cylinder or Inside thumb turn” but the state of the lock.entity is still "unlocked"
Is this a bug?


#70

I notice the notification and the lock_status differ quite often on the BE469. Sometimes the lock_status is blank while notification is populated; but in general the lock_status seems more accurate when it is populated.


#71

I just experienced that today. Bug…


#72

I just integrated my Schlage lock with HA today using an Aeotech Z-Stick in my Pi 3, and I was able to get it set up on the first try (imagine that)! Along with the lock/unlock functionality, I have a few new sensors for my lock and I’m not sure what their values mean. I was looking through the lock manual but I couldn’t find anything about them.

Anyone have an idea about what these sensor values mean or where I could get some more information about them?

  • sensor.schlage_be469nxcen_touchscreen_deadbolt_access_control
  • sensor.schlage_be469nxcen_touchscreen_deadbolt_alarm_level
  • sensor.schlage_be469nxcen_touchscreen_deadbolt_alarm_type
  • sensor.schlage_be469nxcen_touchscreen_deadbolt_burglar
  • sensor.schlage_be469nxcen_touchscreen_deadbolt_power_management
  • sensor.schlage_be469nxcen_touchscreen_deadbolt_sourcenodeid
  • sensor.schlage_be469nxcen_touchscreen_deadbolt_system

#73

The answer is earlier in this thread :slight_smile: I used this as well, works great:


#74

That pdf link appears to be dead… does anyone have a copy of the pdf to share?


#75

Yale Locks Z-Wave developer and user guide. This was the original copy I was looking at.

There is a more up to date revision here


#76

I just installed (physically) a schlage connect z-wave lock. I haven’t done anything from the z-wave side with it yet.

Do I have to follow all of these steps in @mkzimmspost (excluding the removing node part) , or can I simply put the schlage into pairing mode and then use “add node secure” button on the Z-wave tab of home assistant?

Running Home Assistant 0.50.2.

Thank you!

Edit: Dangit! I missed the instructions about network keys in this post. Looks like I’ll be doing the forget node / factory reset rigmarole tomorrow.


#77

After a bit of agony, my lock is working fully in home assistant!

The mistake I made was not setting my network key before calling “add node secure.” By doing that, I ended up in a similar state to other folks wherein I could kinda see the lock, but not all of the sensors and couldn’t control it. Thanks to the fact that I’m using a “newer” version of Home Assistant (e.g. 0.50) I was able to just use the z-wave manager on the front end to remove/add the lock.

What I was able to do to fix it was:

  • Add my network keys as described in this post, which I was able to find thanks to step 1 in @mkzimmspost.
  • Call “Remove Node” on the frontend and put the lock into the pairing routine to remove it (bolt extended, schlage button, six digit programming code, then 0)
  • Verified that the node was removed, I probably rebooted my pi a few times throughout this process
  • Factory reset the lock, just to be sure, it’s quick and easy
  • Called “Add Node Secure” on the frontend, and then put the lock into pairing/inclusion mode as described above.
  • Waited a bit, saw that I had a new entity called something like lock.unlocked
  • Rebooted my pi, and the lock was there and fully working in home assistant! No messing with open z-wave control panel!

Thank you to all of the users that helped me piece this together. If I had been a little more cautious, I think the entirety of my process would have just been adding the network keys, putting the lock into pairing mode, and pressing “add node secure” on the front end.

I thought that I would have to fiddle with open z-wave control panel as I had originally installed z-wave separately from HASS, but I guess the hard work the devs have done means that that’s not the case anymore. :slight_smile:


#78

I get a Kwikset Lock,and is trying to make it work with HA.

At first, I did not set the security key when add node. After that, I can see 3 entities of the lock, 1 lock and 2 sensors. I tried calling services “Lock/Unlock/”, but nothing happened on the lock. Also I tried get_usercode, I got no response from the lock. Also from the log, I can see a lot of message drop.

Then from the forum, people said that I should enable the security key in the option.xml. So I uncommented the option of security key in the file “option.xml” that is in the same folder as the configuration.yaml. Then I removed the Lock and Add it again. This time, I did not see the message drop anymore in the log. Also I find I can call the service lock.get_usercode to get user codes from the lock.

But still, I can’t call the service “lock.lock” or “lock.unlock” to lock/unlock the Lock from the HA GUI. After I issue the command, I can see the Lock/Unlock command is sent to the Lock, but still nothings happens on the LOCK.

Another problem is I can’t see LOCK widgets on the GUI after adding the nodes. Shouldn’t it be created on the GUI automatically after added?


#79

Just like some of you mentioned. I removed the node, and add again, then lock and unlock can work now.


#80

I am seeing only two of these 7 sensors, namely alarm_level and alarm_type - any idea how to look for or force hass to generate the remaining missing 5 sensors?