Schlage Connect ZWave Locks


#141

Just removed and re added the second lock. Same thing. Both locks are BE469, but show different sensors? Maybe firmware? I did buy them about a year apart? Anyone have any experience with this?


#142

Since I have only added one lock. I am not sure about differing firmware. Keep in mind my zwave devices still use the old naming convention because I am still on version .59.2 of HA. I have purchased another one of these locks and will be adding it soon. I will comment here on the results.


#143

So I’ll tell you, I had it working for a while (it was a huge pain and a lot of trial and error), but my dog chewed up my Pi, and Z-stick, so when I tried to reinstall it, I couldn’t get the lock to poll the status correctly anymore, or have any of the sensors/features I used to… I tried for a couple days, before giving up and getting a Vera to handle that… I’ll at least say that I haven’t noticed any kind of slow down linking the Vera with Hassio, as opposed to having a z-stick, so if you’re struggling, I’d suggest doing that as a simpler setup (the whole process took like 10 minutes between adding the lock to the vera plus controller, and adding it my setup. I just opened a port to connect to vera, for me to log in remotely from my phone, to set up temporary lock codes and so on.


#144

Everyone has had different experiences, but I can tell you. Z-wave, Aeotec Z-stick and HA has never been a problem for me. Stuff just works. I do have the Aeotec mini-motes that definitely help with adding devices, but I added my Schlage lock without using the mini mote.

I have the Schlage lock, many GE/Jasco switches,Linear Switches, Linear Bulbs,First Alert Smoke Detectors, and Everspring Leak Detectors.

It takes me 2 minutes to add a device to HA using the HA Z-Wave gui. I have noticed that I generally have to give HA a restart for the Z-Wave devices to show up properly/completely.


#145

That is true. It took quite a few tries (mostly of doing the same thing repeatedly) with AIO, then I moved to hassio, and it worked without a problem, but I didn’t get all the sensors or the ability to add user codes (that didn’t work either time, same z stick though). But when I set it up on the new pi and z stick, I gave up after several days


#146

Anyone have any luck changing configuration options or codes via script. For example, I’d like to disable “lock & leave” on a lock after a specific code(s) are entered, and then reenable when they lock the door again.

That way I know who locked the door when I’m away.

Maybe would use the same sort of logic to enable the burgler alarm options when I’m away, etc.

At this point I just dont know how to see which code unlocked, really dont know how to see much at all. I have been able to use the zwave UI to set codes, which is nice, but would be even nicer to have a script to set codes on all three locks to the same codes. :slight_smile:


#147

Can anyone give a list of sensors that should be exposed when adding? I am running 68.1 and also a dev version of owz. Shows as 1.5.0

Thanks


#148

Mine still uses the old entity_id, but here are the sensors I get

sensor.schlage_be469nxcen_touchscreen_deadbolt_access_control_89_9
sensor.schlage_be469nxcen_touchscreen_deadbolt_alarm_level_89_1
sensor.schlage_be469nxcen_touchscreen_deadbolt_alarm_type_89_0
sensor.schlage_be469nxcen_touchscreen_deadbolt_burglar_89_10
sensor.schlage_be469nxcen_touchscreen_deadbolt_power_management_89_11
sensor.schlage_be469nxcen_touchscreen_deadbolt_sourcenodeid_89_2
sensor.schlage_be469nxcen_touchscreen_deadbolt_system_89_12

And here is how my lock shows up as a lock

lock.schlage_be469nxcen_touchscreen_deadbolt_locked_89_0	locked	value_index: 0
lock_status: Locked with Keypad by user 0
value_instance: 1
node_id: 89
notification: Keypad Lock
new_entity_id: lock.schlage_be469nxcen_touchscreen_deadbolt_locked
friendly_name: Schlage BE469NXCEN Touchscreen DeadBolt Locked
old_entity_id: lock.schlage_be469nxcen_touchscreen_deadbolt_locked_89_0
value_id: xxxxxxxxxxxxxxxxxx

#149

Mine are for one lock
lock.back_door_lock
sensor.back_door_lock
sensor.back_door_lock_access_control
sensor.back_door_lock_burglar
sensor.back_door_lock_power_management
sensor.back_door_lock_system
sensor.back_door_lock_usercode

And
lock.front_door_lock
sensor.front_door_lock
sensor.front_door_lock_access_control
sensor.front_door_lock_flood
sensor.front_door_lock_power_management

for the other. Both are schlage BE469 locks. Only difference is I bought them about 6 months apart, and one was just deadbolt, the other came with a handle. I have added, removed, several times. They both seem to pair “OK”, but the front door is always a bit more of a pain to get added.

Here is the info from the backdoor lock
node_id: 56 node_name: Back Door Lock manufacturer_name: Schlage product_name: BE469 Touchscreen Deadbolt query_stage: Complete is_awake: true is_ready: true is_failed: false is_info_received: true max_baud_rate: 40000 is_zwave_plus: false capabilities:

and here is the front door
node_id: 59 node_name: Front Door Lock manufacturer_name: Schlage product_name: BE469 Touchscreen Deadbolt query_stage: Complete is_awake: true is_ready: true is_failed: false is_info_received: true max_baud_rate: 40000


#150

I always lock mine by hitting the Schlage logo (no PIN required) and it shows up as Locked by User 0. I am not concerned with who locks the door as much as who unlocks the door.


#151

Yup, me too for the most part, but I’d still like to do this from time to time. :slight_smile:

Sometimes it’s just because I can. haha. If you can turn that off and on, you can also utilize some of the other lock features in your HA, like kick off the alarm on the door if something else happens. I’m sure the logic for enabling diabling this would cross the other items as well.


#152

I’ve also noticed that even though I can lock and unlock via HASS, they status does not update if the locks are manually locked or unlocked. Only if they are controlled by HASS.


#153

Do you poll your zwave devices? Mine status definitely updates. This is from this morning. (My Logbook)

7:52 AM
Schlage BE469NXCEN Touchscreen DeadBolt Locked changed to unlocked

and then right after

7:52 AM
Schlage BE469NXCEN Touchscreen DeadBolt Locked changed to locked

Both of these action were manual actions (Inside Thumb turn for the first one and outside keypad for the 2nd)


#154

That’s a good question. Haha. How do I ensure they are being polled?


#155

Ok found polling intensity. Set it it one. Updates now on manual lock. So does an intensity of one mean every second? Seems like battery won’t last too long.


#156

1 means every 1 interval. Default interval is 60 seconds. So polling intensity of 1 means every 60 seconds. I have mine set to 30 (which is the absolute minimum recommended)

zwave:
  usb_path: /dev/ttyUSB0
  polling_interval: 30000
  new_entity_ids: false
  network_key: "Not posting in public forum"
  device_config: !include zwave_device_config.yaml

Then I define each device in a separate file

light.linear_wd500z1_wall_dimmer_switch_level_8_0:
  ignored: false
  polling_intensity: 1
switch.ge_unknown_type4952_id3033_switch_13_0:
  ignored: false
  polling_intensity: 2
switch.ge_unknown_type4952_id3033_switch_24_0:
  ignored: false
  polling_intensity: 1

#157

I think the zwave locks report in every 60 seconds on their own anyways (at least my KwikSet does), so it shouldn’t reduce your battery life. The result of your pairing of the front door lock almost looks like it failed to get the full secure handshake (range issue). :frowning:


#158

I feel like neither lock has paired fully or correctly. Until i set the intensity to 1 it only reported when locked or unlocked with HA.


#159

I am seeing the exact same thing. I have a Schlage BE469 deadbolt lock.

This script does not work at all

  remove_user_code_test:
    alias: Remove Code Clear
    sequence:
      - service: lock.clear_usercode
        data:
          node_id: 41
          code_slot: 4

Both of these scripts get rid of the old code and replace it with a code of 0000. Entering 0000 into the keypad unlocks the door.

  remove_user_code_test2:
    alias: Remove Code Add1
    sequence:
      - service: lock.set_usercode
        data:
          node_id: 41
          code_slot: 4
          usercode: '0000'
          
  remove_user_code_test3:
    alias: Remove Code Add2
    sequence:
      - service: lock.set_usercode
        data_template:
          usercode: '0000'
          node_id: 41
          code_slot: 4

Anyone see what is wrong here? Those of you that are using the ‘0000’ code workaround, what locks are you using?

Fighting with home assistant to do seemingly simple things is starting to get old. Every time I add a new component to home assistant and it turns into a multi-hour exercise in frustration, I really wonder if I should give SmartThings a try.


#160

You need to change the node_id

As a side note: On the KwikSet zwave locks you have to overwrite the old code slot with another code, it will not allow you to delete a code. So I use a randomly generated code to ‘nuke’ the old code out. This maybe the same on the Schlage, you’d have to check the manual.