SEAT Connect car integration in Hassio

Hi,

same here. I logged in to the SEAT-ID-Portal and clicked through the data and privacy questions. After that, the integration worked again.

I assume the portal is located here: SEAT ID & CUPRA ID
I went there, walked through the questions, toggled them twice so I could hit the save button and gave it another go. Unfortunately without a different outcome.

Since it’s al marketing / commercial consent, I don’t think it matters whether you give consent or not, but did you consent to specific parts?


P.s. Just for the record, I created this issue, since the integration tends to break after 2024.8 (2 months from now).

I logged in Here:

I think you solved a different issue, being issue 63, related to error:

Login failed, the terms and conditions might have been updated and need to be accepted. Login to SEAT Connect portal is no longer available online. Download the SEAT Connect App | SEAT and accept the new terms before trying again

The error I get is, see issue 60 with the errors:

  1. Invalid credentials or invalid configuration. Make sure you have entered the correct credentials

Which is obvious not the case since I use the same credentials (stored in a password manager and thereby not entered manually). So the UID/PWD are correct. The only think I can think of is the thing mentioned in issue 63, being the s-pin. But I cannot enter it anywhere, since the logon screen shown at adding the integration only offers a username and password field.

  1. Login failed with error: User appears unauthorized

I don’t know what I can do to solve this, since I have a connect plus subscription, use the app without issues and so on. So I assume error 2 relates to 1. Since issue 63 relates to updated terms and conditions, the authorization procedure might have change or something and makes it impossible to logon using newly installed integrations.

I hope @jfamaral is still active and willing to have a look at it.

How often do you update the values from the portal? I experienced the same issue a few months ago. SEAT/CUPRA limited the amount of polling the portal. If you poll to often during the day, if you use the offical app and poll with the HA-integration to often, the access to the portal via HA and the app is blocked. Try reducing the poll frequency.

Never, cause I can’t install the integration since I cannot login.
I however also tried it in the morning, so the change to bump into a limitation of the API is minimal. I read the issues and lowering the poll-freq suggestions, but since I don’t even get that far, it’s not applicable right now.

The app usage is less than 3 times a day, if I even make it that often. Never have issues, not even close to midnight.

Hmm, that points to https://identity.vwgroup.io/
I logged in, using your link, gave consent and tried to install the integration. Unfortunately no difference.

I’m waiting for my car so I haven’t been able to test it myself yet

Is there anyone with a Formentor E-Hybrid who can switch the charger?

Welcome to the community Ruben.
I don’t exactly know what you mean with ‘switch the charger’, but in case of HA it’s likely the same as switching any other switch. Using a dashboard card and trigger de switch like you prefer.

First step however is getting the integration to work. I’d like to know if you succeed in that and if so, how you managed to do so.

1 Like

Still not lucky unfortunately finaly.

So… for everyone who bumps into the same issue as I did.
When you install the Seat Connect App, it prompts you to install MySeat App (at least on iOS). Just close the app and reopen it and repeat that every time it prompts you to install the MySeat App.

After the first restart, you can login to the app and do everything that is necessary.

So, at first it looks like a BS App, which I obviously removed almost instantly… But that basically was the whole issue…

hi, did you make it? I would also be interested

How did you get the image from the app?

I managed to get the Integration installed but it doesn’t appear to do any updates after the initial setup, even with 600 seconds set. I get this error:
Error doing job: Task exception was never retrieved (None)