Send rs232 data

Hi, is there any way to send serial data to a comport from
Need to send below binary
0xBE 0xEF 0x03 0x19 0x00 0x00 0x00 0x01 0x00 0x02 0x01 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0xCC 0xCC 0xCC 0xCC 0xCC 0xCC 0xCC 0xCC 0xCC 0xCC 0xCC 0xCC

That would depend a lot on the underlying hardware & OS.
Very little hardware has RS-232 ports any more.

Hi, I’m using a rpi3 with a usb>serial adapter.
I first tried with Node-Red and it flash the tx led on the adapter but it comes out in wrong format I guess since the hardware does not react on command.

What OS?

I think Home Assistant can run shell commands so I would look toward getting things working from the command line first, if running something other than HassOs.

I’m running the image.

That would be HassOs. :frowning:

I am not sure what options you have. I am currently running Hassio on Raspian Lite on my RPi 3B+.

Ok, I may need to think over and change os to be able to run shell script.

I am running RPI3/HassOS.

Some time ago I tried to make my home receiver (Rotel RSP-1572 with RS232) controllable from my PC. I bought a IP-to-RS232-box and got it working, using a PC software.

Could someone please tell me how to use a script/command to send a binary code to a known port and IP address, from Hassio?

Did you check the usb-serial adapter has the right chipset to work with the rs232 device? I had issues with an older TV supporting ftdi chipset, but not ch140.

Yes, I used this adapter on a windows machine with Homeseer to control the screen but want to move this part to home assistant.

HassOs likely does not have the proper kernel modules installed.

Ok, I’m also planning to upgrade the hardware since I already have a odroid xu4 and Intel Nuc i7.
But I don’t know what installation method that is best option, docker / python etc.

I have no clue about this subject, but maybe this is relevant?
Going to try this out myself for controlling my home receiver.

Use the NUC, install Ubuntu server, docker install HassIO following the HA docs

Hi all,
I am looking for some help in my challenge: 8 relay board - RS232-USB controll - integration
Woudl any of you have any idea or hint which direction to go ?

To wake up an old thread, I’m trying to send rs232 commands via HA and a USB/Serial device, but wonder if I should first verify command(s) via the HA command line terminal. The ascii command I’m trying is “zsc,5,01”. It works through Termite, a Windows terminal. I’ve tried many variations of the following code, but it always returns bash: //dev/ttyUSB0: Read-only file system

echo -e -n 'zsc,5,01[cr]' > /dev/ttyUSB0

EDIT: if I remove the “-e -n” in the various attempts, I do not get an error, buy my device doesn’t do anything (either doesn’t receive the command or it’s in the wrong format).

Also, how do I set the baudrate, etc.?

I’m running the HA VM on my unraid, and though I have the USB-Serial device checked to passthrough in the VM settings, it doesn’t seem to actually pass through. When I run lsusb in HA’s terminal, it doesn’t show the USB-serial device. So more digging…