Send SMS with USB GSM modem when alarm triggered

@bkbartk The SMS integration deletes SMSs after it dispatches them onward, at least as far as I can read the code (which is not working for me)
If the modem is not connected (to the integration) then it depends on the modem I guess…

1 Like

I’ve got myself a SIM800C (https://www.amazon.nl/-/en/dp/B07RLN7DMJ )
I’m running Home Assistant OS, on Proxmox, on a x86 machine.
Device gets through no problem:
/dev/serial/by-id/usb-1a86_USB_Serial-if00-port0

I’m trying to add the “SMS notifications via GSM-modem” integration.
First few tries i got more errors than i do now (did some restarts), so it’s progressing.
Now i’m only left with ERR_NOSIM:

image

As instructed by others i’ve first put the sim in my phone, got it activated, i’ve send a SMS with it which works, and removed the pincode.
Also the orientation in the SIM800C is as pointed out by others, which is with the chamfered corner on the outside (and obvisouly the contacts facing the PCB).

I’m in the Netherlands, using Vodafone provider.

Anybody has some tips to follow?
Thanks!

vodafone should work

I myself use KPN,
did you remove the pin code? 0000 is not ok, should be removed

I use Lebara NL. Works like a charm.

Hello all,
I am using a SIM800C but it is not working


Same on my PC with AT commands. The SIM is recognised but no network connection. The sim works with a Huawey key (unfortunately not recognised by HA…) Do anyone have an idea on how to solve that with my SIM800C?

check the frequency, maybe you have imcompatibility between the frequency available (your carrier and the zone where you test) and the frequency support by the sim800c

from what I see here : SIM800C
the only band support are : 850/900/1800/1900MHz

the huawey key probably support more than that, also maybe your sim is 3g or 4g or lte which seem to not be support by the sim800c ?

I am not an expert but I thought that the 3G/4G cards were supported

Theoritically in switzerland my operator supports the 900,1800MHz… How can I be sure on that ?

I’m not expert either, maybe a phone could help you check what band is used.

maybe your card is LTE only ?

Just call your provider?

does any of you know the cheapest option for 4G?
My provider is 4G only.

I have a Sim7070G I bought from Aliexpress that works and supports 4G, and works with this integration. There are a bunch of different ones listed there, but there’s one I bought for under $20. I tried posting the link but it doesn’t seem to be working, so I would just go on there and search for sim7070G.

found it, it is quite simple :slight_smile:

The spec. says it only supports CAT-M, CAT-NB. If I understand correctly, these are both IoT specific networks: Cellular Protocols: Differences between CAT-M & NB-IOT | Sony Altair

Does that work with standard SIMs?

It workes with a tello sim in the us, which is standard. I have a minum minute and data plan, whith unlimited text.

Not sure about other providers/countries though

1 Like

I got myself a ZTE K3565-Z which seems to be recognized by Debian 12 (I see the GSM option in the settings when I connect it to the PC). I don’t understand how to configure “SMS notifications via GSM-modem”. I am asked to indicate the “device”, what should I enter? I use HA via docker. Can someone help me?

You would need to map the device into docker. There’s a couple of ways to do that, but I use the device flag.

You need to find the path of your device on the host first. I use the /dev/serial/by-id method since the path doesn’t change. If you run

ls /dev/serial/by-id

on the host you should see the path of your device. If you’re not sure what device it is, run the command with the device plugged in and unplugged, and see what comes and goes. Your modem might create multiple devices, in which case you’ll need to check the modem documentation as to which one is the GSM option (or trial and error them)

This would be the compose

version: '3.3'
services:
    home-assistant:
        container_name: homeassistant
        volumes:
            - '/home/$user/homeassistant:/config'
        devices:
            - '/dev/serial/by-id/$pathtoZTEk3565:/dev/ttyUSB0'
        environment:
            - TZ=$yourtimezone     
        restart: always
        network_mode: host
        image: 'ghcr.io/home-assistant/home-assistant:stable'

replacing anything with $ with your own info - ie $pathtoZTEk3565 is the path you obtained from the ls command.

I actually map my device from that long path on the host to just /dev/ttyUSB0 in the home assistant container. For me, this has made the GSM integration have an easier time finding the modem. When you add the integration, when the path to device option comes up, you can just use /dev/ttyUSB0 (you’d have to change this if you have another device, like a zigbee stick, that conflicts)

@mwav3 thank you.
After several attempts I managed to get it working. I had to connect my usb modem via a usb y cable otherwise I had a lot of timeouts (I guess there wasn’t enough power). Now it happens very rarely (once, twice a day) but then it seems to work normally again.

I am having numerous problems getting these devices to work. I tried two USB devices (Huawei K3765 and ZTE K3565-Z) these are recognized and seem to work but after a few dozen minutes/an hour they become unavailable due to a timeout. At that point I have to restart the Home Assistant container to make them work again but after a while they stop again. I then bought a SIM800c (the model that is often discussed in this post). This seems to work better but most of the time it remains in the NoNetwork or RequestingNetwork state and only rarely switches to HomeNetwork, despite the fact that the signal percentage is almost always between 60% and 80% (with other devices it was lower, between 25% and 50%). Now I want to order a larger antenna but I’m not sure if this will correct the problem. Does anyone have any advice for me?

1 Like

Same issue here.

I moved the device from behind a piece of furniture to above it and since then (it’s been days now) the device is always in HomeNetwork and the signal percentage no longer fluctuates. I think it’s a reception problem. I want to order a long cable antenna and see if I can put the device behind the furniture and the antenna on top (it should work)