♾ Sensor Light Add On - Media & Movie Lights - House Alarm Lights - Smoke Alarm Lights & Exhaust Fans + More


Hi Kalen, sorry for the delay. This is a bug (can’t believe I missed this one :relieved:). I have fixed it and a new release will be out soon. Just testing everything again.

Once the new release 1.3 is out please update and let us know if it working for you.

Good news is now you know what to put in your;

  • On State = Playing
  • OFF State = OFF

If you would like the lights to go back and use the main sensor light automation when you pause then;

  • On State = Playing
  • OFF State = OFF & Paused

If you would like to use intermission option.

  • On State = Playing
  • OFF State = OFF
  • Intermission enabled and select Paused and set up your lights.

Thanks for your help.

PS: No it was not quotes.

Blacky :smiley:

New Update - Version 1.3

Bugs Fixes :bug:

  • Fixed major bug that stopped the automation from working if you didn’t add any entities in “Start Turn OFF Options” and “End Turn ON Options”. You would also get an error message like this;
Stopped because of unknown reason "null" at July 31, 2023 at 10:34:50 AM (runtime: 0.00 seconds)

If you like this blueprint? Consider hitting the :heart: button in the top post :+1:

If you like my blueprints, and would like to show your support or just say thank you? Click Here :smiling_face_with_three_hearts:


Blacky :grinning:



There are a couple ways to do this. Below is one example on how to update a blueprint. You can also find out more information on the Home Assistant official website if you prefer.

This is the official Home Assistant web site Using Automation Blueprints - Home Assistant

Example Below

1 - First most important, do a full backup of your Home Assistant, and store it in a location where you can get to it if you brick your Home Assistant (on a separate computer not running Home Assistant).

2 - To update a blueprint you must have a file editor. There are few to choose from. If you don’t have one already installed then this is how to add the official “File Editor” into your Home Assistant. Go to Settings / Add-ons and then click on “add-on store”. In the " Official add-ons" heading you will see “File Editor”, click on it and install it.

3 - In all my Blueprints, the official latest code is in the first post at the top. There is a link to my GitHub were you can find the code to copy. For this blueprint you will need to copy the code from GitHub.

  • Go to my GitHub link at the top of this post Click Here, in the code area there will be a “Raw” button. If you click on it you will then be able to easily copy the code without copping anything else.

4 - When you have copied the code, go into your file editor. At the top leftish there is a folder icon. If you click on it a navigation area is shown. Navigate to the file of the blueprint you would like to update. For this blueprint it should be in “blueprints/automation/Blackshome” and select “sensor-light-add-on.yaml” file.

5 - Once you select the file you should see the code of the blueprint displayed in the right section. At the top of all my blueprints it should say the name, in this case, “Sensor Light Add On” and you should also see the version you are on. This let’s you confirm that you are on the correct blueprint your about to update and not changing some other code that could brick you HA. Once confirmed, delete all the code and paste the new code you copied before in its place. You should now see the name again and the new version in the code at the top confirming your paste was successful and you are happy to proceed. When you pasted the code a red save button pops up and most importantly you will also see a green tick. If you don’t see this green tick, then stop, something is wrong, check the steps again until you see the green tick. If you see the green tick and you are happy with everything (again, a backup of HA) then and only then should you click save.

6 - Once saved you will need to reload the blueprint to reflect the changes before it will take affect. In the file editor you will see a cog wheel at the top right. When you click on it, select “Reload Automations”. A confirmation will pop up to confirm if your happy to proceed, click yes if your happy.

You have now updated a blueprint :tada:.

To check everything was done correctly, go into your automation and or the blueprint, you should see the new version displayed at the top confirming you are on the latest.


Blacky :smiley:

Back to FAQ: Click Here

The latest update appears to have fixed my issues. Thanks!

1 Like

Thanks for letting us know.

New Update - Version 1.4

New Features :new:

Added two new by-pass options.

  • Enable the By-pass - Turn automation ON
  • Enable the By-pass - Turn automation OFF

Bugs Fixes :bug:

  • Fixed bug if a switch was turn ON at the start of the automation.
  • Fixed an error when transition was disabled like shown below. This was probably when you are using zigbee2mqtt.
Transition value 0 is not valid.

If you like this blueprint? Consider hitting the :heart: button in the top post :+1:

If you like my blueprints, and would like to show your support or just say thank you? Click Here :smiling_face_with_three_hearts:


Blacky :grinning:


Thanks for the great blueprint! One smaller issue I’ve noticed in my setup: I’m using the sun condition, which initially works as expected, however when the sun sets while watching a movie, the lights aren’t turned on, only after changing the TV state the next time. Would be great if the lights get turned on when reaching the set sun elevation while the TV is on as well



Hi Jones

Thanks for the feedback. Yes I agree, and I better do the same for ambient. I will do an update for this :+1:

Blacky :smiley:

1 Like

New Update - Version 1.5

New Features :new:

Added two new features to sun and ambient options.

  • If the trigger is in an ON state, and the automation is blocked from running due to a sun or ambient condition, it will now turn ON when sun or ambient falls below its setting.
  • If the automation is running, when sun or ambient rises above its setting, it will now turn the automation OFF.

Bugs Fixes :bug:

  • Fixed bug in “Enable the By-pass - Turn automation OFF” for snapshots.
  • Fixed bug in “Enable the By-pass - Turn automation OFF” for intermission lights.

If you like this blueprint? Consider hitting the :heart: button in the top post :+1:

If you like my blueprints, and would like to show your support or just say thank you? Click Here :smiling_face_with_three_hearts:


Blacky :grinning:

1 Like

Is there a way to extend the turn off time past 30 min. ? I’ve got a bathroom situation where 30 min. Isn’t enough.


You can just simply type the number (time) you would like into the text box and click save :wink:

Another small point/suggestion: I’m using this alongside adaptive lighting. Overall this works fine, when the blueprint turns the lights on or adjusts them, adaptive lighting marks them as manually controlled. However on pause or at the end I’d like to go back to the lights being controlled by AL. The easiest way to do this would be to call a service provided by AL. While there are some workarounds to achieve this, I’d like to see this possibility directly in the blueprint. Basically besides activating lights or scenes calling any arbitrary service.


Will the " Intermission Option" work?

If you go back to the sensor light blueprint it should reactivate you AL.

Let me know if it is not doing this and I will have to install AL.

Blacky :smiley:

Hi, the when (intermission/end) work as expected. The only topic is what to do - I’m currently not using the sensor light bp in that room so can’t test that now but from my understanding of AL so far there are three ways to get a light back from manual control:

  1. Turning it off and back on (which might be a solution with the sensor bp but would cause at least a short flickering)
  2. Define a timeout for manual control. As the time until pause/end differ and are not known beforehand this isn’t a solution here.
  3. Calling the corresponding service

There might be other ways but I’m not yet that familiar with ALs internals. I was also thinking about using the snapshot functionality but I’m not entirely sure how AL would react on that and whether it’d reset manual control. I’ll try to dig deeper into other possibilities but unfortunately am a bit busy the next few days.


No problem thanks for keeping us posted and once you know more just let us know and I will take a look at it.

Hi @Blacky,

I’ve tried to check this a bit further and got closer to the solution I’d like but I’m not able to get it exactly to what I’d like.

In my current test scenario I have

  • Two lights that are controlled by a motion sensor, managed by the Sensor Light blueprint
  • A template binary sensor as trigger for this blueprint
  • Automation link is enabled
  • AL is enabled for both lights, handling with the main blueprint works as it should
  • A (home assistant) scene where both lights are set to a predefined brightness

This results in the following behaviour

  • Normal movement turns the lights on, brightness is set by AL
  • Turning the sensor on activates the scene, sets the brightness as expected and marks the lights as manually controlled in AL
  • Turning the sensor off turns the lights off until a new movement has been detected, after which the brightness is controlled again by AL

However this results in the lights to be off after this blueprint ends. Ideally I’d like to keep the lights on for at least a short time. I’ve tried to combine the automation link with the end turn off setting but this resulted in some weird off/on transition.

One idea I still have would be to misuse the automation link control:

  • Configure it in the Add On using one input but use a different input in the main blueprint
  • Add an automation that listens to the input of the automation link
  • If turned on, also turn on the second input => Turn off sensor light as would the automation link
  • If turned off, call the manual control service of AL, wait some time and then disable the second input => “Delay” the automation link

I’ll try to check whether that works over the weekend


I would like to test if this blueprint can replace an automation I made for my DIY alarm but I need an info first.

My alarmo (a great custom component) has the following statuses:

disarmed|The alarm is disabled/off.
arming|The alarm is arming.
armed_away|The alarm is armed in away mode.
armed_home|The alarm is armed in home mode.
armed_night|The alarm is armed in night mode.
armed_vacation|The alarm is armed in vacation mode.
armed_custom_bypass|The alarm is armed in custom mode.
pending|The alarm is pending.

In the automation I see for trigger on state just a generic on and playing. Is that generic on will work also with the alarm statuses like triggered?

Moreover can add a feature to be able to set non only color temperature but RGB colors? If it can be used with alarm system I think it should allow to turn light with a 100% RED status do you agree?

I will look into this more as I would like to have an input where you can put in anything you like (costume input) rather than trying to accommodate every integration.

Agree but there are a few ways to do this and not every RGB are the same. The best way to do this is to create a scene and set the colour temp then enter the scene in.

EDIT: This has been done… I will need to test it before I release an update.

1 Like


Regarding RGB ok. I just wonder if I have to create as many scenes for every light I have to include right?

I’m asking because I was thinking to use this blueprint to replace an automation that, based on room occupancy, save light status, change light to a default color (pink) and the restore previous details (status, brightness, color).

It doesn’t work 100% of the time, mainly because of my poor developer skills.

To restore to the previous details use the “Snapshot” option :wink:

I will see if I can get some time in the next 2 days to test it. Thanks for being patient