Set the Indicator Light on a Zooz ZEN32 Scene Controller button to Match the State of a Light

I have been looking for some assistance with this ZEN32 - for a long time. I hope that these Blueprints will give me what I want.

Thought I would share with the writers of said blueprints, I have discovered with the latest firmware for the ZEN32 - you get 3 more colors for the buttons. The latest FW adds Magenta, Yellow and Cyan to the color pool.

image

Just put a new 800 series model in my garage and saw that this doesn’t work with it. I put in a change to allow both the 700 and 800 series to work, will look into the additional colors in the firmware update

hi all,
new to HA and blueprint.
I quickly test ZEN32 (Z-Wave JS) to control lights and scenes. works. ill need to test with a door lock and a zen17, but I suspect it will work.

now I want the leds on the zen32 to match lights, scene, door lock and zen17 status. here are a few example:
_ if the door lock is lock, zen32 led to be green, unlock: red.
_ same with garage door: zen17 sensor status si open, zen32 button red, sensor closed: green
_ scene “basement” is
off (all basement lights off) zen32 button 1: white, button 2: off (button 1 been “basement off” and button 2 been “basement on”
on (all basement lights on) zen32 button 1: off, button 2: white
not or nor off: button 1 and 2 leds off.

I havent found a blueprint yet. anyone can help?
thanks

Anyone unable to disable an LED indicator light? I have a couple of the Scene Controller switches and I want the LED indicators on all five buttons to be always off. This works on one switch, but on another the relay indicator is always on, even when the setting is set to always off. Any ideas?

I have found that after setting the LED “state” in the ZEN32 configuration, I had to actually press the buttons to get the indicators to work as programmed in the configuration. Have you tried the buttons after setting the LEDS to always off?

The only solution I found to this was excluding the device, resetting it, and then re-adding it. Now I can set all the indicator lights to be always off.