Setup Frigate with HACS or as Addon?

Hey,

I have a Reolink 1212a cam and I want to setup frigate in ha. I read a doc about using HACS but after download frigate with HACS I cant add an integration as mentioned in the tutorials:

I found an other tutorial where I have to add frigate as a add-on (configuration → addon). So I installed Frigate (Full Access) as add-on and I get this:

But… the logs


My config


and I also tried

And the config of the 1212a:




I dont’t know if i setup frigate right, if something is missing and if the camera config is correct. Therefor it is hard for me to figure out, where the problem is. It also confuse me, that I can install frigate via hacs, integration and add-on.

1 Like

You seem to not learned the concepts of addon vs integration.

An integration is a piece of Python software that runs as part of Home Assistant and adds a feature to Home Assistant. This can be the code that enables HA to connect to a cloud service, connect to a Philips Hue bridge or something internal like calculating the angle of the sun.
Home Assistant comes with 100s of these. You can also add non-official integrations known as custom components. HACS adds the possibility to find and add custom components. The Frigate custom component in HACS enables you to download the component. Once downloaded and Home Assistant restarted you can add the Home Assistant integration like you add the builtin integrations.
The integration does not contain the Frigate software. It is code that can connect via network to a computer running Frigate. I run my Frigate on an old MacMini with Ubuntu.

An Addon in Home Assistant is a third party server software running in a Docker container on the same computer as Home Assistant. Commonly used addons are Mosquitto for MQTT, file editors, Zigbee2MQTT, Deconz etc. These programs run in their own isolated environment. Home Assistant connects to them via virtual Networks. All these addons are started, stopped, and managed by the Home Assistant Supervisor.

You can install the Frigate software as an Addon. Or you can install it on a different computer. Frigate is a CPU hungry program so if you run HA on a Raspberry Pi, it will struggle running Frigate also. Especially if you have no Google Coral TPU.

Home Assistant has a feature called Ingress which enables HA to show the graphical UI from inside the Addon.

I personally run all software outside Home Assistant and only use file editor Addons. I like to have more control of my 3rd party software.

So assuming you have a machine that runs HA and Frigate fine, you need to get the Frigate Addon working on its own first. In fact you do not want to install the Frigate integration until Frigate is fully working. If you did, remove it and focus on Frigate. Once that works you can install the integration and you will see it all working in HA. Note that HACS offers both the Frigate integration and a Frigate UI card. You want them both.

I cannot help with getting your camera working in Frigate.

16 Likes

@KennethLavrsen is perfectly correct. To summarise

Frigate - software to connect to cameras and create an nvr. Has a web interface UI.

Frigate addon - run frigate on your ha machine if it runs haos or supervised ha.

Frigate proxy addon - if you run frigate on another server get it’s UI on ha, with a side bar icon etc

Frigate integration - get frigate related sensors in ha, so you can turn a siren on when a cat crosses your driveway.

Frigate UI card - get a nice frigate interface in Lovelace. This is not the native frigate web UI.

14 Likes

Hey @KennethLavrsen and @nickrout thanks a lot. Now with the knowledge about addon and integration I focused on configuration frigate and it works now. Thanks a lot!

Actually I use HA in a vm but in the future I will setup a server with proxmox and the addons will be deployed separately. This will be a bigger change, but now I know that everythink will work and I will have the configurations.

1 Like

I.m running HA on a raspberry pi 3. I have :slight_smile:

Home Assistant 2023.5.2
Supervisor 2023.04.1
Operation System 10.1
Frontend-version : 20230503.3 - latest

I also want to install Frigate so this is what I did :slight_smile:

I installed the MQTT Broker first and config that (look like it is working)

Started HACS and added the Frigate Integration.
(There is no Frigate add-on available)

After that I tryed to install a deivce “Frigate”.
The Url it shows is “http://ccab4aaf-frigate:5000

Clickied save but got the error “Failed to connect”.

As a newbee I PANICED.

How can I install Frigate.

Please advise

That is incorrect: GitHub - blakeblackshear/frigate-hass-addons: Frigate hass.io addons

I did but when I want to add the Frigate device I get and Error “Failed to connect”.
What am I doing wrong ?

Please help

Is the addon started?

It is a HACS integration. Where do I start Frigate.

This is what I tried :

Paul, it’s an addon and an integration. The integration will not work without the addon.

You get the addon by adding the repository through the addon store.

This is the repository that you add
https://github.com/blakeblackshear/frigate-hass-addons

Then you configure and install the addon using the documentation in the repository.

Next, you add the integration via HACS and point it at the addon, following the directions in the integration installation.

2 Likes

Petro,
Thanks for the answer.
I installed the add-on and created the file frigate.yml. (Empty file).
But the add-on does not start.

Maybe this module / add-on is to hard for a newbe ?

You need to fully configure each camera in the yaml file. I suggest you read the directions for the addon.

1 Like

Well for frigate as a whole actually. It is very thorough.

1 Like

hi guys.
I have a big problem installing the addon.
here the error I get:

Can’t install ghcr.io/blakeblackshear/frigate:0.12.0: 404 Client Error for http+docker://localhost/v1.42/images/ghcr.io/blakeblackshear/frigate:0.12.0/json: Not Found (“No such image: ghcr.io/blakeblackshear/frigate:0.12.0”)

How can I solve?

Maybe Im just not smart enough, but I wish this message were added on these three links: Frigate Instalation, Home Assistant Integration page, Home assistant Addon page.

So simply and well described. Thank you very much for this explanation @KennethLavrsen , really appreciated!

There is the glossary you know Glossary - Home Assistant

Did you ever solve this? I get the same error now.

  1. Current is at least 13 not 12 so please copy and paste the exact error.

  2. Looks like a dns error.

It’s indeed not the same error, it’s an error 400:


I have other repositories added without issue.