Shelly Plus H&T(Humidity/Temperature) Unknown


I’m having issue with Shelly integration with this Shelly Plus H&T device that it shows Unknown all the time for all entities. Other devices that I have there was option to enable ColoT which works fine.

Any tips or should I move to MQTT?

I have two sensor one is with beta firmware: 0.12.0-beta1 and one with stable 0.11.4.
Home assistant version: Home Assistant 2022.11.2


Testing after configuring web socket for shelly H&T Plus, lets see if we get better results.
Added ws://homeassistantipaddress:8123/api/shelly/ws into Shelly H&T settings

@Beermaster90 did you find how to enable the CoIoT?

I completely removed those shelly H&T sensors from homeassistant shelly integration and updated sensors to beta firmware.
Enabled web sockets on both to hommeassistant(checked also from top right icon that it’s connected).

Then I added them from Integrations view as normally adding new device to integration and now it LOOKS like it’s working again as it should, I have no idea should this have any affect on it or not but it’s working.

EDIT: Just note that it took a while for them to show any values, patience is required.

Got it, thank you

I have an issue with H&T Plus too. I tried with both stable and beta versions, I connected the WebSocket, and it’s working, I added the integration in HA but I cannot see the device, nor the entities. I did reset it to factory defaults and tried again with the same outcome.
I am on Home Assistant 2022.11.2.
Any idea?

@alextct , have a look here

1 Like

I have 2022.11.2 should work completely normal as long as you are in same VLAN and have done the steps I did. No issues here from the solution of mine I tagged.

Hi all,

I have a Shelly Plus H&T, trying to it working following the instruction in the thread…

My Homeassistant details are as follows:
Version: HA 2022.11.4

Both devices are on the same VLAN

Shelly Plus H&T Configured as follows:
Firmware: 0.12.0-beta3
Outbound web socket ws://
Connection Type: Default TLS
Websocket = Enabled
Connection = Websocket disconnected

The Shelly Plus H&T appears in the integration, but with no devices or entities listed.

Screenshot 2022-11-27 at 14.34.51
Screenshot 2022-11-27 at 14.34.56

Anyone any ideas?

Any News or Ideas on this? I also can add the device to HA and it tells me it adds the integration, but there’s no device and no entities showing up like @solomalee also experienced.
Any help would be appreciated.

Update: found the solution here: Shelly Plus H&T no Entities since Update to 2022.11.0 - Third party integrations - Home Assistant Community (

Sorry for bumping this thread.